Quantcast Set affinity option does not show (in Vista)

Closed Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Notebook Consultant
    Join Date
    Jul 2007
    Posts
    100
    Rep Power
    18

    Default Set affinity option does not show (in Vista)

    Hello,

    I would like to assign both cores to a game (GTR2) , but for some reason the option "set affinity" does not show when I right click the process exe file in task manager.


    My laptop is a Clevo 570RU-U (same as Sager) with Intel Core2 Duo CPU T7700 2.4 GHz. The OS is Vista Home Premium 32bit with all updates installed.

    Since I could not see the option others can(?) I reinstalled Vista last night. Before I reinstalled Vista I tried making new accounts both with and without UAC to make the option "set affinity" visible with no success.

    However directly after the reinstallation of Vista I could see the option "set affinity"! Heureka!

    But after the Vista updates and some OEM driver installation (such as fingerprint reader) the option was gone again. Through all installation I have used the same and only account with admin rights. UAC is activated.

    How can I make the "set affinity" option visible? Why and what does Vista do to me and my rights? Am I not the admin even though there is only one account from the start? Could it be any of the updates or drivers fault? They are all from windows update or included from the OEM.
    Last edited by _GZ_; 18th February 2008 at 06:12 AM.

  2. #2
    Notebook Evangelist
    Join Date
    Oct 2007
    Location
    Australia
    Posts
    445
    Rep Power
    19

    Default Re: Set affinity option does not show (in Vista)

    Have you checked device manager to see if both cores show up? All processes have both cores assigned by default (In XP anyway) so there's nothing you can really do to boost performance other than close background applications.

    Grand Admiral
    DOWN WITH MICROSOFT!

    CFT005 (2nd Custom)
    Phenom II 955 BE 3.2GHz|4GB 1333MHz DDR3 Corsair RAM|2+1TB 7200RPM HDs|1GB HIS 4890 Turbo|XP Pro

    CFT004 (1st Custom) KIA

    CFT003 (HP Pavilion dv6519tx)
    Core 2 Duo T7100 1.8GHz|2GB 667MHz DDR2 RAM|160GB 5400RPM HD|128MB NVIDIA 8400M GS|XP Home

  3. #3
    Notebook Consultant
    Join Date
    Jul 2007
    Posts
    100
    Rep Power
    18

    Default Re: Set affinity option does not show (in Vista)

    Yes there are two cores in the device manager, or more exactly two rows with the same processor info.

    Intel Core2 Duo T7700 @ 2.4 GHz
    Intel Core2 Duo T7700 @ 2.4 GHz

    Well the mystery is that other people get the option "set affinity" and I myself finally got a brief moment of glory. But it is now missing again.

    Others that play GTR2 report a substantial gain in fps when assigning both cores manually. Why exactly I don't know, but it seems to work well.

  4. #4
    Notebook Guru
    Join Date
    Jan 2008
    Posts
    71
    Rep Power
    17

    Default Re: Set affinity option does not show (in Vista)

    Quote Originally Posted by _GZ_ View Post
    Others that play GTR2 report a substantial gain in fps when assigning both cores manually. Why exactly I don't know, but it seems to work well.
    But I don't understand how you can set them manually when both cores are already checked by default.

  5. #5
    Linux geek con rat flail!
    Join Date
    Jun 2006
    Location
    Denver, CO
    Posts
    7,105
    Rep Power
    52

    Default Re: Set affinity option does not show (in Vista)

    Others are blowing smoke. If the program can use multiple cores, Windows will schedule it. All programs are automatically assigned to be able to run on either core, which is what you're trying to have happen. You can only limit the process to a single core, not assign it to both. Basically, you never want to try to manually assign an application to a core. Windows knows better than you do how to balance the load.
    HP Envy 15 | Win7x64 | i5-540M | Radeon 5830 1GB | 6GB DDR3-1066 | 256GB Crucial M225 SSD | Matte 15.6" 1920x1080
    Get your answers here!
    Answers: $5
    Good Answers: $10
    Correct Answers: $20
    Well-researched Answers complete with reference: time and materials
    Dumb looks are still free

    __________________

  6. #6
    Notebook Consultant
    Join Date
    Jul 2007
    Posts
    100
    Rep Power
    18

    Default Re: Set affinity option does not show (in Vista)

    Quote Originally Posted by Pitabred View Post
    Others are blowing smoke. If the program can use multiple cores, Windows will schedule it. All programs are automatically assigned to be able to run on either core, which is what you're trying to have happen. You can only limit the process to a single core, not assign it to both. Basically, you never want to try to manually assign an application to a core. Windows knows better than you do how to balance the load.
    Fair enough...I don't have first person knowledge about this.

    But I will lay sleepless for weeks if I don't know why Vista disqualifies me from seeing what others can see. I have only had Vista for a couple of days and don't like the way it is acting regarding this issue. Is there more stuff hiding from me? Yes probably.

    And I did see the option for a brief period, until I automatically installed windows updates and OEM drivers. What happened? What did Vista do with my rights? Or was it something else?

    I had a suggestion that it could be the finger print reader software, anyone know about this? I removed it and nothing seemed to change about "set affinity".

  7. #7
    Notebook Evangelist
    Join Date
    Oct 2007
    Location
    Australia
    Posts
    445
    Rep Power
    19

    Default Re: Set affinity option does not show (in Vista)

    I doubt it was the fingerprint reader, if it were to be anything it would more likely be the chipset or processor driver (As far as I know intel doesn't have a special processor driver, only AMD). I wouldn't stress too much about this option, I use it often but never to boost performance, only to isolate programs which chew processor (like DVD Shrink) so I can keep working without my system locking up.

    Grand Admiral
    DOWN WITH MICROSOFT!

    CFT005 (2nd Custom)
    Phenom II 955 BE 3.2GHz|4GB 1333MHz DDR3 Corsair RAM|2+1TB 7200RPM HDs|1GB HIS 4890 Turbo|XP Pro

    CFT004 (1st Custom) KIA

    CFT003 (HP Pavilion dv6519tx)
    Core 2 Duo T7100 1.8GHz|2GB 667MHz DDR2 RAM|160GB 5400RPM HD|128MB NVIDIA 8400M GS|XP Home

  8. #8
    Banned
    Join Date
    Dec 2007
    Location
    Dubai
    Posts
    1,906
    Rep Power
    0

    Default Re: Set affinity option does not show (in Vista)

    Quote Originally Posted by brain3 View Post
    But I don't understand how you can set them manually when both cores are already checked by default.


    true that :!!

  9. #9
    Notebook Consultant
    Join Date
    Jul 2007
    Posts
    100
    Rep Power
    18

    Default Re: Set affinity option does not show (in Vista)

    Problem solved.

    I reinstalled Vista (again), third time is the charm. Now I have the option "set affinity" like others.

    I am not sure what went wrong the first two times? The computer store installed Vista the first time and I did the second attempt. The one thing I did different this time was more restarts between driver installations, even though they seemed to have nothing in common.

  10. #10
    Comrade Santa
    Join Date
    Jul 2006
    Location
    Denmark
    Posts
    3,468
    Rep Power
    36

    Default Re: Set affinity option does not show (in Vista)

    Glad you got it figured out. And as Pita said, you should never set affinity unless you have to. Its purpose is to fix apps that *can't* handle being run on multiple cores. (To keep them from crashing, or other bad behavior)
    For best performance, you should leave it alone and let Windows schedule the app.

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -4. The time now is 05:10 PM.
Powered by vBulletin® Version 4.2.2
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO 3.6.1