Yoga C940 Inconsistent WiFi Speeds

Discussion in 'Lenovo' started by Mickeylittle777, Nov 30, 2019.

  1. Mickeylittle777

    Mickeylittle777 Newbie

    Reputations:
    0
    Messages:
    8
    Likes Received:
    2
    Trophy Points:
    6
    I have the i7 with 12 GB ram and not the 4K model. I have Windstream internet service at 200 mb per second and on my iPad Pro I consistently get around 35 to 85 MB download range, depending on where I am in my house. But on my Yoga C940 I get from 105 MB all the way down to 6 MB and there is no apparent reason as even when it is low the iPad is still doing fine.

    I have all the windows updates and have even gone to Device Manager, Network Adapters, Intel WiFi 6 AX201 160MhZ and updated the driver but to no avail.

    Any ideas?

    There is absolutely no other issue this laptop has, it's that freaking good :)
     
  2. Mickeylittle777

    Mickeylittle777 Newbie

    Reputations:
    0
    Messages:
    8
    Likes Received:
    2
    Trophy Points:
    6
    This is so frustrating. I just rebooted and went from 5 Mbps to 103 Mbps.
     
  3. senso

    senso Notebook Deity

    Reputations:
    291
    Messages:
    905
    Likes Received:
    279
    Trophy Points:
    76
    What is your router?
     
  4. Mickeylittle777

    Mickeylittle777 Newbie

    Reputations:
    0
    Messages:
    8
    Likes Received:
    2
    Trophy Points:
    6
    I have a Windstream Wi-Fi Modem T3200. It has the smaller phoneline that comes into the DSL port on the back. I hate that but all that's available here. We have the fastest speed available up to 200 Mbps download and my wired PC consistently gets 110 Mbps download and 40-50 Mbps upload speeds.
     
  5. Atma

    Atma Notebook Deity

    Reputations:
    221
    Messages:
    811
    Likes Received:
    982
    Trophy Points:
    106
    Have you tried updating drivers? I was getting about 10x slower download than normal. I just updated the wifi 6 driver through device manager and it's normal now.
     
  6. Mickeylittle777

    Mickeylittle777 Newbie

    Reputations:
    0
    Messages:
    8
    Likes Received:
    2
    Trophy Points:
    6
    Please see the original post as I state that I went to Device Manager and updated the wifi 6 driver but it didn't help. But thanks anyway.
     
    Atma likes this.
  7. Atma

    Atma Notebook Deity

    Reputations:
    221
    Messages:
    811
    Likes Received:
    982
    Trophy Points:
    106
    ah .. totally missed that.
     
  8. Mickeylittle777

    Mickeylittle777 Newbie

    Reputations:
    0
    Messages:
    8
    Likes Received:
    2
    Trophy Points:
    6
    No problem. I did make a change to our network and it has helped. I removed the Google - Google Wifi AC1200 Dual-Band Mesh Wi-Fi Router from the network that I was using to push the signal out further into our house and I've noticed the signal is just as good without it. Also noticed my C940 now varies in a tighter range. So the download speed never drops below 20 MPS which is a lot better than before when it was dropping down to 6 MPS. I can live with this but hopefully someone will provide fiber internet for us in the near future and the problem will be solved.

    Thanks everyone. If there is a way to mark a thread solved we can do that here.
     
    Atma likes this.
Loading...

Share This Page