XPS 9550 Keyboard issue / Killer 1535 info

Discussion in 'Dell XPS and Studio XPS' started by smilie121, Sep 9, 2017.

  1. smilie121

    smilie121 Notebook Enthusiast

    Reputations:
    0
    Messages:
    24
    Likes Received:
    3
    Trophy Points:
    6
    I recently bought a 4k 9550 and I have an issue where sometimes when the machine starts, the keyboard does not work. Touch screen, touchpad or wireless mouse are all fine. If I reboot the keyboard will return. I have played around with lots of settings and feeling lost (probably with the other faults its had).

    The laptop has a killer 1535 which disconnects all the time, causing the mouse become erractic. But can cause the machine to freeze altogether. But only when on battery. If on mains i have had it on for several hours, leaving it download when not in use and not one hiccup. So until my DW1830 arrives I use the laptop tethered to the mains.
     
  2. Danishblunt

    Danishblunt Notebook Deity

    Reputations:
    81
    Messages:
    1,009
    Likes Received:
    350
    Trophy Points:
    101
    After some reading, I figured out that for some reason apparently a BIOS update fixes loads of bugs.

    After some more reading:
    Your system has some major power management issues without a BIOS udpdate.
     
  3. smilie121

    smilie121 Notebook Enthusiast

    Reputations:
    0
    Messages:
    24
    Likes Received:
    3
    Trophy Points:
    6
    Latest bios installed ( 1.3 ) as is most drivers - intel RST not installed as using a samsung 961 512gb.

    Though when on Bios 1.29 i did a OS reload as i changed the SSD and didnt note any keyboard issues. I may roll back just to see.

    Keyboard issue is only on a cold boot. Most of the time keyboard not working. Reset via start bar guarrantees the keyboard will return. Power off and on and its the gamble it will be there or not. Have tried removing and reinstalling via device manager.
     
  4. Danishblunt

    Danishblunt Notebook Deity

    Reputations:
    81
    Messages:
    1,009
    Likes Received:
    350
    Trophy Points:
    101
    The notebook seems noitorious for being full of bugs, maybe you should give dell a call. I almost think this is a Bios/EC issue. You ould try and make a clean install on the notebook and see if anything happens. You could also try and delete the keyboard in the device manager and then restart the system so it installs it again, maybe it could fix it.
     
  5. smilie121

    smilie121 Notebook Enthusiast

    Reputations:
    0
    Messages:
    24
    Likes Received:
    3
    Trophy Points:
    6
    Already tried the device manager on a number of ways. Before changing my ssd to the samsung 961 i never noticed any keyboard issues. However i did a bios update and then a fresh install of Win10pro. Wasnt till i did a bunch of updates (and turned off the privacy concerns) did i notice it on a reboot.

    Hoping my wifi card arrives Monday as i will be making it into a hackintosh. Did it on my XPS L702x with modified bios and was one of the factors of choosing the 9550
     
  6. Killer_Networking

    Killer_Networking Company Representative

    Reputations:
    37
    Messages:
    25
    Likes Received:
    60
    Trophy Points:
    16
    One thing that we have noticed is that sometimes this platform will have disconnects due to the default power plan settings, especially when on battery compared to when plugged in. For the details,
    you can read about that here - https://support.microsoft.com/en-us...ctivity-issues-or-performance-issues-when-you - but, to summarize, the default power plan is not ideal for Wi-Fi, and Microsoft's suggestion is to maximize power going to the Wi-Fi adapter and remove the ability for Windows to turn the adapter off to save power. The effect on battery performance seems to be negligible.

    To check your power settings:

    1. Right click Start
    2. Click “Power Options”
    3. Click “Change Plan Options” on currently selected power plan
    4. Click “Change Advanced Power Settings."
    5. Click “Wireless Adapter Settings”
    6. Under “Power Saving Mode” change “Setting” to “Maximum Performance” on both “On battery” and “Plugged in"
    7. Click "Okay" then "Save Changes".
    8. Right-click your Start Button and click "Device Manager"
    9. Find the "Network Adapters" heading and double-click it.
    10. Find your Killer Wireless Adapter and double-click it.
    11. Click the "Power Management" tab.
    12. Make sure the box for "Allow the computer to turn off this device to save power" is not checked.
    13. Click "OK"
    If you are missing any of these options, then that means your machine's manufacturer has disabled them in the registry. Many of our users have had luck using the method described here - https://www.eightforums.com/tutorials/54127-power-options-add-remove-wireless-adapter-settings.html - to re-enable those options, so that they can adjust their power settings appropriately. The fix claims to be for Windows 8.1, but it works the same with Windows 10. If you don't want to make the registry change yourself, and are uncomfortable using a registry file downloaded from this site, you can contact us at killersupport@rivetnetworks.com. I can send you a copy that I keep on my own disk that I can verify works for this purpose and has not been tampered with.

    Once you have acquired the registry file and run it, you will need to start back at step 1 to change the settings. You should now have access to them all. Once you are able to make these power setting changes, this will very likely solve the issue of the disconnects, but not necessarily the mouse malfunctions, which probably aren't related to the 1535. However, if you have any other Killer-related issues, or just have questions, feel free to reach out to us at killersupport@rivetnetworks.com any time, and just reference this conversation, if you like.

    --Anthony with Killer Support
     
    Vasudev likes this.
  7. Vasudev

    Vasudev Notebook Virtuoso

    Reputations:
    767
    Messages:
    3,270
    Likes Received:
    1,550
    Trophy Points:
    231
    You can try these tweaks on killer Killer vs. Intel network cards performance
    Never enable power saving on killer cards on windows or linux. They go nuts, but even w/o power saving it consumes less power than intel and has more range than intel cards.
     
  8. smilie121

    smilie121 Notebook Enthusiast

    Reputations:
    0
    Messages:
    24
    Likes Received:
    3
    Trophy Points:
    6
    I had already tried the power settings as described above in combination to various driver releases from Dell and direct from the manutacturer. I am pleased to say that now i have installed the 1830 and not a single issue wifi or bluetooth since. Keyboard issue remains but not as bad as it was before rolling back the BIOS.

    However it upgraded to creators edition the other day and has gone to the freezing issue many have reported in other 9550 threads. Rolled back and the issue remains. So gonna have fun with this now.
     
Loading...

Share This Page