XPS 9550 + 4K panel screen flicker thread.

Discussion in 'Dell XPS and Studio XPS' started by GoNz0, Aug 24, 2016.

?

4K screen flicker

  1. Yes Bios A10 (This may be a very slight flicker but still happens)

    17.4%
  2. Yes Bios A11 (probably unbearable)

    15.2%
  3. Yes Bios A12 (Still there and enough to piss you off within 5 minutes)

    54.3%
  4. No Bios A10

    10.9%
  5. No Bios A11

    4.3%
  6. No BIOS A12

    6.5%
  7. Yes Bios A06 (1.2.0)

    6.5%
  8. No Bios A06 (1.2.0)

    26.1%
  9. Yes A16 1.2.18

    0 vote(s)
    0.0%
  10. No A16 1.2.18

    23.9%
Multiple votes are allowed.
  1. GoNz0

    GoNz0 Laptop Engineer & Online games hosting.

    Reputations:
    139
    Messages:
    2,694
    Likes Received:
    841
    Trophy Points:
    131
    Let's get a list of who has the 4k panel & screen flicker at any brightness setting so I can present this to Dell the next time I call and they tell me they have never heard of this problem before (the default response)
    If you have the FHD (1080) panel please don't reply as the initial fix seemed to be aimed at the FHD customers that in turn broke our 4k panels.
    Dell may need to split the BIOS into 2 to fix specific panel types so we need to get a case going.

    Please list the BIOS versions you tried, personally the A10 BIOS seems best for me and the latest official Dell intel driver.

    so for me I live between 17-25% screen brightness indoors where I spend 99% of my time on the laptop.
    • A10 works best, I have had to roll back to this.
    • A11 causes a near constant flickering
    • A12 is a little better but still at least 3 per minute
    If you want to try older BIOS versions they are here http://downloads.dell.com/published/pages/xps-15-9550-laptop.html use Ctrl + F then search for BIOS.
     
    nosauce, Arondight and PhilTheHill like this.
  2. lalalulu57

    lalalulu57 Notebook Enthusiast

    Reputations:
    0
    Messages:
    25
    Likes Received:
    3
    Trophy Points:
    6
    I also have the screen flicker since A12 i think.... they released a new bios today Dell XPS 15 9550 1.2.13 A12 System BIOS, did you already try out this one?
     
  3. GoNz0

    GoNz0 Laptop Engineer & Online games hosting.

    Reputations:
    139
    Messages:
    2,694
    Likes Received:
    841
    Trophy Points:
    131
     
    MiRage11 likes this.
  4. Chang_loo

    Chang_loo Notebook Enthusiast

    Reputations:
    2
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    15
    I had to roll back to BIOS version 1.1.19! Version 1.2.10 caused flickering as well on my 4k panel.

    The version 1.2.13 contains an update of the intel ME which can't be downgraded by flashing version 1.1.19. So be aware! By now I have not recognized anything bad from the latest update of the intel management engine.
     
  5. GoNz0

    GoNz0 Laptop Engineer & Online games hosting.

    Reputations:
    139
    Messages:
    2,694
    Likes Received:
    841
    Trophy Points:
    131
    Yes the IME update seems fine and I took the opportunity to flash the Thunderbolt while the BIOS was upgraded. 1.2.0 is as stable as 1.1.19 (not to be confused with 1.2.10)
     
  6. Chang_loo

    Chang_loo Notebook Enthusiast

    Reputations:
    2
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    15
    Thanks GoNzo. Just reflashed to 1.2.0 !
     
  7. TDO

    TDO Notebook Consultant

    Reputations:
    10
    Messages:
    170
    Likes Received:
    18
    Trophy Points:
    31
    I use A10 at 140cd/m² after calibration which is around 40% screen brightness.
    Haven't noticed any flicker.
    But I can give A12 a try and report when I am back from work.

    I have A12 running now for 1h. Haven't noticed any flickering yet.
     
    Last edited: Aug 24, 2016
  8. MiRage11

    MiRage11 Newbie

    Reputations:
    2
    Messages:
    3
    Likes Received:
    2
    Trophy Points:
    6
    Have you tested it without it being plugged in? A12 was fine for me until I unplugged it.
     
  9. TDO

    TDO Notebook Consultant

    Reputations:
    10
    Messages:
    170
    Likes Received:
    18
    Trophy Points:
    31
    Ah, I am using it 99% of the time plugged in.
    I will test it on battery in the evening.
     
  10. salada2k

    salada2k Notebook Consultant

    Reputations:
    148
    Messages:
    181
    Likes Received:
    9
    Trophy Points:
    31
    Urgh, A12 made my TB15 dock work, (wow!) but yep, screen flicker is back and driving me BONKERS again. I guess you just cant have it all.

    P.s. I'm plugged in to power delivered by Thunderbolt cable from a TB15 dock, and this problem happens only when screen brightness is 40% or below. I have not tested running off just battery. Huh, just as typed that at 50% brightness I got a flicker. Damn.

    EDIT: Happening at 60% as well. Seems to be getting worse?

    EDIT 2: Happening at 70%, perhaps less frequent, but still there.

    EDIT 3: Man, my eyes are burning up at 70%
     
    Last edited: Aug 25, 2016
    Bommel87 likes this.
Loading...

Share This Page