XPS 15 (Haswell) Owner's Lounge

Discussion in 'Dell XPS and Studio XPS' started by mark_pozzi, Oct 23, 2013.

  1. GoNz0

    GoNz0 Notebook Prophet

    Reputations:
    254
    Messages:
    4,063
    Likes Received:
    1,391
    Trophy Points:
    231
    yep that song sounds crap with maxxaudio enabled, turn maxx off and it sounds fine.

    funny thing is if I plugin my bose QC3 it sounds fantastic, laptop speakers for you I guess vs expensive cans with a dsp chip.

    windows mobility center for the fn keys m8.

    3D mark, that really is nothing, keep taking the test, I put money on you NEVER repeating the same score.
     
  2. jphughan

    jphughan Notebook Deity

    Reputations:
    352
    Messages:
    1,696
    Likes Received:
    347
    Trophy Points:
    101
    Fn keys are solved either in Windows Mobility Center I(with Dell Quickset installed), the BIOS, or just pressing Fn+ESC. Take your pick. :)

    Given that you just had a motherboard replacement, if you have a QHD+ panel and Dell Quickset installed, you might find that Splendid Mode is no longer listed in Mobility Center, and it's probably been automatically re-enabled. If that's the case, you should be able to fix it by going into the BIOS, disabling Secure Boot (which will enable Legacy Option ROMs automatically), and booting once in this configuration. Splendid mode should now be back in Mobility Center. If so, you should be able to switch those settings back in the BIOS and continue to have access to the splendid mode setting.
     
  3. 227

    227 Notebook Consultant

    Reputations:
    38
    Messages:
    126
    Likes Received:
    4
    Trophy Points:
    31
    Thanks! I see - I can't seem to find maxxaudio -> I assume it's a program that I need to download? Regarding 3d mark - yeah :) I just used to get closer to 3k with multiple re-runs, but I guess that's fine - the difference in performance will not be noticeable.

    Thanks! The Fn+Esc fixed it :). And the Splendid mode actually worked fine without any additional setting (though it was disabled originally).
     
  4. someguy00

    someguy00 Notebook Consultant

    Reputations:
    14
    Messages:
    110
    Likes Received:
    2
    Trophy Points:
    31
    There is a setting in the BIOS to set your preference for the Fn keys. I think that you get into the bios by pressing F2 when the laptop starts up (I forget).
     
  5. jphughan

    jphughan Notebook Deity

    Reputations:
    352
    Messages:
    1,696
    Likes Received:
    347
    Trophy Points:
    101
    MaxxAudio settings are controlled in the Dell Audio app, which is installed when you install your audio drivers.

    You misunderstood about splendid mode. That's something you actually want to disable. It grossly oversaturates colors; generic mode is far more accurate. But some people after getting motherboard replacements have noticed that splendid mode is enabled (even if they previously disabled it) AND the Mobility Center toggle to disable it again has been removed. If you see it, I would strongly recommend switching to generic mode. :thumbsup:
     
  6. 227

    227 Notebook Consultant

    Reputations:
    38
    Messages:
    126
    Likes Received:
    4
    Trophy Points:
    31
    Thanks - figured it was audio app :). You are right - the background is now clean, but I have noticed that the speakers are not as loud. I guess its a trade-off. Do you use it by default?

    Haha, I actually liked the saturated colors - I was comparing this to the Razer and liked the vivid colors better on the XPS. I guess its just a matter of preference. Though for video editing I would probably turn it off.

    On a different note. I have noticed a lot of stuttering during the battery saving mode - so much so that I always switch to balanced. I guess it might set some limitations on the CPU - but this seems rather drastic difference. Any ideas - or do I just want too much? :)
     
  7. willmb

    willmb Notebook Enthusiast

    Reputations:
    0
    Messages:
    17
    Likes Received:
    1
    Trophy Points:
    6
    New BIOS A05.
     
  8. benbegg

    benbegg Notebook Enthusiast

    Reputations:
    0
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    5
    Do you think the new BIOS A05 might solve the whining problem? Mine only whines when under load , 100% charged and plugged in. As I run the laptop in the bedroom on the table and it is always plugged in..whenever the machine undertakes updates during the night the whining starts. Most annoying.

    On another matter, I am thinking of getting the Win 8.1 Professional. Dell charge well over $100 for the upgrade but there are some retailers that have it on sale at times for like $80. Can I purchase this sort of upgrade or do I have to use the Dell one? Is it just a matter of entering a new Serial Number to upgrade Win 8.1 to Win 8.1 Pro?
     
  9. adlerhn

    adlerhn Notebook Consultant

    Reputations:
    24
    Messages:
    273
    Likes Received:
    26
    Trophy Points:
    41
    From Driver Details | Dell US:

    I wouldn't keep my hopes high on the coil whine...
     
  10. GNUDell

    GNUDell Notebook Enthusiast

    Reputations:
    0
    Messages:
    46
    Likes Received:
    12
    Trophy Points:
    16
    The A05 bios flashed fine.

    For me it doesn't fix or alter in any way the coil whine! :(

    Still the same from loudness and situations of occurrence.

    I checked quickly the c-states: still not possible to restrict sleep states to for example c3 (helped with haswell coil whine on some thinkpad models).

    I can not see any change from the new bios to any point at the moment. But I will see later (for example had some wired issues with some usb devices on the left usb ports, often had to use the right ones for e.g. connecting safely to an android device)..
     
    adlerhn likes this.
Loading...

Share This Page