XPS 15 9570 Owners Thread

Discussion in 'Dell XPS and Studio XPS' started by el3ctronics, May 16, 2018.

  1. SDeP58

    SDeP58 Notebook Evangelist

    Reputations:
    69
    Messages:
    416
    Likes Received:
    113
    Trophy Points:
    56
  2. _sem_

    _sem_ Notebook Deity

    Reputations:
    90
    Messages:
    756
    Likes Received:
    258
    Trophy Points:
    76
  3. annabel_shanderin

    annabel_shanderin Notebook Geek

    Reputations:
    14
    Messages:
    82
    Likes Received:
    43
    Trophy Points:
    26
  4. idark77

    idark77 Notebook Enthusiast

    Reputations:
    2
    Messages:
    35
    Likes Received:
    48
    Trophy Points:
    26
    Can you try to update the firmware with anything (TB3 device or accessory ) connected to Thunderbolt 3 port ?
     
  5. annabel_shanderin

    annabel_shanderin Notebook Geek

    Reputations:
    14
    Messages:
    82
    Likes Received:
    43
    Trophy Points:
    26
    Maybe that was the trick needed. But to be honest, I also removed the driver and installed it again before trying with something connected, so that could also be what jiggled it into place. But thanks anyway!
     
  6. improwise

    improwise Notebook Deity

    Reputations:
    60
    Messages:
    1,508
    Likes Received:
    425
    Trophy Points:
    101
    Only me that has started to experience some problems like BT mouse stuttering etc after upgrading to the latest BIOS which supposedly fixed DPC problems? Since Windows also installed quite a few updates recently, its hard to know what is to blame for what.
     
    Papusan and pressing like this.
  7. maffle

    maffle Notebook Evangelist

    Reputations:
    95
    Messages:
    415
    Likes Received:
    344
    Trophy Points:
    76
    Weird concidence, but I experienced kinda the same over the last week, after Windows updates, I had the feeling that the mouse DPI changed, it felt different and somehow slower and laggy and not smooth anymore. I was thinking I just imagined it, until reading your comment.
     
  8. splus

    splus Notebook Consultant

    Reputations:
    8
    Messages:
    163
    Likes Received:
    70
    Trophy Points:
    41
    I also experience mouse choppiness (just a few times though) in the last few days... It isn't laggy, but it looks like the mouse freezes for a few tenths of a second, and then responds normally. I don't see the system getting frozen, just the mouse.
    I updated to the new BIOS some days ago, but I'm not sure if it's that or some Windows update. I use Logitech USB receiver for the mouse, I haven't tried to connect it with the bluetooth.
     
    maffle likes this.
  9. maffle

    maffle Notebook Evangelist

    Reputations:
    95
    Messages:
    415
    Likes Received:
    344
    Trophy Points:
    76
    @splus Same. I use a MX 2s with Logitech dongle. Mouse feels different somehow since some Windows updates...
     
  10. splus

    splus Notebook Consultant

    Reputations:
    8
    Messages:
    163
    Likes Received:
    70
    Trophy Points:
    41
    I've actually had those few glitches only when the laptop was doing something CPU intensive, but not during the lighter use. But still, it never happened before...

    @maffle Me too, the MX Master 2S, the best mouse eva! ;)
     
    Last edited: May 15, 2019
    maffle likes this.
Loading...

Share This Page