XPS 15 9570 Owners Thread

Discussion in 'Dell XPS and Studio XPS' started by el3ctronics, May 16, 2018.

  1. vCanalla

    vCanalla Notebook Enthusiast

    Reputations:
    0
    Messages:
    47
    Likes Received:
    4
    Trophy Points:
    16
    I reached out to dell and they effectively told me that the sleep issues are Window's problem (which is probably true). Doing some google searches, it does seem even Surface's are not a stranger to this issue.

    Also, since the new bios, i've hard a weird issue where when I start a game up, like WoW, it takes about a minute for the system to kick into high gear and use faster clocks. Anyone have this issue or have suggestions?
     
    alaskajoel likes this.
  2. maffle

    maffle Notebook Evangelist

    Reputations:
    137
    Messages:
    484
    Likes Received:
    421
    Trophy Points:
    76
    The problem IS MODERN STANDBY...

    ^

    I have an interesting information to share though on this. I bought a Samsung 970 EVO to replace my SKH. So I also did a clean Windows install. I wanted to try to debug step by step, if maybe some driver causes the c state bug with S3. So I installed Windows, and installed no drivers but chipset and GPU and then deactivated modern standby via registry and monitored c states with TS... and the resulting is the following:

    After a fresh Windows 10 install with just chipset drivers, thermal drivers and GPU... S3 works normally, no c state bug. S3 works beautiful, c states work normally after wake up. I was totally happy and began to reinstall all other drivers, always monitored c states again after each reboot and did a S3 sleep... all working, no c2 stuck bug. I began to think this may be resolved. Then 2 hours later... I checked again, and now it is broken again and won't work anymore, whatever I do. C would be stuck in C2 after S3.

    I have no idea why. Something changed in that 3 hours and I have no idea what and why it could cause this. I just changed from local account to MS account. I have some suspicion that Windows 10 installed a bunch of drivers over Windows update in that 3 hours of idle time because I see that in the Windows logs, even I deactivated automatic driver install via OOSU as one of the first things before Wifi driver install... which seems to be ignored, which is just COOOL. Totally COOL. I googled about it and even if you deactivate auto driver update, Windows 10 still will do it for most drivers (except GPU, network, and some more, but "important" drivers it will just update regardless of deactivating driver update), so you cant prevent that. And it seems something it installed in the background is causing the c state bug.

    If anyone want to help to figure out, what the culprit is of the bug, I would be glad about it. Maybe someone here wanted to do a fresh Windows 10 install anyway and can help to debug step by step which could lead to the broken state.

    Because... S3 worked perfectly after deactivating modern standby via registry in the first 2 hours of fresh Windows install. THIS is why I hate Windows 10 so much. Because of COUNTLESS of tiny little bugs like this, the normal user has no idea about, which just lurk in the system.

    I am sure the issue was not triggered by a normal Windows 10 update because I did that, and checked after reboot, c states worked still. It must be something else Windows 10 did afterward.

    The Intel Audio Service wasnt also crashing in the beginning, Windows 10 installed a driver through store which then caused it.

    The stuck at Dell logo also randomly happens now again :)

    I will try another Windows 10 install and wont install Wifi drivers, so it cant do Windows Upates, install all Dell drivers and then look if c state works or not, so it must be some Windows update / driver through Windows update causing it.
     
    Last edited: Aug 22, 2018
    alaskajoel, improwise and splus like this.
  3. splus

    splus Notebook Consultant

    Reputations:
    8
    Messages:
    170
    Likes Received:
    80
    Trophy Points:
    41
    Maybe Windows needs few hours to settle in and enable some hidden internal setting that messes up the S3?
    Could you try to make a longer pauses between driver updates, like a day after each driver update, and see if the sleep still works? That should give the sufficient time to know if any of those driver updates messes up the sleep...
    Or even not install ANY driver (but give it wifi) and see if the sleep will get messed up within a day...

    Is it possible to enforce the S3 sleep via registry only with the old BIOS 1.2.2 or also with the new BIOS 1.3.0 that disabled the S3?
     
  4. maffle

    maffle Notebook Evangelist

    Reputations:
    137
    Messages:
    484
    Likes Received:
    421
    Trophy Points:
    76
    Ok I did another Windows install... and I was able to identify the cause of the c state bug. Well, kinda. In other words, I found a workaround how to prevent it and indirectly the cause of it. It seems to be a Windows bug, but mostly also in combination with Dell bios bug, because, I dont see any reports of this on the web with other laptops. I dont have another laptop to test this though, which uses modern standby. Maybe someone with a 2018 model can test this, if it is a general Windows 10 bug, or a Dell XPS 15 bios bug.

    Anyway... the cause of the c state bug is: Pure S3 (suspend to RAM). I found by luck, that if you disable (or let Windows disable it) hybrid sleep, then the c state bug will happen. If you keep hybrid sleep enabled, it wont happen and WILL work normally. What is hybrid sleep? It is basically a mix of S3 and hibernate. So you willl basically have S3 (fast wakeup), but Windows will also write "some" data (not clear out of MS docs what data, it doesnt seem to be the whole RAM) to disk as a "backup" if S3 fails (battery empty or power cut).

    This is totally weird though, because, S3 is still functioning normally. I have no idea why a "pure S3" triggers the c state bug and the hybrid sleep not. Maybe in hybrid sleep, Windows writes the kernel memory to disk and loads it then every time when waking up meaning it "restarts" the CPU maybe, and this prevents this c state bug.

    So... if you let hybrid sleep enabled... you will have WORKING s3, no c state bug, fast wakeups, safe sleep, little drain, laptop totally off during sleep. The only "disadvantage" now is, that you will have a bit of write to your SSD everytime you put it to sleep. If a normal SSD has a lifetime of maybe around 500TB write, thats mostly negligible.

    So how to get this?
    1. Start the registry editor (regedit.exe).
    2. Move to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power.
    3. Double-click CsEnabled and set to 0, then click OK.
    Reboot and done. Modern standby is now deactivated, Windows 10 will use S3 if you put it to sleep. You have to check if hybrid sleep is enabled for battery and AC under energy settings, otherwise, it will trigger the c state bug after waking up. This works regardless of the bios update to 1.3.x. You don't need to reinstall Windows. You should select the Windows balanced energy profile though, not the Dell one if you have one.

    You will need to change CsEnabled to 0 after every major Windows update, that are the creators/fall/spring updates happening 1-2 times per year, because the registry is set to default by that.
     
  5. Woodking

    Woodking Notebook Evangelist

    Reputations:
    70
    Messages:
    438
    Likes Received:
    246
    Trophy Points:
    76
    I couldn't see what size 970 Evo you installed from your posts, but here's the spec from Samsung that shows the TBW per drive.

    How much is written each time you put the machine to sleep, roughly?

    * TBW: Terabytes Written
    * Warrantied TBW for 970 EVO: 150 TBW for 250GB model, 300 TBW for 500GB model, 600 TBW for 1TB model, 1,200 TBW for 2TB model.
     
    Last edited: Feb 12, 2019
  6. maffle

    maffle Notebook Evangelist

    Reputations:
    137
    Messages:
    484
    Likes Received:
    421
    Trophy Points:
    76
    @Woodking I said already 500TBW as a middle. Even if you assume a worst case of 32GBW per day, that would be 12TBW per year, meaning the drive may fail after 50 years...
     
  7. Eason

    Eason Notebook Virtuoso

    Reputations:
    271
    Messages:
    2,253
    Likes Received:
    892
    Trophy Points:
    131
    @maffle Is the bug you're referring to where the CPU stays at like 2-3W on idle instead of 0.7-1.2W?
     
  8. maffle

    maffle Notebook Evangelist

    Reputations:
    137
    Messages:
    484
    Likes Received:
    421
    Trophy Points:
    76
    Yes.
     
  9. splus

    splus Notebook Consultant

    Reputations:
    8
    Messages:
    170
    Likes Received:
    80
    Trophy Points:
    41
    This sounds great if it works! I'll try it.
    But I don't have any setting for hybrid sleep in my Balanced (or Dell) advanced power settings, only the basic Sleep after and Hibernate after settings. How to enable Hybrid sleep if it's not displayed in the settings?
     
  10. iMbaQ

    iMbaQ Notebook Evangelist

    Reputations:
    20
    Messages:
    472
    Likes Received:
    72
    Trophy Points:
    41
    What is the verdict on the 1080p vs 4K screen on this? Noticed in UK they are now providing 97wh 1080p versions, which is tempting.
     
Loading...

Share This Page