*** XPS 15 7590 Owners Lounge ***

Discussion in 'Dell XPS and Studio XPS' started by Spartan@HIDevolution, Jun 23, 2019.

  1. yerda

    yerda Notebook Enthusiast

    Reputations:
    0
    Messages:
    22
    Likes Received:
    2
    Trophy Points:
    6
    Not sure if anyone needed to hear this or if they were unaware, but the 7590 battery appears to have the same issue as in previous generations where it has battery swelling. The battery becomes enlarged and starts to have inflated bubbles; this pushes up the case of the xps and also makes the touch pad hard to press down.

    If you have warranty, they will replace the battery at no cost to you, and if not, you can still order another battery off of ebay for around $50.

    I just replaced mine, and not only can I properly type and use the touchpad, but my temperatures have significantly dropped, from around 50-80C to 30-60C.
     
    Papusan likes this.
  2. Chang_loo

    Chang_loo Notebook Guru

    Reputations:
    10
    Messages:
    71
    Likes Received:
    12
    Trophy Points:
    16

    Maybe this thread (german language) https://www.deskmodder.de/phpBB3/viewtopic.php?f=334&t=24535 might help you.
     
  3. Roy Gao

    Roy Gao Notebook Enthusiast

    Reputations:
    0
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    5
    I bought a 7590 and revert BIOS to 1.5.0 to use ThrottleStop and it works fine. Now I bought a 2nd 7590 with exactly the same spec. I reverted BIOS to 1.5.0, but ThrottleStop does not work, it has "Turbo Overclocking -Locked" and "FIVR Control - Locked". Does anyone have this issue?
     
  4. Schmoo2k

    Schmoo2k Notebook Consultant

    Reputations:
    27
    Messages:
    200
    Likes Received:
    52
    Trophy Points:
    41
    Try doing a bios factory reset?
     
  5. Roy Gao

    Roy Gao Notebook Enthusiast

    Reputations:
    0
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    5
    What puzzled me is that I am following the same step as I did with previous 7590 2 weeks ago. Yes I did factory reset and disabled auto updated in UEFI.
     
Loading...

Share This Page