XPS-13, WD19TB Dock, USB-C DP Monitor, HELP

Discussion in 'Dell XPS and Studio XPS' started by deanforbes, Apr 16, 2020.

  1. deanforbes

    deanforbes Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    Hello,

    I purchased the New XPS 13 and a Thunderbolt Dock WD19TB to go with it.
    I am trying to use the USC-C DP connection out of the Dock to connect to the monitor and the monitor is not detecting a signal. Everything else seems to be working fine with the dock that I have tried including the regular DP connection to this monitor. I've tried calling dell tech support a couple of times and was eventually disconnected both times but neither person was being helpful anyways.
    I can plug laptop USB-C directly to monitor and it works fine so I feel that eliminates a cable issue or a monitor issue. For reference the cable is 3ft and is a higher end one that has a "SS 10" logo printed on it and monitor is a MAG321CURV. I'm plugged into the USB-C port on Dock with DP symbol but have tried both of the other USB-C ports as well.
    There are no firmware updates for this Dock on Dell or I would try that.

    Does anyone have any other troubleshooting tips?, I've tried looking at stuff in Device Manager but Haven't found anything.
     
  2. Schmoo2k

    Schmoo2k Notebook Consultant

    Reputations:
    23
    Messages:
    179
    Likes Received:
    43
    Trophy Points:
    41
    Display over USB-C may not be supported on the dock (like thunderbolt over USB-C might not be supported)?
     
  3. Mastermind5200

    Mastermind5200 Notebook Virtuoso

    Reputations:
    370
    Messages:
    2,117
    Likes Received:
    814
    Trophy Points:
    131
    The front USB-C does not support DP, but the back one does.
     
  4. deanforbes

    deanforbes Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    Yes, I've used the back one. There was a recent firmware update for the Dock and XPS, the dock firmware referenced monitor fixes but if anything it only made things worse. Now I have issues with bringing monitor back from sleep using displayport.
     
Loading...

Share This Page