XPS 13/15 Infinity Display Windows 7

Discussion in 'Dell XPS and Studio XPS' started by RobotDoctor, Aug 1, 2016.

Thread Status:
Not open for further replies.
  1. RobotDoctor

    RobotDoctor Notebook Consultant

    Reputations:
    0
    Messages:
    151
    Likes Received:
    34
    Trophy Points:
    41
    I just did a fresh installation of Windows 7 Pro on my XPS 13 (9343 - Broadwell CPU) and it appears to be running flawlessly. There is still a slight issue with the performance of the mouse trackpad but it appears to be slightly better than the performance on Win8/10. I found the driver cab file on the Dell XPS 13 9343 page. I am not seeing any performance issues so far. I will update if I run into any issues. Now to install XP Mode and the software I need to run on this computer.
     
  2. RobotDoctor

    RobotDoctor Notebook Consultant

    Reputations:
    0
    Messages:
    151
    Likes Received:
    34
    Trophy Points:
    41
    Battery power is on the poor side for this battery. It's been advertised for 6-8 hours of charge. I am getting the 3 hour or so charge on Win7 but this is pretty much the same as it was for Win10 as well.
     
  3. RobotDoctor

    RobotDoctor Notebook Consultant

    Reputations:
    0
    Messages:
    151
    Likes Received:
    34
    Trophy Points:
    41
    I had an issue with the touch pad not disabling the touch option, even though I had selected the touch to be deactivated. I downloaded the Snaeptics touchpad download (R242713) and that took care of the touchpad issues. Other than abysmal battery life there are no issues with running Windows 7. Running Windows 7 is needed due to several versions of OEM software for my profession that has execution and display compatibility issues with Win8 and Win10. I am pleased I can run Win7Pro on the system instead of creating a virtual system to do so.
     
  4. RobotDoctor

    RobotDoctor Notebook Consultant

    Reputations:
    0
    Messages:
    151
    Likes Received:
    34
    Trophy Points:
    41
    Now I have an issue. The D31o0 docking station isn't working with video and audio. I do see an external hard drive connected and a USB mouse and keyboard is working. The XPS 13 is otherwise working without an issue. I would suspect I might need to get a different video and audio driver. Not sure on this. If anyone can point me in the right direction I would appreciate it.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page