XMG P407 1050 Ti Problem Bluescreen

Discussion in 'Sager and Clevo' started by sbbv123, Nov 29, 2020.

  1. sbbv123

    sbbv123 Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    6
    Hello Guys, i just bought myself a XMG P641HK with the 1050Ti Graphics.

    it came with no harddrive so i put a ssd inside and installed Win 10. If i try to install the nvidia graphics drivers i get a bluescreen. Page fault in nonpaged area. Have a look of the Bsod for yourself here: https://www.bilder-upload.eu/bild-734c5c-1606683327.jpeg.html

    If i try to install the nvidia driver from xmg, it installs perfectly fine and no error, even in device manager it says the graphics card works normally. But if i reboot, device manager tells me that the graphics card stopped working and has a yellow triangle. also games do not really work, it behaves like there is no driver installed, even when the card is listed as working in device manager.

    What are your ideas? I hope i can get this thing to work, otherwise i have to use it as a office laptop :DD

    Thank you in advance!
     
  2. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    9,035
    Messages:
    55,967
    Likes Received:
    16,541
    Trophy Points:
    931
    Sounds like the GPU may be dead, did they let you know when you got it?
     
  3. sbbv123

    sbbv123 Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    6
    they described the problem differently. The seller said that if you move the screen it goes black. I taught that s an easy fix, probably de lcd cable, but i do not have this issue at all, just the graphics issue..
     
  4. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    9,035
    Messages:
    55,967
    Likes Received:
    16,541
    Trophy Points:
    931
    Problem is certainly not as described and would be a suitable reason for a return IMO.
     
  5. sbbv123

    sbbv123 Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    6
    true, but unfortunately i did not had the time to test the device and over a month passed since then... my next try is the hot airgun method, maybe it will work, but the bluescreen sounds more like a vram issue, i am not sure tho..
     
  6. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    9,035
    Messages:
    55,967
    Likes Received:
    16,541
    Trophy Points:
    931
    It will be due to the card sending rubbish info for optimus to the main system memory.
     
  7. sbbv123

    sbbv123 Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    6
    reflow did not help, the driver installation is going further now, but after some time the same bluescreen appears...
     
  8. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    9,035
    Messages:
    55,967
    Likes Received:
    16,541
    Trophy Points:
    931
    Sadly it sounds like it is dead then.
     

Share This Page