XMG A522 - Clevo w35_37ET issues

Discussion in 'Sager and Clevo' started by simopil, Mar 9, 2019.

  1. simopil

    simopil Notebook Enthusiast

    Reputations:
    0
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    5
    Hi to all, I'm new in this forum and, first of all, sorry for my bad english.
    I've got an XMG laptop with clevo W35_37et, it's a good solution for the price (i bought used two year ago), but I have lot of issues.

    1) Fan management is ridicolous, sometimes remains to max instead cpu about 45°C, sometimes heathsink is untouchable but fan stays off, I think temperature sensor reads wrong values (specially during hight loads).
    Temps goes from 40 to 90 then to 40 again during ex: starting chromium. This 40/90/40°C has a less than 1sec period, but makes fan noisy for 5/6seconds.
    I replace thermal paste every 3/4 months, temps are identical everytime.

    2) I'm a linux user, couple of months ago, I was trying to get optimus work and get nvidia card off, something breaks ACPI stuffs in the bios, windows (or every his media installer) was broken with "system not fully acpi compliant" , cmos reset didn't anything and only solution to got it working again was flashing updated clevo-stock bios (1.02.22 / ec:1.02.13) and now in the bios mainboard model is correct w35_37et but in the bootlogo I read "ver: w15er", seems strange. Windows is working again but all issues (fan/temps) remains.

    I tried clevo control center and similar software but seems not working with this barebone.

    I read about a bios mod called prema that resolves lot of clevo bugs, I assumed story of developers and what appened. I can understand them.
    Is there a way to get it or to solve my problems without mod?
    Thanks for all
     
    Last edited: Mar 10, 2019
  2. simopil

    simopil Notebook Enthusiast

    Reputations:
    0
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    5
    up, @Prema are you there? Is there a way to donate for your bios mods?
    Edit: I made a video that shows the strange temp readings
    Both gpu and cpu heatsinks are touchable during test, CPU one seems about +20°C compared to gpu (I haven't a thermometer) fan runs at "medium" speed, and when I stopped test temps drops immediately at 60°C, I think that temperature is about 60°C during entire test but sensor shows wrong value during cpu load. Windows 7 and 10 have identical scenario, I used linux to show because easier
     
    Last edited: Mar 11, 2019
  3. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    8,146
    Messages:
    51,624
    Likes Received:
    14,722
    Trophy Points:
    931
    You may have borked something not in the update portion. A full flash might be needed, speak to your reseller.
     
  4. simopil

    simopil Notebook Enthusiast

    Reputations:
    0
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    5
    I bought it used, so i flashed stock clevo but after this I found official XMG update, but file is the same as clevo's bios i've flashed (I compared md5). Xmg isn't a prema partner. Seems bios knows right temp but OS reads it badly (fan ad middle speed, os reports 85°C+).
    Is it possible that last owner flashed wrong bios (w150er) and bug still remains even after my update to correct bios?
     
    Last edited: Mar 11, 2019
  5. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    8,146
    Messages:
    51,624
    Likes Received:
    14,722
    Trophy Points:
    931
    Either way a full flash would fix it.
     
  6. simopil

    simopil Notebook Enthusiast

    Reputations:
    0
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    5
    How can I do this? Is there a way to get premamod?

    Inviato dal mio Redmi 3 utilizzando Tapatalk
     
  7. Prostar Computer

    Prostar Computer Company Representative

    Reputations:
    1,257
    Messages:
    7,429
    Likes Received:
    1,013
    Trophy Points:
    331
    You would need to flash the EC, ME, and BIOS using what the original seller provides. I don't recall @Prema having made a mod for this model.
     
  8. simopil

    simopil Notebook Enthusiast

    Reputations:
    0
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    5
    After some researches I've found in this forum a reference to a w350et mod by prema. In my reseller website are only updates (same files in clevo's website). Seems there isn't a full flash package

    Inviato dal mio Redmi 3 utilizzando Tapatalk
     
  9. BrunoN80

    BrunoN80 Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Hi, could you post link here?
     
  10. simopil

    simopil Notebook Enthusiast

    Reputations:
    0
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    5
Loading...

Share This Page