X3Plus V3 Starcraft 2- Ultra setting = slow frame rate :-(

Discussion in 'Gigabyte and Aorus' started by coolesnce, Feb 20, 2015.

Thread Status:
Not open for further replies.
  1. LVNeptune

    LVNeptune Notebook Virtuoso

    Reputations:
    615
    Messages:
    2,128
    Likes Received:
    96
    Trophy Points:
    66
    You can control it from the NVIDIA Control Panel.
     
  2. bernieyee

    bernieyee Notebook Evangelist

    Reputations:
    57
    Messages:
    457
    Likes Received:
    56
    Trophy Points:
    41
  3. SeagateBoy

    SeagateBoy Notebook Consultant

    Reputations:
    10
    Messages:
    261
    Likes Received:
    34
    Trophy Points:
    41
    With starcraft it's usually the CPU especially when there are many units on the screen, I've experienced that many times, I have 970m and i7-4720, and they don't matter, once there are many units it'll crap out on you ..........
     
    coolesnce likes this.
  4. coolesnce

    coolesnce Notebook Enthusiast

    Reputations:
    0
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    5
    Are you having to throttle down the Graphic settings for SC2 as well to high, or medium?
     
  5. SeagateBoy

    SeagateBoy Notebook Consultant

    Reputations:
    10
    Messages:
    261
    Likes Received:
    34
    Trophy Points:
    41
    I leave it at ultra, I don't mind the stutter since I'm not good at it so at least I have something to blame LOL
    Although maybe I should ask my friend who plays starcraft on his MacBook pro, and see if that makes any difference
     
  6. SeagateBoy

    SeagateBoy Notebook Consultant

    Reputations:
    10
    Messages:
    261
    Likes Received:
    34
    Trophy Points:
    41
    Yup, my friend who plays starcraft on MacBook pro suffers the same stuttering problem, it's Blizzard's fault, petition anyone ??!?!?!? :p
     
    Last edited: Feb 23, 2015
    coolesnce likes this.
Thread Status:
Not open for further replies.

Share This Page