1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

X220 - Trackpad button issue?

Discussion in 'Lenovo' started by snuci, May 15, 2011.

Thread Status:
Not open for further replies.
  1. snuci

    snuci Notebook Enthusiast

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    I'm not sure I like the buttonless trackpad but I'm trying to get used to it. I've installed the latest driver from 4/21/2011 and I'm having an issue with the virtual buttons.

    I'm used to lifting my fingers off the trackpad and pressing the left button to select something but I notice that a little "scroll bar" pointer pops up and I clicking does nothing. The problem is that I rest my thumb on the button and doing this pops up the scroll bar pointer. If I hit it immediately, it works but I have to be very precise with no resting at all.

    I've learned that if you have you finger on the trackpad and then simultaneously hit the left button, it's okay.

    Does anyone know if you can disable the "resting on button showing the scroll bar pointer" feature? I'm not sure what you have to select to remove that option.

    Is this bugging anyone else? Thanks in advance.
     
  2. p0rtmonkey

    p0rtmonkey Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I'm agreeing with you right now -- I just purchased my x220 with an i7, 160GB SSD, and 8GB memory... it flies!

    HOWEVER, with that said, this is the worst possible experience I've EVER had with a freaking mouse. I've got a Macbook pro that has nailed the touchpad, and my Dell Precision laptop that weighs 15 lbs has a mouse experience that is 10x better than what I'm currently dealing with on the Lenovo.

    I'm not sure if updated drivers will fix this problem in the future, but I swear the experience of trying to scroll using the designated regions for one finger scrolling or 2 finger scrolling is pretty terrible. It doesn't work half the time, and if it does, it's a pain in the rear.

    Just my 2 cents.
     
  3. jarros

    jarros Newbie

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    Today I've been trying to tweak the trackpad to work the way I want. I had similar frustrations as you, but may have found a way to get it to work.

    Press Fn+F8 and click on "Manage Settings" to get to advanced features for the trackpad. Start by cranking the sensitivity - this makes it a lot more responsive, especially with gestures and scrolling. snuci, you might want to turn off horizontal scrolling, it sound like that's your problem.

    I've also installed the program "TwoFingerScroll" to get smoother scrolling. It's a small app that just sits in the system tray. Give it a try.
     
  4. WAYNENUMM

    WAYNENUMM Notebook Guru

    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    15
    I was going to mention that also. It seems to really help with the scrolling (ie I can actually use 2 finger scrolling now LOL!)
     
  5. serialk11r

    serialk11r Notebook Consultant

    Messages:
    229
    Likes Received:
    0
    Trophy Points:
    30
    in the settings there's a place to adjust the scroll area on the edges. Personally I am rather conflicted about the touchpad. Tap zones, one finger scroll, two finger scroll, tap to click, all feel like they get in each other's way. The whole touchpad gets in the way of the Trackpoint experience when your palm accidentally triggers something. After messing with settings for a while I just gave up and disabled the trackpad. Doesn't bother me (but my mom was pretty confused when she tried to use it lol).
     
  6. mikesta21

    mikesta21 Notebook Enthusiast

    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    5
    I was in the same boat yesterday with my new x220.

    Found a decent solution:

    Install synaptics drivers (most recent from their website)
    uninstall scrybe (i find it to be useless)
    widen the vertical scroll range remove the horizontal scroll.
    turn on CHIRAL SCROLLING.

    this is a feature where you move your finger in a circle to scroll. Strangely the sensitivity for scrolling seems to go up quite a bit with this on. Additionally, I really like the ciruclar scrolling. You can barely make a circle with your finger, just a tiny bit of movement and it controls the scrolling great. I use my pointer or ring finger, and start in the top right corner. It works great.

    I heard about twofingerscroll but I haven't bothered. I will say that I am using "not another scrolling extension" or something like that for my firefox, and it has an apple-ish feel to it now, after playing with the add on settings a bit.

    hope that helps!

    mike

    PS I have an old dell inspiron that has a better touchpad than this! Who do they think they are? The computer is fantastic save the touchpad.
     
  7. WAYNENUMM

    WAYNENUMM Notebook Guru

    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    15
    I went to synaptics and saw this:
    The lenovo manufacturer's link just went to Lenovo. Did you install the generic driver?

    Thanks
     
  8. WAYNENUMM

    WAYNENUMM Notebook Guru

    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    15
    Ignore my last entry. I installed the generic driver (after creating a restore point). It took me about half an hour to figure out where to go to widen the vertical scroll range and to turn on chiral scrolling, but persistence paid off and I managed to do it! Yeah!

    Ok, this chiral scrolling is really excellent. I love it. Using the index finger works really well. And when typing, as an alternative to using the "touchpoint + middle button" to scroll up/down, you can instead use your thumb to chiral scroll up or down in the text box without taking the hands off of the keyboard. Very cool!

    Yes, I turned it off so as not to interfere.

    I wish I didn't have to check that out, but I probably do LOL!

    Thanks buddy!
     
  9. chaose

    chaose Notebook Consultant

    Messages:
    103
    Likes Received:
    0
    Trophy Points:
    30
    one thing you can do is to disable the trackpad buttons and just use the ultranav buttons for the clicks.
     
  10. c17chief

    c17chief Notebook Consultant

    Messages:
    126
    Likes Received:
    1
    Trophy Points:
    31
    or disable the trackpad all together and use the stick. :D
     
Thread Status:
Not open for further replies.

Share This Page