X220 and T420s: Guide to get rid of 50 Hz when running on battery

Discussion in 'Lenovo' started by sniper_sung, Aug 10, 2011.

Thread Status:
Not open for further replies.
  1. sniper_sung

    sniper_sung Notebook Evangelist

    Reputations:
    66
    Messages:
    611
    Likes Received:
    0
    Trophy Points:
    30
    Have you ever been upset with the rude action taken by the Intel integrated graphics card constantly switching the refresh rate of your screen to 50 Hz whenever you unplug your AC power adapter? Hate the annoying scan lines? Eyes got tired quickly? Whenever plugging in/pulling off the AC adapter, messed up your current player cuz you no longer see video output or the player simply crashed? Really tired of the screen flickering?

    Here is the fix for you! This way is essentially the same way as mentioned on the Lenovo site, however my method could avoid breaking the digital signature of the driver. Furthermore, not every version of the driver comes with the same key value so it's difficult for newbies to generalize.

    Now this guide is simple and easy.

    This guide has been tested and proved to be working in Windows 7 64-bit, with the following versions of graphics card driver:

    Intel 8.15.10.2321 (downloaded from Intel's website)
    Lenovo 8.15.10.2418 (downloaded from Lenovo's website)
    Intel 8.15.10.2559 (downloaded from Intel's website)

    Disclaimer: This guide includes registry editing, and it is only recommended for experienced users. Unwanted changes to the registry may lead to unexpected problems, so move with caution and stop if you are not sure what you are doing!

    Open Start Menu, and type "regedit", right click on "regedit.exe" and select "Run as administrator".

    Locate the following path:

    Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\

    Press Ctrl + F, and search for the following key: FeatureTestControl

    If everything goes well, you should be able to locate a DWORD with hex value f900. Change it to f940. (Note: for later drivers, if you see f800, change it to f840.)

    Reboot your laptop.

    Now enjoy the consistency and sanity of a stable 60 Hz, regardless of power status!

    [​IMG]
     
  2. crispyJ

    crispyJ Notebook Enthusiast

    Reputations:
    0
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    15
    nice one! much simpler than the one from the lenovo forum :)
     
  3. Jesper Juul

    Jesper Juul Notebook Consultant

    Reputations:
    17
    Messages:
    174
    Likes Received:
    0
    Trophy Points:
    30
    Yes perfect, I was going insane having to change from 50hz to 60hz everytime I was on battery.
     
  4. Isaac-1

    Isaac-1 Notebook Guru

    Reputations:
    16
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    15
    Thanks, I can confirm this also works on a T420s with Nvidia Optimus graphics.

    Ike
     
  5. zygomatic

    zygomatic Notebook Guru

    Reputations:
    2
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    15
  6. dbman190

    dbman190 Notebook Geek

    Reputations:
    18
    Messages:
    86
    Likes Received:
    0
    Trophy Points:
    15
  7. gmoneyphatstyle

    gmoneyphatstyle Notebook Deity

    Reputations:
    399
    Messages:
    733
    Likes Received:
    0
    Trophy Points:
    30
    What model thinkpad are you using?
    Did you upgrade to the latest version of Power Manager as well? as indicated here

    sniper_sung, have you tried the latest Intel HD Graphics driver?
    Version 8.15.10.2418
    LINK

    I'd be interested to know if the latest driver fixes the problem as Lenovo claims.
     
  8. Azrielsc

    Azrielsc Notebook Geek

    Reputations:
    15
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    15
    Thanks Sniper_sung for the registry hack.

    I had installed the latest 2418 drivers as well as the latest power manager (3.62) and it still didn't help me till I used the registry hack.
     
  9. tommyxv

    tommyxv Notebook Evangelist

    Reputations:
    80
    Messages:
    473
    Likes Received:
    13
    Trophy Points:
    31
    I have the latest 8.15.10.2538 Intel driver and this problem still exists. Your regedit fix it!
    This needs to be a sticky!
    Thank you!!!!
     
  10. sgogeta4

    sgogeta4 Notebook Nobel Laureate

    Reputations:
    2,389
    Messages:
    10,556
    Likes Received:
    7
    Trophy Points:
    456
    The newest version of Power Manager has an option to turn off the switching. Seemed to work on my W520, but not sure about the other laptops.
     
Thread Status:
Not open for further replies.

Share This Page