Windows 7 installation help for Intel Skylake and Kaby Lake laptops

Discussion in 'Windows OS and Software' started by Atom Ant, Apr 13, 2017.

  1. cincinnatus

    cincinnatus Notebook Enthusiast

    Reputations:
    5
    Messages:
    33
    Likes Received:
    6
    Trophy Points:
    16
    Sad to hear that.

    Do you have any yellow alert in "device manager"? (except the touchpad).

    I would install Windows 7 drivers (I got mine from the previous laptop model that supported it) and avoid Windows 10 drivers (even if they install fine).

    This is what I would try, let us know if it gets any better...
     
  2. Atom Ant

    Atom Ant Hello, here I go again

    Reputations:
    1,314
    Messages:
    1,451
    Likes Received:
    188
    Trophy Points:
    81
    Have you used my modded driver that I linked in my first post? You should not experience any performance loss with it.
     
  3. Zazazas

    Zazazas Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    So is it possible to install 7 on an i5 8300h with a 1050 on a h370m chip? I keep on getting conflicting opinions saying that no you can't or you need a pci controller or something else.
     
  4. Atom Ant

    Atom Ant Hello, here I go again

    Reputations:
    1,314
    Messages:
    1,451
    Likes Received:
    188
    Trophy Points:
    81
    No drivers for I5-8300H exist yet, so you have to go with Windows 10.
     
  5. julian167

    julian167 Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    6
    Unfortunately no. I tried everything I could for the last few months before giving up on this.
     
  6. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,287
    Messages:
    5,015
    Likes Received:
    3,307
    Trophy Points:
    431
    Please help, the intel hd 630 driver causes me a blackscreen after I reboot, no matter which driver I try to install, always does the same thing.
     
  7. Papusan

    Papusan JOKEBOOKS = That sucks! Dont wast your $ on FILTHY

    Reputations:
    16,364
    Messages:
    20,139
    Likes Received:
    31,802
    Trophy Points:
    931
    It worked before?
    And you are sure you haven’t got new updates from Microsoft?
     
  8. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,287
    Messages:
    5,015
    Likes Received:
    3,307
    Trophy Points:
    431
    never worked, I am using win7 sp1 image. literally this is the last step in configuring my blade to run win7, I even managed to get the i2c touchpad to work!

    Edit
    Upon further investigation, everything works via HDMI out.....just the internal display seems to be having problems. No problems in device manager when connected over hdmi, anybody run into something like this before?
     
    Last edited: Sep 27, 2018
    hmscott likes this.
  9. Atom Ant

    Atom Ant Hello, here I go again

    Reputations:
    1,314
    Messages:
    1,451
    Likes Received:
    188
    Trophy Points:
    81
    Which version driver are you using, modded by who? Also which generation is your CPU?
     
  10. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,287
    Messages:
    5,015
    Likes Received:
    3,307
    Trophy Points:
    431
    the driver that is linked in the original post. running 7700hq/hd 630
     
Loading...

Share This Page