Windows 10 Automatically updating drivers.. Driving me insane

Discussion in 'Windows OS and Software' started by Claytankozmo, Jun 19, 2017.

  1. Claytankozmo

    Claytankozmo Notebook Enthusiast

    Reputations:
    0
    Messages:
    19
    Likes Received:
    2
    Trophy Points:
    6
    As the title says, I have windows 10 and everyone hates the automatic windows updates, and ironically it's those I have no problem with. It's the automatic driver updates - no matter what settings I do or no matter what registry tricks I use it will not stop.

    To be more specific, I use the 378.83 version of nVidia graphics drivers because it appears to be the latest version that doesn't lag, stutter, and generally mess with my games after the windows 10 creators update. I repeatedly reinstall those older drivers and generally within 30 minutes to 3 days my screen will flicker and my GPU will restart, my games will start lagging and I'll notice it updated the drivers and a swearing session will commence...

    I have set the deep in settings for Windows 10 to not automatically update drivers - nope, still updates.
    I have turned all my connections to metered - nope, still updates.
    I have set my registry settings to "ExcludeWUDriversInQualityUpdate" and it still updates.
    I have tried a couple other registry settings - NOPE, still updates my drivers.
    I have used Microsofts troubleshooting tool, to exclude Nvidia drivers from my Windows updates.. does it care? Nope.

    I am getting so mad at this already, how can there be no registry tweak that just shuts off automatic updates in general, I wouldn't even care at this point what it is. It seems like I am the only one with this issue, help please??
     
  2. 0lok

    0lok Notebook Evangelist

    Reputations:
    60
    Messages:
    397
    Likes Received:
    119
    Trophy Points:
    56
    From my experience when I did a clean install. I initially updated my nvidia driver to the latest so that when I updated windows 10 to the latest build it detected that I have the latest nvidia driver and it didnt bother to do anything. After installing everything, I used O&Oshutup 10 and disabled all windows update Restarted laptop and used DDU to remove the latest nvidia driver that I didn't want then install the nvidia driver that I wanted. Kept windows update disabled for now. Will only update if needed. Hope this helps as it worked for me. I have windows 10 home eiditon by the way. For windows 10 pro you have another way via group policy. Check out Windows 10 clean install video by @Phoenix
     
  3. SL2

    SL2 Notebook Deity

    Reputations:
    785
    Messages:
    1,236
    Likes Received:
    205
    Trophy Points:
    81
    I think the OP's issue is that the latest drivers doesn't work.
    This is a very useful software, it's capable of blocking updates and drivers.

    (I installed W10 on my parents computers maybe 18 months ago, and later on I was surprised to see that those machines were still running 1511. I later realized that I had installed O&O Shutup10, disabled updates and forgot about it..
    My reason for disabling updates was that my parents tends to turn off the computers regardless of what the display says, like "Don't turn off your computer".)
     
  4. StormJumper

    StormJumper Notebook Virtuoso

    Reputations:
    491
    Messages:
    2,967
    Likes Received:
    322
    Trophy Points:
    101
    Do you have Nvidia experience installed? If so this will update if you don't stop it from doing so in it's configuration system. I found out that this Nvidia experience after v3 is a pain in the a33 if you leave it auto check it will cause some unforseen problems-so I left all my offline Nvidia install unchecked for Nvidia Experience option. I have Window 10 Pro and it doesn't update Nvidia driver that I do myself. Maybe if you add a hosts edit to your host file that will stop Nvidia experience from doing the update and checking.

    This is the host edit I inputted in the hosts.
    Windows 10 "C:\Windows\System32\drivers\etc\hosts"
    and overwrite the original hosts file itself to make this block work. I use 382.53 and don't have lag or stutter problem just running normally and usage. I think your Nvidia Experience install is part of the problem unless you don't have it installed but express install will install Nvidia Experience unless you choose custom and there you can uncheck it from installing.

    #Nvidia auto update disable
    127.0.0.1 services.gfe.nvidia.com

    This will stop all nvidia auto update and checks.
     
  5. Papusan

    Papusan BGA Filthy = That sucks!! STAHP! Dont buy FILTH...

    Reputations:
    5,977
    Messages:
    14,300
    Likes Received:
    18,875
    Trophy Points:
    931
  6. Vasudev

    Vasudev Notebook Virtuoso

    Reputations:
    560
    Messages:
    2,767
    Likes Received:
    1,298
    Trophy Points:
    181
    steberg likes this.
Loading...

Share This Page