WiFi Remedies for Samsung Laptops

Discussion in 'Samsung' started by Dannemand, Aug 3, 2013.

Thread Status:
Not open for further replies.
  1. Dannemand

    Dannemand Decidedly Moderate Super Moderator

    Reputations:
    11,309
    Messages:
    4,394
    Likes Received:
    2,071
    Trophy Points:
    231
    Discussion about WiFi issues (performance as well as disconnects) comes up repeatedly. Let me try and summarize the multiple remedies that I am aware of:

    Drivers

    Some users have better results with Samsung-provided drivers, others with the latest Intel-provided drivers, and yet others prefer Win8's built-in driver. I prefer the latter on my older Series 7 (with 6230 adapter). But regardless of where you end up, I recommend first cleaning out existing drivers and rolling back to the Win8 built-in driver. Then you can add new drivers from there.

    Note that Win7 does NOT have built-in WiFi drivers for the Intel 6230/6235 adapters, so after this roll-back procedure there will be no WiFi driver installed -- which is OK, we're clean. But before starting the roll-back, download Intel's Driver Only package for Win7 (as described below), and simply install that afterwards.

    Use the following steps to clean out and roll back. This will also remove registry entries from connections created by previous driver entries:

    1) Uninstall any PROset or Samsung provided WiFi drivers using Windows Programs and features.

    2) Reboot (Win8 Restart, not Shutdown).

    3) In Device Manager, right-click the WiFi adapter and select Uninstall; when prompted, check Delete the driver software for this device and click OK.

    4) Still in Device Manager, chose Action (menu) - Scan for hardware changes.

    5) Repeat steps (3) and (4) as long as you still get that Delete the driver software for this device option. That's how you cycle back and delete each of the previous driver versions you have installed. When you do NOT see that option anymore, you're back to the original Win8 driver. Don't uninstall that device (don't click OK).

    6) Reboot.

    You should now be on Win8's built-in driver (or no driver in Win7). If it doesn't work for you (after testing the other remedies in this post) you can update to the latest Samsung-provided driver (using SW Update) or to the latest Intel-provided driver (using Intel Download Center).

    From Intel, I highly recommend the Driver Only version, as opposed to the full PROset version which comes with additional and unnecessary bloat. The file should be called Wireless_x.x.x_Ds64.exe for Win7 and Wireless_x.x.x_De64.exe for Win8 (x.x.x being the version number).

    Intel download 6235 WiFi.png

    Note that when installing the Intel Driver Only package, it simply spins an icon for a while, and doesn't display any confirmation. Go to Device Manager to verify that it installed properly. The driver version you see there may not always match the package version (x.x.x).


    Power Profile Settings

    This has always been one of the most important changes to make on Samsung laptops to help with WiFi performance and stability:

    Using the Power Options control panel, Change plan settings then Change advanced power settings. Under Wireless Adapter Settings change the Power Saving Mode to Maximum Performance for both battery and plugged in.

    If this Power Saving Mode is set to anything "slower" than Low Power Saving (such as Medium or Maximum Power Saving) you are likely to experience disconnects.

    Power profile - WiFi.png

    Note that you must make this change for all Power Profiles that you use. That includes Samsung Optimized (default) and Power Saver (used in Silent and Eco Mode). Some people also use High performance or the good old Balanced.

    Personally I use Low Power Saving on battery in my Power Saver profile -- knowing that it will slow my WiFi down when I toggle Silent Mode with Fn-F11. But it saves a little juice, without saving so much that I get disconnects.

    While in there, consider also changing other important power settings as described in this post and this post.


    Adapter Settings

    Check your WiFi Adapter Settings as described in TANWare's post here. In particular, make sure Transmit Power is set to Highest.

    To get there, locate the WiFi adapter in Device Manager, open Properties (right-click or double-click it) and switch to the Advanced tab.

    WiFi Adapter Power settings.png

    Some owners with 6235 adapters have seen improved performance and stability by disabling Wireless-N under Adapter Settings. I have not found this necessary myself, and I hate recommending it because it basically limits WiFi to the old Wireless-G protocol which had a much lower theoretical max transmission speed. This shouldn't be a bottleneck for typical Internet connection speeds, but could limit access speed to disks and and other computers shared on the WLAN. I recommending trying the other remedies first to see if this one is necessary.

    WiFi Adapter settings wireless-N.png

    While in Adapter Settings, you may choose to disable the option Allow the computer to turn off this device to save power on the Power Management tab. Some users have found that this solved their disconnect issues. Personally, I keep this one enabled; after rolling back to Win8's built-in driver (AND as long as my Power Profiles are set as described above) I have not seen any disconnects.

    WiFi Adapter Power settings.png


    Router settings

    Many stubborn WiFi problems turn out to be related to the router -- to the understandable surprise of users, because they see the router working with other devices.

    First try power cycling it. But beyond that, try changing to a different router channel that is less crowded. Use the free tool inSSIDer (that was a link) to see how much overlap comes from neighboring networks. Something else that solved issues with my TP-Link router was to enable SSID Broadcast (which I normally like to disable).

    My point here is that there are an infinite number of combinations of routers, settings, devices and environments, so one particular setting may not solve it for everybody.

    For persistent problems, I recommend trying a different router at a friend's house or a coffee shop -- just to see if the problem is really with the laptop or with the router.


    Locating other WiFi discussions in Samsung forum

    WiFi performance has been an ongoing topic on the Samsung forum for a long time. In case you are not aware of it, the following Google syntax is a great way to locate past discussions here: site:notebookreview.com/samsung wifi issues. You will find extensive discussion of this subject in many threads.

    Of course you can use that syntax to locate discussions of other subjects as well :rolleyes:


    Intel 6235 discussion forum

    Finally do note that the Intel 6235 has known connectivity issues as discussed in this Intel forum.


    I hope some of this helps. I'll add to (or update) this post with any new information I see.

    Edit 4-Aug-2013: Added disabling Wireless-N as possible remedy

    Update 16-Nov-2013: Intel has released a significantly updated WiFi driver version 16.6.0. See John's post here for details.

    Update 1-Dec-2014: Updated link to Intel Download Center above.
     
    downloads and apa64 like this.
  2. PenguinPlop

    PenguinPlop Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Hi dannemand. Thanks for replying to my previous post in the owners lounge thread. I actually tried all of the solutions mentioned above prior to posting but unfortunately none seemed to help. I did see you mentioned something about disabling bluetooth in one of the threads you linked to so ill try that and see how it goes. I havent seen anyone else with the problem related to GPU use though.
     
  3. Dannemand

    Dannemand Decidedly Moderate Super Moderator

    Reputations:
    11,309
    Messages:
    4,394
    Likes Received:
    2,071
    Trophy Points:
    231
    I noticed that you mentioned the issue was triggered by GPU, and admittedly I don't know what that could be. Maybe it really is a power issue as you suggested there, but I haven't heard others mention it either. I just wanted to make sure you had tried the other remedies as well, that's why I referred you to this thread. Clearly you already did :eek:

    You're right, I used to keep Bluetooth AMP disabled in my Adapter Settings. That was when I used Win7 where Easy Settings would let me power off the BT adapter. The options is still there in Win8 Adapter Settings, you can definitely try that and see if it makes a difference.

    Here's a test you could try: What if you run a 3D benchmark or some other 3D app -- but NOT a game that uses network. Then run speedtest.net at the same time. I am curious if the issue could be the actual game and its network access rather than the WiFi adapter.

    Something else playing into your suggestion about power maxing out: Are you using the High Performance power profile? I know many gamers do (hey, they want high performance). The problem is it locks the CPU at 100% (and thus max power consumption) not allowing it to rest even when the GPU is doing most of the heavy lifting. I wonder if that could leave too little power for the WiFi.
     
  4. PenguinPlop

    PenguinPlop Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    I thought for a second that it might just be generally poor wireless performance because it stopped working when on low settings too. But now its back to the way it was before. I've changed the bluetooth settings but still no luck. I have been using high performance profile but having looked at my power settings that still lets the cpu usage fall as low as 5%. Ran speedtest as you suggested, once with skyrim (single player only 3d game) running and once without. Without it I got a ping of 49ms, download speed of 6.5Mbps and upload speed of 0.84Mbps. When I ran it with skyrim open it failed completely showing a ping test error. Im considering just returning the laptop as there's clearly something strange wrong that I doubt ill manage to fix
     
  5. Dannemand

    Dannemand Decidedly Moderate Super Moderator

    Reputations:
    11,309
    Messages:
    4,394
    Likes Received:
    2,071
    Trophy Points:
    231
    Thanks.

    If Minimum processor state is 5%, that's good. I believe default in the High Performance profile is 5% on battery and 100% when plugged in. If the problem is really power maxing out (and we don't know) that could have been a reason. But you already changed that, so it isn't.

    While we're at it: You DID update the Wireless Adapter Settings in the High Performance power profile to Max Performance, both on battery and plugged in, right? I am sorry to even ask, just making sure :rolleyes:

    Otherwise I agree this sounds odd, I haven't heard it from others (at least that I remember). I would go for swap if you can.
     
  6. alfling

    alfling Notebook Deity

    Reputations:
    90
    Messages:
    995
    Likes Received:
    9
    Trophy Points:
    31
    Did you try to set CPU maximum state at 99% instead of 100%? This should prevent TurboBoost from being activated, thus reducing power consumption

    Sent from HTC HD2 with Tapatalk
     
  7. PenguinPlop

    PenguinPlop Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Sorry for the delayed reply. I was away for a few days and then had guests staying so didn't get much time to test. I tried the power settings you suggested but it seemed to make no difference. Having spent the last couple of days trying out different combinations of graphics and wireless drivers I've found that I get the best performance using the samsung provided gpu drivers and the latest intel wireless wifi driver (16.1.1 on the intel download page but reading 15.10 in driver details once installed).

    Having done some testing on a friends router I have also discovered that mine definitely needs replacing as the signal strength is incredibly weak in comparison. There were some minor connection issues when testing on my friend's router, however he claims that he does frequently get ping spikes on his connection and the issues were so minor with the gpu in use that it was very difficult to determine whether using the integrated gpu made any real difference. Having also tested my own router with an older laptop that previously worked well, I noticed that it too was now quite unreliable at the same range. Due to the older laptop's (First gen HP envy 15) chronic overheating problems, I wouldn't be too confident in the health of its wireless card and so am not sure it makes a great comparison, but it was the only other laptop available to me that didn't use integrated graphics and hence could test any games.

    The fact remains however, that on my own own (apparently very poor) connection turning off the dedicated gpu makes a very noticeable difference to connection quality, even with the better drivers, and I can't figure out why.

    I have contacted the retailer who sold the laptop and they said that a replacement isn't possible due to lack of stock but have offered me a refund up to the end of the month. As I got the laptop at an excellent price a replacement would have been ideal (and I could have worked out was it an issue common to this model or just this laptop), but I'll test a few more routers over the next day or two and let you know the results before deciding whether or go for a refund or just get a half decent router, as the impact may be very minor and only apparent on a very tenuous connection.
     
  8. three0s

    three0s Notebook Enthusiast

    Reputations:
    0
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    5
    Rolling back to win8 driver works for me. No more random 1sec spikes.
     
  9. Dannemand

    Dannemand Decidedly Moderate Super Moderator

    Reputations:
    11,309
    Messages:
    4,394
    Likes Received:
    2,071
    Trophy Points:
    231
    Excellent, good job!
     
  10. Dannemand

    Dannemand Decidedly Moderate Super Moderator

    Reputations:
    11,309
    Messages:
    4,394
    Likes Received:
    2,071
    Trophy Points:
    231
    @PenguinPlop: Thanks a lot for that update. I love how thoroughly you have approached this. Also, your findings are a reminder how much difference routers can make.

    It does indeed sound like there is some correlation between your GPU and your WiFi. That's still puzzling to me. In addition to the power draw (which you mentioned originally) I wonder if the GPU may actually create some radio interference.

    Did you try different channels? 20 vs 40MHz Channel widths? 2.4GHz vs 5GHz? Disabling Bluetooth AMP and/or disabling BT entirely?

    You probably tried those already, I just wanna make sure :eek:
     
Loading...
Thread Status:
Not open for further replies.

Share This Page