Warcraft 3 lags like hell even i have the right specs

Discussion in 'Other Manufacturers' started by Clark1234567, Mar 11, 2016.

  1. Clark1234567

    Clark1234567 Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I am using a notebook and when i play Warcraft3 the fps will be 18 below but when i go to system requirements lab its says my fps is supposed to be 35+


    Warcraft 3 minimum requirements:
    VIDEO CARD
    Minimum: 8 MB 3D Video Card with DirectX 8.1 support

    CPU
    Minimum: Pentium II or Athlon equivalent

    CPU SPEED
    Minimum: 400 MHz

    RAM
    Minimum: 128 MB

    OS
    Minimum: Windows 98/ME/2000/XP

    FREE DISK SPACE
    Minimum: 550 MB

    CD-ROM
    Minimum: 4X CD-ROM

    My Specs:

    Driver Version: 8.14.8.1096
    Operating System: Windows 7 Service Pack 1(6.1.7601)
    Default Language: English (Republic of the Philippines)
    DirectX* Version: 9.0
    Physical Memory: 2036 MB
    Minimum Graphics Memory: 64 MB
    Maximum Graphics Memory: 762 MB
    Graphics Memory in Use: 49 MB
    Processor: x86 Family 6 Model 54 Stepping 1
    Processor Speed: 1596 MHz
    Vendor ID: 8086
    Device ID: 0BE1
    Device Revision: 09

    Accelerator in Use: Intel(R) Graphics Media Accelerator 3600 Series
    Video BIOS: 1071.0
    Current Graphics Mode: 1024 by 600
     
  2. jaug1337

    jaug1337 de_dust2

    Reputations:
    2,050
    Messages:
    4,757
    Likes Received:
    838
    Trophy Points:
    181
    Technically you should hit at least 20 fps or so, but try to see if you are missing some newer drivers.
     

Share This Page