[VAIO Z13] Limit CPU on BIOS

Discussion in 'VAIO / Sony' started by Paloseco, Apr 16, 2017.

  1. Paloseco

    Paloseco Notebook Evangelist

    Reputations:
    7
    Messages:
    321
    Likes Received:
    44
    Trophy Points:
    41
    My VAIO Z13 powers off when I try to install the Windows 10 Creators Update because it uses a 100% CPU. I have a power plan which specifies 70% (called Balanced) but it does not apply when making a clean install or updating. That way, the CPU reaches 105 º Celsius, I try to keep it below 95ºC..

    How can I limit the processor on the BIOS? I can't update.
     
  2. don_svetlio

    don_svetlio Notebook Deity

    Reputations:
    83
    Messages:
    1,536
    Likes Received:
    588
    Trophy Points:
    131
    You can't - what you must do is clean it and repaste. 105*C is dangerous - even 90*C is somewhat dangerous.
     
  3. Paloseco

    Paloseco Notebook Evangelist

    Reputations:
    7
    Messages:
    321
    Likes Received:
    44
    Trophy Points:
    41
    Finally could. Here's the explanation.

    My BIOS is the Insyde H2O Setup Utility. It's hacked to display the advanced settings. To update Windows 10 used the Microsoft Update Assistant utility "Windows10Upgrade9194.exe".

    These are the things that I've tried but didn't work:

    • Advanced tab -> Thermal Configuration -> Platform Thermal Configuration -> Throttle On Temperature -> changed from 93 ºC to 70 ºC, but apparently no effect.
    • Advanced -> Arrandale QPI Options -> QPI Frequency -> [Auto] ot [3.200 GT], but apparently no effect.

    What worked was:
    • Advanced -> Thermal Configuration -> Intelligent Power Sharing [Enabled] -> CPU Turbo: [Enabled] to [Disabled]
    • Advanced -> Thermal Configuration -> Intelligent Power Sharing [Enabled] -> MCH Turbo: [Enabled] to [Disabled]
    That diminished the fan speed and the CPU temperature I believe. Also, I put the laptop resting on its right side, so the fan exhaust is looking to the ceiling instead of the normal position. That helps hot air go upwards. With all that finally could update my Windows 10 from build 10586 (November update/Threshold 2) to 15063.rs2_release.170317-1834 (Redstone 2/Creators update). The computer rebooted 3 or 4 times showing the update progress like that:

    Working on updates 16%
    Don't turn off your PC. This will take a while.
    Your PC will restart several times.

    Very happy now. The other BIOS options that may have an impact reducing CPU/GPU temperatures are:
    • Advanced -> Thermal Configuration -> Intelligent Power Sharing [Enabled] -> MCH Power Limit -> [Disabled] to [Enabled]
    • Advanced -> Thermal Configuration -> Intelligent Power Sharing [Enabled] -> Processor Power Limit -> [Disabled] to [Enabled]
    • Advanced -> Thermal Configuration -> Intelligent Power Sharing [Enabled] -> Core Power Limit -> [Disabled] to [Enabled]
    • Power -> Advanced CPU Control -> P-States (IST) -> change [Enabled]
    • Power -> Advanced CPU Control -> CMP Support -> change [Auto]
    • Power -> Advanced CPU Control -> HT Support -> change [Auto]
    • Power -> Advanced CPU Control -> Use XD Capability -> change [Enabled]
    • Power -> Advanced CPU Control -> C-States -> change [Enabled]
    • Power -> Advanced CPU Control -> Enhanced C-States -> change [Enabled]
    • Power -> Advanced CPU Control -> Enable C6 -> change [Enabled]
    • Power -> Advanced CPU Control -> Turbo Mode -> change [Enabled]
    Probably would be a great idea to post a video navigating through all the settings inside the BIOS because has a lot of option. Can somebody point me out what are the adequate settings to reduce CPU power under any circumstance instead of having to replace the thermal paste?
     
    Last edited: Apr 16, 2017
    anytimer likes this.
  4. anytimer

    anytimer Notebook Deity

    Reputations:
    159
    Messages:
    1,665
    Likes Received:
    109
    Trophy Points:
    81
    Try unplugging the power adapter during the update. The power management profile for battery mode is somewhat less agressive, so that might work for you.

    I do feel your pain - I'm in India and it is already 35 deg C ambient, which doesn't leave much headroom for CPU intensive work.
     
    Paloseco likes this.
  5. enri1357

    enri1357 Newbie

    Reputations:
    0
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    The only settings I have changed in the BIOS is: Display = Static, Throttle at 75 C

    The story is: I changed my thermal paste of CPU and leave the GPU pad untouched, I have problem on heavy workload such as HEVC play back shutdown vaio in 5 secs. I go find ways to disable Turbo Boost and it help stabilizing everything except playing those 10bit HEVC. I wonder why Turbo Boost ON will make thing bad, coz it should not as it has been advertised working

    What I found that is there are improper assembling last time I change the thermal paste. All 4 mounting points are on the CPU side: 1 copper, 2 black plastic on top of the heatsink, and 1 Back Plastic Fan clip at the bottom of the heatsink all mounted/clipped on the CPU/Fan plug side. When install back the board to the case, the heatsink lift up a bit making a improper contact of the GPU

    What I did that make it work is to clip Back Plastic Fan clip at the bottom to the other side:
    1. The heatsink copper clip has to be clipped to the CPU/Fan Power side
    2. The Back Plastic Fan clip at the bottom has to be clipped to the other side

    This make my VAIO work solid now, even Turbo Boost is ON

    Conclusion for my case:
    Turn OFF turbo boost might help, but it should work when it is ON
    The install back *of the heatsink/fan has to be careful

    (I know, your Z1 should have work for the past few years like that, just worth take a look)
     
    Last edited: Apr 18, 2017

Share This Page