Vaio Z11/13 screen brightness hotkeys Windows 8 RTM

Discussion in 'VAIO / Sony' started by wolfman-one, Aug 16, 2012.

Thread Status:
Not open for further replies.
  1. wolfman-one

    wolfman-one Notebook Enthusiast

    Reputations:
    9
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    5
    Hi,

    I've installed Windows 8 RTM from Technet.
    After installing:
    Sony Firmware Extension Parser Driver
    Setting Utlilty Services
    Sony Shared Library
    VAIO_Event_Service_5.3.0.05310

    the hotkeys to adjust screen brightness are not working.
    I can adjust the screen brightness via Windows on-board utilities.

    Are yours?

    Thanks
    Kind regards,
    wolfman-one
     
  2. Ambroos

    Ambroos Notebook Consultant

    Reputations:
    74
    Messages:
    188
    Likes Received:
    0
    Trophy Points:
    30
    I think you really need all the Sony tools to get them to work, possibly even Sony's own graphics drivers.

    I have given up on Windows 8 personally.
     
  3. AGabi

    AGabi Notebook Consultant

    Reputations:
    26
    Messages:
    163
    Likes Received:
    1
    Trophy Points:
    31
    I tried to install W8. Almost all sony drivers I installed with W7 compatibility. All Sony functional keys working good.
    Only video driver (ver.193) not working correctly- W8 has artefactes in interface after. As a result I retuned to W7)))
     
  4. wolfman-one

    wolfman-one Notebook Enthusiast

    Reputations:
    9
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    5
    I had absolutely no problem using Windows 8 Release Preview.
    I'm using the bios hack and fixed VGA.
    No problems with integrated Intel VGA drivers and Nvidia drivers from laptopvideo2go.
    The F keys won't' work with the RTM...
    Are you using the Release Preview or the final Windows 8 release?
     
  5. rescares

    rescares Notebook Guru

    Reputations:
    0
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    15
    I'm having the same issue on my SA.
    Are you able to see further settings in VAIO Control Center?, mine just shows the "system information"
     
  6. AGabi

    AGabi Notebook Consultant

    Reputations:
    26
    Messages:
    163
    Likes Received:
    1
    Trophy Points:
    31
    It was RTM. Try reinstall sony drivers through troubleshoot compatibility with W7. Unistall existing drivers before.
    Here is my order for installation:
    1. Windows 8
    2. Intel Chipset
    reboot
    3. Nvidia Graphics
    reboot
    4. Audio
    5. Ethernet
    6. MS Card
    7. SD Card
    8. Pointing Device
    9. Sony Firmware Extension
    10. Bluetooth
    11. Intel ME
    12. Intel Wireless
    13. Turbo Boost
    14. TPM (if needed)
    reboot
    15. Setting Utility Series (compatibility with W7)
    16. Sony Shared Library (compatibility with W7)
    17. VAIO Event Services (compatibility with W7)
    18. VAIO Control Center (compatibility with W7)
    19. VAIO Smart Network (compatibility with W7)
    reboot
    20. installing updates for sony utilities (compatibility with W7)
    reboot
     
  7. AGabi

    AGabi Notebook Consultant

    Reputations:
    26
    Messages:
    163
    Likes Received:
    1
    Trophy Points:
    31
    Today I install W8 with video driver from Andrew08. There are no artifacts. Switchable graphic, automatic brightness, all functional keys, VAIO Control Center working fine.
     
  8. anytimer

    anytimer Notebook Virtuoso

    Reputations:
    302
    Messages:
    2,160
    Likes Received:
    321
    Trophy Points:
    101
    Good to know. Thanks.
     
  9. SNicholson

    SNicholson Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    AGabi, can you point me in the direction of the video driver from Andrew08 please.

    I have the VPCZ128GG and am stuck on the Intel HD graphics at the moment due to the incompatible Windows 7 X64 driver (artefacts on screen as you highlighted)

    Many thanks in advance.
     
  10. AGabi

    AGabi Notebook Consultant

    Reputations:
    26
    Messages:
    163
    Likes Received:
    1
    Trophy Points:
    31
    1.Before installing video driver you need enable test mode
    - Open a command prompt as an admin and type:
    -bcdedit -set loadoptions DISABLE_INTEGRITY_CHECKS"
    -"bcdedit -set TESTSIGNING ON"
    2. Restart
    3.installing Andrew08 video driver from here http://forum.notebookreview.com/son...vaio-z-s-hybrid-graphics-252.html#post7176699. I using Nvidia 26314 - Intel 2266 signed version.
    4. Restart PC
    5.Disable test mode
    -Open a command prompt as an admin and type:
    - "bcdedit /deletevalue loadoptions"
    -"bcdedit -set TESTSIGNING OFF"
    6. Restart
     
Loading...
Thread Status:
Not open for further replies.

Share This Page