1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

Vaio Z Windows 7 Official driver available now!!

Discussion in 'Sony' started by achau, Oct 18, 2009.

Thread Status:
Not open for further replies.
  1. achau

    achau Notebook Geek

    Reputations:
    7
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    0
  2. tabrisfreewill

    tabrisfreewill Notebook Consultant

    Reputations:
    0
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    0
    I've installed the video driver (187.35) but the brightness adjust still does not work on speed mode.

    I did not, however, do a clean install of the graphics driver. I will try that after I do a clean install of Win 7 and see.
     
  3. eli2k

    eli2k Notebook Consultant

    Reputations:
    2
    Messages:
    273
    Likes Received:
    0
    Trophy Points:
    0
  4. reaborg

    reaborg Notebook Consultant

    Reputations:
    1
    Messages:
    215
    Likes Received:
    0
    Trophy Points:
    0
    Upon installation of nvidia driver, newer version is installed, but brightness still doesn't work in Speed mode.

    After installing Notebook utilities, brightness adjustment doesn't work in either stamina or speed mode. Guess its better to wait a bit until all the bugs are cleaned out.
     
  5. dLo GSR

    dLo GSR Notebook Enthusiast

    Reputations:
    0
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    0
    yeah using notebook utilities 5.0 doesnt allow the hotkeys to work in either stamina or speed; going back to 4.3 allows it to work in stamina again.
     
  6. 5ushiMonster

    5ushiMonster Notebook Deity

    Reputations:
    130
    Messages:
    728
    Likes Received:
    3
    Trophy Points:
    0
    I have a 2nd GEN Z with a P8600 CPU which came preinstalled with a x86 version of Vista.
    Planning on installing 6GB RAM along with Windows 7 PRO x64.

    I know that we need a CPU (Intel Chipset) driver or something, but Sony doesn't have models with x64 CPU driver for the P8600 processor - would I be ok just clean-installing 7 without the cpu (Intel Chipset) driver?
    The eSupport site actually has practically everything I need except that (and a working graphics driver...)

    Also, I/O drivers, Parser drivers; are there any variations between various Z models? Would it be safe to just go and install those?
    Really keen on upgrading - windows 7 gets released in 3 days after all....

    Cheers in advance
     
  7. TLN

    TLN Notebook Consultant

    Reputations:
    6
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    0
    If there's win7 clean install guide?
    I've installed W7 today andsome drivers after, now it shows up a BSOD on load in both modes =((
    I will install it again today one more time. What should i do to install all the drivers for devices?
     
  8. dLo GSR

    dLo GSR Notebook Enthusiast

    Reputations:
    0
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    0
  9. eli2k

    eli2k Notebook Consultant

    Reputations:
    2
    Messages:
    273
    Likes Received:
    0
    Trophy Points:
    0
    You can try the Intel chipset drivers directly from Intel's website.
     
  10. ngvuanh

    ngvuanh Notebook Deity

    Reputations:
    274
    Messages:
    1,138
    Likes Received:
    18
    Trophy Points:
    0
    I got weird problem when install new video driver.
    The desktop got shrink to only half of screen on the left and on the right side of the screen shows vertical lines as bad LCD.
     
  11. Zap-xpilot

    Zap-xpilot Notebook Guru

    Reputations:
    0
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    0
    Hi, second that, exactly the same problem.
    Just to doublecheck, I had installed updated versions of the SFEP and SPIO drivers before attempting the nvidia update

    Strangely enough, I didn't uninstall the older driver first, just ran the install for the new driver.
    Can this be the cause of the problem? It seems strange for sony to ship a notebook with a broken video driver?

    Tried on a European Z21WN vaio
     
  12. 5ushiMonster

    5ushiMonster Notebook Deity

    Reputations:
    130
    Messages:
    728
    Likes Received:
    3
    Trophy Points:
    0
    There is a Z user from another thread who runs Windows Server 2008 who has the same problem. So far, that is the worst case scenario (next to the BSOD above...)

    It is the new nVidia graphics thread (promoting the new driver) - they think that it is not the driver causing the problems, rather the EventServices (the app that displays volume and brightness levels on screen and plays other biggish roles on Vaios) that is buggy.

    But when some roll back to the Vista graphics driver, they (if they are lucky) get back brightness control with stamina and the usual no control with speed.

    Personally since hybrid is Sony-made, they have yet to intergrate their own hybrid graphics drivers and the new eventservice app - I will give them till 22nd this week. If not fixed, I am going to be the first asking some serious questions...

    ALL (at least, the last time I checked) are reporting that they lost brightness control in BOTH stamina and nvidia graphics with the new driver.

    Lets just wait for the 22nd and onwards; hopefully Sony is already aware of this and fixing as we speak (if not... Oh boy.... -_-*)
     
  13. Base

    Base Notebook Geek

    Reputations:
    0
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    0
    As I mentioned in the other thread I tried the new NVIDIA Driver with Win7 64B Prof resulting in the "just-half-the-screen"-Problem. It was still possible to switch between stamina (normal displaying) and speed (half screen). But no brightness control in both modes. After uninstalling the new driver and installing the old one for Vista 64B everything is as it was before the new driver.

    Tried it on a european Vaio Z (Z4).
     
  14. NHT

    NHT Notebook Evangelist

    Reputations:
    18
    Messages:
    525
    Likes Received:
    1
    Trophy Points:
    0
    I have the same problem with Seven x64, tried on Z31WN europe
     
  15. TLN

    TLN Notebook Consultant

    Reputations:
    6
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    0
  16. slpro

    slpro Notebook Geek

    Reputations:
    11
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    0
    Same here, european Z21WN
     
  17. NHT

    NHT Notebook Evangelist

    Reputations:
    18
    Messages:
    525
    Likes Received:
    1
    Trophy Points:
    0
    Fresh installation?
     
  18. TLN

    TLN Notebook Consultant

    Reputations:
    6
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    0
    Yes.
    Installing a 7600 build.
    Downloaded stuf for z750d/b and for 8xx series.
    Got BSOD after some driver installation.

    usin installation order from sony website for vista cause ther'e no one for seven.

    any ideas?
     
  19. NHT

    NHT Notebook Evangelist

    Reputations:
    18
    Messages:
    525
    Likes Received:
    1
    Trophy Points:
    0
    UEFI mode on or off?
     
  20. TLN

    TLN Notebook Consultant

    Reputations:
    6
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    0
    Dunno. How can i check it?
    I've enabled vt and advanced menu in BIOS.
     

Thread Status:
Not open for further replies.

Share This Page