USB 3.0 not working on my ASUS G74SX A2

Discussion in 'ASUS Gaming Notebook Forum' started by fermanagh, Aug 6, 2011.

Thread Status:
Not open for further replies.
  1. fermanagh

    fermanagh Notebook Enthusiast

    Reputations:
    0
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    5
    Sorry it took so long to get back on this post but USB 3.0 is still not working...

    I installed that USB Charge app but it doesn't even launch! I can see it in the task bar and see the icon ASUS Ai charger but clicking on it does nothing, and killing the task and restarting it does nothing either.

    For info, I'm running Windows 7 64 bit

    Yep, all USB 2.0 devices work perfectly when connected to the USB 3.0 port. If I connect my 3.0 device into the 2.0 hub it works fine.
     
  2. Chastity

    Chastity Company Representative

    Reputations:
    1,295
    Messages:
    6,545
    Likes Received:
    336
    Trophy Points:
    251
    Go into your BIOS, and go to the 2nd tab. You should see an entry for USB CHARGE. Please enable this. This does the same as the AI Charger application.

    Case: 1584769
     
  3. FlyingFalcon

    FlyingFalcon Notebook Evangelist

    Reputations:
    52
    Messages:
    395
    Likes Received:
    2
    Trophy Points:
    30
    I have a G53JW. I own a WD Passport and Samsung M2, both of which connects with the usb3.0 port to my computer perfectly well. But i tried connecting my friend's Samsung M2 usb3.0 hard disk via usb3.0 and my computer refuses to read it but my computer detects it as being connected because the led on the hard disk lights up and my computer makes the sound that plays when an external device is connected. It works on the usb2.0 port perfectly fine. What could the problem be?
     
  4. MRZEN

    MRZEN Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    I have the same problem on my UX31 ultrabook. Did you perhaps upgrade Windows 7 to the ultimate edition?
     
  5. fermanagh

    fermanagh Notebook Enthusiast

    Reputations:
    0
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    5
    Hello there,

    I installed the app and then enabled the setting in the BIOS. I still have the same issue as before...
     
  6. Chastity

    Chastity Company Representative

    Reputations:
    1,295
    Messages:
    6,545
    Likes Received:
    336
    Trophy Points:
    251
  7. FlyingFalcon

    FlyingFalcon Notebook Evangelist

    Reputations:
    52
    Messages:
    395
    Likes Received:
    2
    Trophy Points:
    30
    Hi people

    I just bought a Seagate 1.5tb usb3.0 portable hard disk because my WD MyPassport got screwed. I got it yesterday. I had plugged it into my usb3.0 port and the thing worked fine. I copied 250GB stuff from my internal hard disk to the Seagate and it did it very fast. Then disconnected the thing.
    Today, I tried connecting it to my USB3.0 port and it simply will not recognise my external. I connect it to the usb2.0 port and it works fine. Tried restarting but to no avail.

    Is there anything I can do to get it working on my usb3.0 port. I cannot find a powered cable here in Kerala, India. The AiCharge thing does not work on my laptop for some reason.

    ANy help will be appreciated.

    Regards,
    Vipin
     
  8. kimiraikkonen

    kimiraikkonen Notebook Evangelist

    Reputations:
    20
    Messages:
    383
    Likes Received:
    22
    Trophy Points:
    31
    Hi Vipin,
    I noticed G53JW has a BIOS update called "210" version here and its release note only contains "Update USB 3.0" which may be a fix against intermittent USB 3.0 connections. Thanks to Asus for providing non-brief explanation about release notes, though!:mad:
     
  9. fermanagh

    fermanagh Notebook Enthusiast

    Reputations:
    0
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    5
    Hi there, I successfully installed the updated version of the app this time and pushed it all the way to 99%. The 3.0 port still won't recognize my WD passport drive! I even went out and bought a 4 port powered USB 3.0 hub and it won't even accept the connection from my drive...?

    Any ideas Chastity?
     
  10. Wolfpup

    Wolfpup Notebook Prophet

    Reputations:
    128
    Messages:
    4,082
    Likes Received:
    13
    Trophy Points:
    106
    For the record, my G74's USB 3.0 port has always worked fine, with just the single driver for it downloaded from Asus' site. I've used it with two different USB 3.0 Seagate external drives, and then used a Tripp Lite USB 3.0 powered switch, which worked great too.

    Speeds really are much better...probably a minimum of twice as fast as 2.0 on my hard drives, and quite often 4x as fast.

    (My G74's keyboard went wacky I guess after I cleaned it, so now it's sitting under my desk running Folding @ Home on my CPU and GPU 24/7! It's doing THAT really well too so far :) )
     
Loading...
Thread Status:
Not open for further replies.

Share This Page