Upgrading to Nvidia GTX 770m on Alienware m17x R3

Discussion in 'Alienware 17 and M17x' started by Alienwarem17xR3s, Sep 15, 2013.

Thread Status:
Not open for further replies.
  1. MickyD1234

    MickyD1234 Notebook Prophet

    Reputations:
    3,157
    Messages:
    6,473
    Likes Received:
    1,161
    Trophy Points:
    331
    Double post!
     
  2. Robbo99999

    Robbo99999 Notebook Prophet

    Reputations:
    4,246
    Messages:
    6,780
    Likes Received:
    6,000
    Trophy Points:
    681
    Post #92 in this thread:

    http://forum.notebookreview.com/ali...-m17x-r3-460m-780m-questions-concerns-10.html

    There's a good description of how to install it there. Thing is, you've probably already tried all that, but I thought I'd put it there in case it gives you any ideas or makes you realise you may have done something wrong.
     
  3. frznto

    frznto Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    6
    Thanks Robbo, did try that, only thing that I can gleam from that post that I haven't tried is new thermal pads, seems like all component are making contact but never know if one isn't making full contact and the card senses it and wont allow for full boot-up...One possibility I haven't tried to fix for lack of thermal pads on hand. I work in a computer repair shop and my specialty apparently seems to be the higher end laptops and gaming computer as well as the headaches that go with. With lacking the 3D support it would suck but I could work with it, Don't 3D game much anymore just cause a 460 1.5GB card really doesn't make sense to me why that would be for 3D but a x80m series card doesn't have native 3D display support...

    Beeps wise Ive gotten 5 beeps twice now and the 8 beeps once and that was the last time it beeped at me.
    Unlocked bios wise, ive used for the performance settings for the cpu a little bit, not much but set the fan settings to help with the heat and of the such more so then not. Hate to loose the unlocked for the card to work. That being said if the stock bios isnt the cure is the unlocked bios still flashable on top of the stock bios or would i have to downflash back to A04 or some other level for how I had to originally unlock it.

    Thanks for all your help guys.
     
  4. Robbo99999

    Robbo99999 Notebook Prophet

    Reputations:
    4,246
    Messages:
    6,780
    Likes Received:
    6,000
    Trophy Points:
    681
    I don't think the thermal pads are the problem with your 770M. I think your card is just not compatible, it might be because the specific vBIOS you have is incompatible with the R3. Some users 'say' they have gotten a 770M to work, but none of the people who have said that ever uploaded a copy of their vBIOS when asked, which makes me suspicious as to whether anyone has actually got a 770M to work in an R3 (but at the same time why would anyone just make stories up about it!).

    I've flashed the unlocked SATA Tweak BIOS on top of a stock BIOS before without any problems.

    Maybe a good deal on a 680M might be a better solution for you if you send back your 770M for a refund. The 680M definitely works in the R3!
     
    MickyD1234 likes this.
  5. frznto

    frznto Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    6
    Okay well im gonna try doing the install with a stock bios here later and report back probably tomorrow. Fingers crossed.

    Thanks
     
    Robbo99999 likes this.
  6. atorre

    atorre Newbie

    Reputations:
    23
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Hi guys i solved the problem today i bought gtx 770m on ebay it arrived yesterday. I have an alienware 17mx r3 sandy bridge rev 09 hm67 B3 and i was with nvidia 460M before the upgrade , i got alot of truble at start , like 5 beep problems etc i was trying to install the card with a12 unlocked bios but things wont work and i culdnt pass neither the boot 5 beep problem, i noticed while trying that neither my old card was working anymore with this bios so i gone back to manufacture a12 bios , bios was not recognizing the card so i just pulled in pulled out alot of times, tough was a problem with pci enter(cos mine was a little bit ruined like the side plastic pins ar little bit broken etc so after alot of try , in the end i found the perfect positioning 1millimeter away from the right plastic remain of the pci and the bios found my old card so i did the same with the new one and magic it was recognized by the bios too tadannnnnnnnn , after this i ntered in windows and got White screen , so reading on others comment i got that for pass this block i had to disable hd integrated audio, and finally i was in windows , it recognized the card as generic nvidia video card , i took the drive from here : v335.23 Windows 8 64bit | NVIDIA OEM Mobile - GeForce r334 series - LaptopVideo2Go Forums
    i extracted it (save the path link like c:\NVIDIA\etc\etcetc you will get a error message like "hardawere not supported or somethign like this" so you open the path that you previus saved c:nvidia\displaydriver\335.23\win8_winvista_win7_64\international\display.driver and change the nvdmi.inf with this one :
    http://laptopvideo2go.com/infs/335series/33523_win8x64/nv_dispi.inf
    then you go in the upper folder ( c:nvidia\displaydriver\335.23\win8_winvista_win7_64\international\) and run the setup.exe and job is done! congratulation
    after the istallation i tryed to put back on the integrated hd audio but got again the non working windows this time with full blu screen instead of white so atm i dont have the solution for running the integrated audio but im very happy to have my video card updated :D

    I Hope that my story can help some one and sorry for my poor language but im from Italy and my English is not so good but i try :D
     
  7. Stijn107

    Stijn107 Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    could u please upload the nvdmi.inf file you used (the one in the comment is a dead end here )
    ive gotten passed the bios problems and found a solution for the sound problems aswell (just went through usb ports and bluetoot for sound so the startup doesnt get white screen )
    the only problem is getting the driver installed on the 770 M for the games.
    and the only thing i need for that ( i hope ) is the correct inf file
    modding it myself has not been a succes so far
     
  8. atorre

    atorre Newbie

    Reputations:
    23
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5

    hey mate for the driver just go here : LaptopVideo2Go hardware and driver community

    i do like this , go on nvidia site and check the latest driver for your card for example mine now are 335.23 WHQL latest then go to the site i gave to you and check series in the forum are divided by series category (our for example is GeForce r334 series ) so just get the one for your system get the nvdmi.inf file or just open text pad and ctrl copy paste and you have done.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page