Toughbook CF-19 Mk5 Windows 10 WAN problem

Discussion in 'Panasonic' started by micke656, Mar 30, 2021.

  1. micke656

    micke656 Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Hello

    I have a strange problem with 8 computers, that have Windows 10. The computers are Toughbook CF-19 MK5, and the WAN card they have installed is Sierra Wireless Gobi 2000.

    The problem is that when Windows starts, I can not activate the mobile connection. Wifi starts up normally. If I first turn on flight mode, and after that turn off flight mode, it activates the mobile connection, and after that I can use the Gobi 2000 card. The problem is that these computers should have access to Internet when they start, so this is really a bit of an issue.

    Windows 10 is the latest version, and what I've read on Internet, it looks like it might be the problem (I have not experienced this problem earlier) - Windows 10 just won't me downgrade.

    I have also tried a Ericsson F5521gw card from an other CF-19 Mk5 - it works perfectly, and connects automatically to the Internet.

    So, the question : is there any way to get the Gobi 2000 card to work correctly? An other solution is to buy Ericsson F5521gw cards on ebay - they question is, how do I know that those cards are compatible to the CF-19 Mk5 computer?

    Thankful for any help!
     
  2. BaRRmaley

    BaRRmaley Notebook Deity

    Reputations:
    206
    Messages:
    1,379
    Likes Received:
    451
    Trophy Points:
    101
    If you have Wireless switch utility installed - disable it in task manager's startup list. If it's not installed - install and disable.
    Or install and not disable if previous advices don't help.
     
    Toughbook likes this.
  3. micke656

    micke656 Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    I will give it a try - I have tried to disable the Wireless switch from the BIOS, but it did not help. Wireless Switch utility is installed. Should I have the wireless switch enabled in the BIOS, and disable it from the start-up list?
     
  4. BaRRmaley

    BaRRmaley Notebook Deity

    Reputations:
    206
    Messages:
    1,379
    Likes Received:
    451
    Trophy Points:
    101
    ++
     
  5. micke656

    micke656 Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Hello

    I enabled Wireless Switch in BIOS, and disabled it from startup. No difference, I still have to click on the Windows "Flight mode" button.

    When Windows 10 starts, it finds the SIM card, and tell the operator and shows the network strength for mobile data. Underneath, it says" Turned off". By activating flight mode and turning flight mode off again, the Mobile connection activates an connects.

    I tried also to uninstall and reinstall Wireless switch - the problem is that I am not able to do it: "Set the wireless LAN to [Enable] before uninstalling the Wireless Switch Utility"
    No difference if the switch is "on" or "off" - same message pops up.
     
  6. Toughbook

    Toughbook Drop and Give Me 20!

    Reputations:
    1,267
    Messages:
    7,356
    Likes Received:
    364
    Trophy Points:
    251
    Look into your startup apps also. You want Win 10 to control your WWAN so you might need to disable the switch in startup... I had this issue years ago and fiddled around with it until it worked. I just don't remember what I did.
     
  7. micke656

    micke656 Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Hello

    That was exatcly what I did - just disabling the wireless switch program from starting up did not solve the problem. Please try to remember what you did :)
     
  8. BaRRmaley

    BaRRmaley Notebook Deity

    Reputations:
    206
    Messages:
    1,379
    Likes Received:
    451
    Trophy Points:
    101
    @micke656, anyway, you will have to win this fight vs wireless switch utility :))
    Gobi 2000 is too old for win10. I recommend to install smth like mc8355 and forget about that time bomb. I think it's about USD40 total for all your 8pcs.
     
  9. micke656

    micke656 Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    These mc8355 cards are hard to find in Europe, but I managed to get six Ericsson cards, they work without any problems.
    But if someone knows a fix for the Gobi 2000, I appreciate your help!
     
Loading...

Share This Page