Toshiba x775 GTX 560 M not detected by games

Discussion in 'Toshiba' started by citivsaltivsfortivs, Sep 17, 2013.

Thread Status:
Not open for further replies.
  1. citivsaltivsfortivs

    citivsaltivsfortivs Notebook Enthusiast

    Reputations:
    9
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    5
    Hi everyone,

    I have owned Qosmio x775 q7272 for 2 years. Now my Geforce gtx 560m is not working. I am sure it is not dead because it shows up in device manager and when I uninstall it and press "Scan hardware changes" it is found right away. But whenever I try to do sth using the card, the notorious "display driver stopped and came back" appears. Please do not advise to switch to older drivers because I already tried all of them. And the weird part is that whenever I start Nvidia Inspector to check the state of the card, it shows the card is under 95-99 per cent load. The temps are fine. I already opened it up and tried to disconnect and reconnect my GPU but I cannot because it is under the motherboard and although I know how to open the upper surface of the PC, i find it impossible to take the mother board entirely off the case. And by the way I already tried a full format of Windows 8 and even underclocking the GPU. Even telling me to find a switch or cable to disconnect and reconnect the GPU to the mobo would be useful.
    Pls help because Fifa 14 is demo is out and it is painful to be unable to play it. THX in advance...
     
  2. Priest-King

    Priest-King Notebook Consultant

    Reputations:
    95
    Messages:
    201
    Likes Received:
    2
    Trophy Points:
    31
    A lot of people have complained about Windows 8 and it's performance in games, perhaps that is the problem.
    Try going back to Windows 7 and see how it does. It may simply be Windows 8 that is causing the problems.
    I have an X875 that came with Windows 8 but I wiped Windows off of it, and Installed Windows 7 Ultimate and have suffered none of the problems that others have complained of with theirs, plus with Windows 7 I got much higher benchmark scores on 3DMark. I know of several posts at the Toshiba forums for the US where users posted that their game performance was much much faster with Windows 7 than it had been with Windows 8.
     
  3. citivsaltivsfortivs

    citivsaltivsfortivs Notebook Enthusiast

    Reputations:
    9
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    5
    Thanks Priest King but no improvement whatsoever... Any else recommendations anyone?
     
  4. Priest-King

    Priest-King Notebook Consultant

    Reputations:
    95
    Messages:
    201
    Likes Received:
    2
    Trophy Points:
    31
    Did you install the intel graphics drivers from the Toshiba site first? If not, then that is likely the problem. You cannot install the Nvidia driver until after the intel driver is installed.
     
Thread Status:
Not open for further replies.

Share This Page