Toshiba satellite c850 fails to boot & black screen

Discussion in 'Toshiba' started by helenedwards, Jan 14, 2017.

Thread Status:
Not open for further replies.
  1. helenedwards

    helenedwards Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    My Toshiba satellite c850 stopped working yesterday. Battery was drained at some time during the day, then we plugged in and started came up with lines of screen instead of starting normally. Turned off, now only gives me a black screen with not boot and fans / drive spinning. Tried a numebr of times taking battery out holding the power butto and putting back in, but still no luck. Any suggestions?
    _________________________________
    Relax: ringtones, message tones
     
    Last edited: Feb 8, 2017
  2. Charles P. Jefferies

    Charles P. Jefferies TG Lead Moderator Super Moderator

    Reputations:
    14,515
    Messages:
    36,137
    Likes Received:
    2,458
    Trophy Points:
    581
    Hey there,
    It could be the CMOS battery on the motherboard, but that's a long shot.
    You also might try hooking up an external monitor and then booting up the system, see if you can get a picture to display.

    Charles
     
    Ultra Male likes this.
  3. Ultra Male

    Ultra Male Super Tweaker

    Reputations:
    15,373
    Messages:
    18,023
    Likes Received:
    25,071
    Trophy Points:
    931
    Did you try fully charging it again? How long have you had it? I hope it's still under warranty.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page