Titan X - bad performance - cpu is old but at 40% usage

Discussion in 'Alienware Desktops' started by Alienware Gamer ALX, Sep 5, 2016.

Thread Status:
Not open for further replies.
  1. killkenny1

    killkenny1 Too weird to live, too rare to die.

    Reputations:
    7,550
    Messages:
    4,492
    Likes Received:
    8,814
    Trophy Points:
    581
    So your PC started having performance issues just recently?
    Did you install any software prior to game performance decrease?
    How about other games, how to they perform?
     
  2. Cass-Olé

    Cass-Olé Notebook Consultant

    Reputations:
    393
    Messages:
    291
    Likes Received:
    686
    Trophy Points:
    106
    [​IMG]
    this image, found in NBR Aurora Owner's Lounge, portends to be TitanX; as I zoom in, it appears this person chose to run it off of only one video-cable (6pin + the parasitic jumper --> if so, then why the power supply doesn't shut-off / reboot under load is odd). Aurora with the 875watt (part# J556T or W299G) has two cables (each cable has a primary 6pin & a jumper 6+2) & each cable is on its own 12volt rail (18amps per rail)
    [​IMG]
    the proper way to connect a solo-card is to use the blu-wht & blu-ylw, thus deploying both cables / both 12volt rails into the card. So long as yours is connected properly, just to have a good steady power base to feed it with, you might explore your Bios & ensure it has PCI-E Gen3 enabled ... check both
    [​IMG]
    Whether you have this cooler or not, shown is the R4 Premium cooler, part# 01YGW (available on eBay at times ~$50/$80 used: play the waiting game, they pop up often & sell qwick); 38mm wide radiator with copper base, whereas the non-premiums are 25mm with aluminum base; these are a direct drop-in for all R1-R4 & recommended for 130watt Sandy/Ivy-E to help bring temps down. General tips here: how to get my Aurora R3 to run cooler
    ____________
    RMA / return your T-Rex as a last resort, it might be bunk​
     
    Last edited: Sep 11, 2016
    TomJGX likes this.
  3. Alienware Gamer ALX

    Alienware Gamer ALX Notebook Enthusiast

    Reputations:
    0
    Messages:
    32
    Likes Received:
    15
    Trophy Points:
    16
    it was pretty ok with 7970ghz crossfire, then i upgraded to titanx and i have about the same performance

    sistem is brand new because i formatted recently

    the other games are all disappointing, not 30fps, but less than the other titanx


    man your advice is good for another reason:
    my actual problem is not heat related, because it s present also at default with good temps, but i had a problem keeping temps ok with cpu overclock and i m going to buy the aurora

    Premium cooler, part# 01YGW for sure!

    psu is ok man , it s only 1 card and i connected 2 cables from 2 different lines :)
     
    Last edited by a moderator: Sep 9, 2016
  4. alawadhi3000

    alawadhi3000 Notebook Consultant

    Reputations:
    4
    Messages:
    126
    Likes Received:
    35
    Trophy Points:
    41
    GPU usage is 99% so its the GPU.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page