Titan X - bad performance - cpu is old but at 40% usage

Discussion in 'Alienware Desktops' started by Alienware Gamer ALX, Sep 5, 2016.

Thread Status:
Not open for further replies.
  1. Alienware Gamer ALX

    Alienware Gamer ALX Notebook Enthusiast

    Reputations:
    0
    Messages:
    32
    Likes Received:
    15
    Trophy Points:
    16
    my cpu is really old (2012), but i think it s not its fault

    This is Battlefield 1 beta: (here you can blame that s a new game)



    Black ops 3 (older is a little better)



    ...









    this is old, and also here i have fps drops (more than BO III)



    cpu is at 40% usage, so i cant blame it
     
    Last edited by a moderator: Sep 5, 2016
  2. rinneh

    rinneh Notebook Virtuoso

    Reputations:
    366
    Messages:
    3,765
    Likes Received:
    1,468
    Trophy Points:
    231
    Is it a pre sandy bridge cpu? Even my 5ghz ocerclock sb 2500K is a bottleneck nowadays. My cpu is fluctuating constantly between 60 and 90% usage causing dips in BF1.

    edit: sorry i misread. I thought your GPU had low usage.

    Now that is strange because an older CPU would be utilized to the fullest.
     
    Last edited: Sep 5, 2016
  3. Alienware Gamer ALX

    Alienware Gamer ALX Notebook Enthusiast

    Reputations:
    0
    Messages:
    32
    Likes Received:
    15
    Trophy Points:
    16

    it s 3970x, can handle 5ghz but it s old.

    i m not sure i can blame the cpu
     
  4. TomJGX

    TomJGX I HATE BGA!

    Reputations:
    1,449
    Messages:
    8,708
    Likes Received:
    3,311
    Trophy Points:
    431
    BF1 kills everything, especially the GPU... Its horribly unoptimised now so I would suggest another game like overwatch to compare!!
     
  5. Alienware Gamer ALX

    Alienware Gamer ALX Notebook Enthusiast

    Reputations:
    0
    Messages:
    32
    Likes Received:
    15
    Trophy Points:
    16
    low fps on the other games too man
     
  6. StormJumper

    StormJumper Notebook Virtuoso

    Reputations:
    497
    Messages:
    3,136
    Likes Received:
    370
    Trophy Points:
    151
    Since you didn't post what system or specs how would you expect others to know what is going on or figure what to do? No details specs and no one can help you set things to work properly. There are many factors that can be a bottle neck but lack of details won't get help fast.
     
    James D, killkenny1 and TomJGX like this.
  7. TomJGX

    TomJGX I HATE BGA!

    Reputations:
    1,449
    Messages:
    8,708
    Likes Received:
    3,311
    Trophy Points:
    431
    Agreed that would help.. Also put temps from Hwinfo64 after playing the games for a while... Stuff like this will make the answer easier...
     
  8. Alienware Gamer ALX

    Alienware Gamer ALX Notebook Enthusiast

    Reputations:
    0
    Messages:
    32
    Likes Received:
    15
    Trophy Points:
    16
    tnx all, the config is:


    Alienware Desktop: [Alienware Aurora ALX]
    Monitor : [Alienware OptX AW2310]
    Keyboard :[Alienware TactX Keyboard]
    Mouse: [Alienware TactX Mouse]

    CPU : 3970X @ 5GHz (Intel EE Extreme Edition)
    RAM: 32GB
    SSD: 1TB
    HD: 4TB
    GPU: Titan-X


    the only problem i can address is the old cpu


    edit, i tried it also at default, with very low temps and it s exactly the same (oc seems to make no difference at all)
     
  9. TomJGX

    TomJGX I HATE BGA!

    Reputations:
    1,449
    Messages:
    8,708
    Likes Received:
    3,311
    Trophy Points:
    431
    Hmm.. Have you tried a Windows reinstall? I have a feeling your Windows might be borked.. Do a fresh install and then install the motherboard/Intel/GPU drivers etc.. Use new versions of the Intel drivers if you can dig them out from somewhere.. Also when you say low temps, how low?

    Sent from my LG-H850 using Tapatalk
     
  10. Alienware Gamer ALX

    Alienware Gamer ALX Notebook Enthusiast

    Reputations:
    0
    Messages:
    32
    Likes Received:
    15
    Trophy Points:
    16

    w10 is a fresh install, i placed a new ssd and it s brand new

    temps are overall high, but Tj for my cpu is 91' and everything under 80 is ok for me i think
     
Loading...
Thread Status:
Not open for further replies.

Share This Page