The ThrottleStop Guide

Discussion in 'Hardware Components and Aftermarket Upgrades' started by unclewebb, Nov 7, 2010.

  1. Fernando Pena

    Fernando Pena Notebook Enthusiast

    Reputations:
    0
    Messages:
    34
    Likes Received:
    4
    Trophy Points:
    16
    Mine is a 8550U. It's already a lot better after some tweaking, but I still suffer from throttling sometimes.
    I set the max clock to 3.2ghz, -0.100 voltage offset and 45W in both PL1 and PL2. I get a max of 85°C on heavy load.
    While benchmarking I noticed it reaches around 28-29W and starts to decrease to less than 25 after a few seconds, I'm not sure if PROCHOT is the culprit, even though it's disabled in throttlestop... Any tips for me?
     
  2. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,710
    Messages:
    5,613
    Likes Received:
    4,333
    Trophy Points:
    431
    On some Dell laptops, the turbo power limits will be enforced regardless of your settings in ThrottleStop or Intel XTU. Are you using the ThrottleStop - FIVR - Disable and Lock Turbo Power Limits feature? When you are benchmarking, open up the Limit Reasons window and see what is glowing in red when your CPU starts throttling. Make sure HWiNFO is not running in the background when testing with Limit Reasons.

    If the above option is enabled and your power limits are set to 45W in ThrottleStop and these power limits are being ignored, that means the EC is likely throttling you down to 25W or less. The 8550U has a TDP rating of 15W so anything above this is a bonus. Some laptop manufacturers leave things wide open so you can go way beyond 15W but some other laptop manufacturers do not.

    Why not post some TS screenshots while you are benchmarking so I can have a look. The main screen, the TPL and FIVR screens and Limit Reasons will show me a lot of info without me having to ask 101 questions or guess at how you might have TS setup.
     
  3. Fernando Pena

    Fernando Pena Notebook Enthusiast

    Reputations:
    0
    Messages:
    34
    Likes Received:
    4
    Trophy Points:
    16
    Yes, I'm using "Disable and Lock Turbo Power Limits". Without that my cpu stick with the default values.
    It usually flashes EDP OTHER in RING and THERMAL in one of the other 3 columns. I got a Thinkpad E480 btw.

    My machine does run above 15W and HWiNFO shows correctly 45W in both PL1 and PL2, so I think this is working properly. Yesterday I downclocked from 3.2 to 3.0 and that was a LOT more stable while gaming. The system wasn't asking more than 23W of PKG POWER.

    limits.png
    FIVR.png
    TPL.png
     
    Vasudev likes this.
  4. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    7,360
    Messages:
    10,397
    Likes Received:
    7,665
    Trophy Points:
    931
    I don't think you can adjust Turbo Ratios on your ULV chip. You can safely disable C1E since its not used in modern CPUs.
    You can now tweak Speedshift (Main window) and Intel Power balance values (in TPL window)
     
    Fernando Pena likes this.
  5. Fernando Pena

    Fernando Pena Notebook Enthusiast

    Reputations:
    0
    Messages:
    34
    Likes Received:
    4
    Trophy Points:
    16
    Yes, it's possible. It's working perfectly fine here.
    EDIT: Clocks don't go higher than 3.0, exactly how I set in Turbo Ratios.

    Thanks, I was really wondering about the need of C1E.
    EDIT: I'm ok with speed shift 128, if set that to zero cpu will run at full speed all the time, even in idle. 128 keeps the clock at about ~800mhz and the response is pretty quick if I need more speed.
     
    Last edited: Feb 26, 2019
  6. Fernando Pena

    Fernando Pena Notebook Enthusiast

    Reputations:
    0
    Messages:
    34
    Likes Received:
    4
    Trophy Points:
    16
    About Intel Power Balance, I'm not sure what values to put there...
    I see this is some kind of TDP distribution between Intel CPU and GPU, but what behavior should I expect if I put CPU 31 / GPU 0?
     
  7. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    7,360
    Messages:
    10,397
    Likes Received:
    7,665
    Trophy Points:
    931
    Maybe that's a bug in BIOS. Usually 8xxxU series and any HQ/ULV chips can't adjust multipliers. Only HK/K series can increase/decrease multipliers. If it is indeed a bug, don't upgrade BIOS ever.
    Put speedshift value of 80 for on-demand max boost. 128 takes a little time to adjust to demanding tasks.
     
    pressing and Fernando Pena like this.
  8. Fernando Pena

    Fernando Pena Notebook Enthusiast

    Reputations:
    0
    Messages:
    34
    Likes Received:
    4
    Trophy Points:
    16
    Maybe that's the case, because I don't upgrade the BIOS for quite some time.
    I actually downgraded it in the past because in newer versions Lenovo throttles the dGPU to the point that it's useless.
    I'm running v1.13. The newest one is 1.28.

    Or maybe that's just a thinkpad thing...

    Thanks for the tip, I'm gonna test with 80. This parameter only affects the idle clock, right? So in consequence it takes less time to go from idle to full speed when it's needed...
     
    Vasudev likes this.
  9. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    7,360
    Messages:
    10,397
    Likes Received:
    7,665
    Trophy Points:
    931
    Thinkpad T series? They do throttle dGPU after couple of BIOS updates, reduce core/memory clocks by BIOS update.
     

    Attached Files:

  10. Fernando Pena

    Fernando Pena Notebook Enthusiast

    Reputations:
    0
    Messages:
    34
    Likes Received:
    4
    Trophy Points:
    16
    E series actually. Thinkpad E480.
    They started to throttle dGPU on bios 1.14. So I'm stucked with 1.13, but that's ok, everything works as it should.
     
Loading...

Share This Page