The ThrottleStop Guide

Discussion in 'Hardware Components and Aftermarket Upgrades' started by unclewebb, Nov 7, 2010.

  1. Papusan

    Papusan JOKEBOOKs Sucks! Dont waste your $$$ on FILTHY

    Reputations:
    26,162
    Messages:
    24,809
    Likes Received:
    43,850
    Trophy Points:
    931
    You can start to read this two... And Apple is on same level. Only worse.
    http://forum.notebookreview.com/thr...950h-coffee-lake.810891/page-92#post-10769126

    http://forum.notebookreview.com/thr...rmance-explained-by-notebookcheck-net.808983/
     
    Ashtrix, raz8020 and Maleko48 like this.
  2. UNFORSWEATABLE

    UNFORSWEATABLE Notebook Enthusiast

    Reputations:
    0
    Messages:
    16
    Likes Received:
    7
    Trophy Points:
    6
    I have a i5-8250U (-90mW, Turbo Ratio Limit from 34 is on 31, TB Long Power 25W and Short Power is 44W) everything is fine until the Windows 10 is on "Best Performance" mode (Which lock the CPU speed to 3.1GHz always).
    If I change it to "Better Performance" (Which let the CPU go down from 3.1GHz) after a while i get BSOD during the Battlefield 4. What is the reason of this? Its because of the -90mW?
     
  3. andreacos92

    andreacos92 Notebook Enthusiast

    Reputations:
    0
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    5
    Hi, I have an Asus ROG notebook with a i7-4710HQ and latest version of ThrottleStop.

    CPU is Haswell, so with the integrate voltage regulatore FIVR.
    I OCced to 3.7 an all 4 cores and during stress test with AVX2 (AIDA64 FPU for example), after some minutes I notice some throttling caused by VR thermal limit.
    In these conditions, Max Power is above 80W, so it's quite normale for a CPU of 47W TPU.

    Limit Reasons shows VR THERMAL on both Core and Ring.

    My question: is it the VRMs on the motherboard or the integrated FIVR on the CPU package that hits the VR thermal limit?


    Thanks in advance :)
     
  4. Ionising_Radiation

    Ionising_Radiation ?v = ve*ln(m0/m1)

    Reputations:
    671
    Messages:
    2,783
    Likes Received:
    2,321
    Trophy Points:
    181
    I still can't find that annoying little thing that's keeping my CPU from going to deep sleep states. I feel it's my mouse/touchpad, but I can't pin it down. C0% is still quite high.
     
  5. Takeishi

    Takeishi Notebook Guru

    Reputations:
    6
    Messages:
    56
    Likes Received:
    17
    Trophy Points:
    16
    Did you do some stress testing after your undervolt to make sure it was stable? And even if it is, there are cases where there is a BSOD after the CPU goes from a high load to a small load (or clock speed). Having the CPU locked at 3.1GHz might be preventing that from happening.
     
  6. Maleko48

    Maleko48 Notebook Evangelist

    Reputations:
    185
    Messages:
    679
    Likes Received:
    505
    Trophy Points:
    106
    Ionising_Radiation likes this.
  7. Temp1234453

    Temp1234453 Notebook Consultant

    Reputations:
    12
    Messages:
    187
    Likes Received:
    30
    Trophy Points:
    41
    Did you manage to fix that? My 7700HQ doesnt go deeper than C3 on idle
     
  8. Maleko48

    Maleko48 Notebook Evangelist

    Reputations:
    185
    Messages:
    679
    Likes Received:
    505
    Trophy Points:
    106
    Are you running on AHCI or RAID? Are your SSD(s) set to Lowest or HIPM+DIPM in Window's advanced/hidden power options?
     
  9. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,984
    Messages:
    5,753
    Likes Received:
    4,694
    Trophy Points:
    431
    ThrottleStop 8.70.6
    https://drive.google.com/open?id=19h2pOlAZWjP0UVecQw-i6HTJikgq_xzo

    - fixed Core i5/i7 4xx0HQ Haswell, Crystal Well support.

    I think I saw this problem a long time ago but must have forgot about it. I need to be nagged more to fix bugs like this. I would like nothing more than to blame Apple but in this case, it is all my fault. The CPUID for a 4980HQ is 0x40661. In two separate places within the ThrottleStop code, I forgot to write the 0x part of that number so ThrottleStop has not been detecting any of the Crystal Well series correctly. Here is Intel's list of Crystal Well based processors.

    https://ark.intel.com/products/codename/51802/Crystal-Well

    Hopefully Limit Reasons is no longer grayed out so you can finally see why your CPU is throttling and also do some under volting to minimize the problem.

    If setting the Non Turbo Ratio to 1 fixes your problem, the actual throttle reason might not show up in Limit Reasons. This is a sign that Apple simply turns off Intel Turbo Boost when the GPU is active. Lenovo does the same thing on my Y510P. Nowhere in the specs do they ever tell users about this "feature". It is a real slippery, slimy business practice to include high performance hardware, deliberately castrate it so it cannot perform at its full rated speed and then turn to denial when they inevitably get caught. :vbfrown:

    I am not a violent person but anyone that tried to tell me that might get a punch in the face. I have never heard a lie quite that ridiculous.

    For a Non Turbo Ratio example, if you set this to 18 and software or the operating system asks for a multiplier equal to or less than 18, the CPU will use that exact multiplier. If the OS asks for 12 or 15, the CPU will used the 12 or 15 multiplier. If the OS asks for a multiplier higher than 18, the CPU sees that you want a multiplier higher than the non turbo ratio so it determines that what you really mean is that you must want full turbo boost and will then use the maximum multiplier. Setting this to a low value like 1 is kind of a tricky way to get the CPU to ignore all of the lower / intermediate multipliers. In this mode, all the CPU knows is full speed ahead.

    The default speed for my 4700MQ is 2400 MHz which is the 24 multiplier. Technically speaking, my Y510P does not disable turbo boost. When the GPU is active, instead of asking for the maximum multiplier, it just asks for the 24 multiplier. The result is the same, just the method is slightly different. By setting the Non Turbo Ratio to 1, when the Y510P asks for the 24 multiplier, the CPU says, that multi is way higher than 1 so you must want full turbo boost. Full speed ahead and an easy and simple way to disable this throttling scheme. Sounds like either Apple has learned from Lenovo or vice versa. They both get a Fail.

    Post some TS screenshots of your 4980HQ. I might see something else that needs a tweak.
     
    Eason, FrozenLord, t456 and 5 others like this.
  10. 6.|THE|1|BOSS|.9

    6.|THE|1|BOSS|.9 Notebook Evangelist

    Reputations:
    900
    Messages:
    492
    Likes Received:
    964
    Trophy Points:
    106
    I almost pee'd on myself from laughing... no offence :)

    :eek:

    Can't blame you on that :rolleyes::) ;)
     
Loading...

Share This Page