The ThrottleStop Guide

Discussion in 'Hardware Components and Aftermarket Upgrades' started by unclewebb, Nov 7, 2010.

  1. Beempje

    Beempje Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    9
    Trophy Points:
    6
    I did. Just checked if I'm on the latest version, which I am (did a BIOS update last week).
     
  2. Vasudev

    Vasudev Notebook Virtuoso

    Reputations:
    594
    Messages:
    2,844
    Likes Received:
    1,340
    Trophy Points:
    181
    So, uncheck BD PROCHOT option in TS and play that game again and see if it fixes issues like strange stutters or throttling.
     
  3. Beempje

    Beempje Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    9
    Trophy Points:
    6
    Thanks for the suggestion. Actually my default profile (and the one I had running when the crashes occurred) already had BD PROCHOT unchecked. Also, it wasn't stutters or throttling, it was a total system freeze out of nowhere, with the game running like a dream just the second before...
     
    Vasudev likes this.
  4. Falkentyne

    Falkentyne Notebook Deity

    Reputations:
    900
    Messages:
    1,268
    Likes Received:
    1,242
    Trophy Points:
    181
    You're undervolting right?
    If the CPU is only using 11-12W, it means that there is almost no CPU power load, and thus the CPU is downclocking. If you are using ADAPTIVE VCORE, it means that the adaptive voltage is also being set lower. If you are undervolting, then the undervolt applies to BOTH the idle voltage and the load voltage. It's possible that at (low load) idle one of the voltage steps is unstable because of the undervolt. The way to fix this is to reduce the undervolt by a little bit.

    This is one of the problems with dynamic voltages. You can see the same thing happen with Pascal video cards. Set a certain overclock when NOT locking the voltage (if the voltage is locked with control L on a point, the vcore will only be reduced when hitting power limits or the temperature throttle -13 mhz steps), the card might be stable for hours at full load and higher heat, but when first starting a game, it may crash in the first minute, as the temps are low and the voltage hits a certain voltage step which winds up being unstable at that core clock.

    The "on/off" button only controls the power saving options in the main window (Speedstep, C1E). Not the profiles or monitoring.
     
    Vasudev likes this.
  5. Beempje

    Beempje Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    9
    Trophy Points:
    6
    Thanks for your reply! Yes, I am undervolting and your reply sounds plausible. I'll have to try it out later tonight. I'm pretty sure that I tested with a neutral normal volted profile too and saw the same results (crash), but I'll double check that too.

    I'll report back when I know more. Thanks for the replies so far! :)
     
    Vasudev likes this.
  6. Beempje

    Beempje Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    9
    Trophy Points:
    6
    Okay so I tested some more. Changed the game profile so there's no undervolt happening, made sure BD PROCHOT is unchecked. Yet the same behaviour occurs: a couple seconds after the fan kicks into high speed, the whole machine crashes and reboots. See the screenshots below for the settings I used, and the last couple of lines from the log right before it crashed.

    [​IMG]
    [​IMG]
    Code:
       DATE       TIME    MULTI   C0%   CKMOD  CHIPM   BAT_mW  TEMP  GPU     VID   POWER
    2017-10-11  21:00:51  27.51   21.4  100.0  100.0        0   68    63   0.9310   11.4
    2017-10-11  21:00:52  28.47   21.5  100.0  100.0        0   63    63   0.9349   11.9
    2017-10-11  21:00:53  27.94   20.9  100.0  100.0        0   65    63   0.9296   11.3
    2017-10-11  21:00:54  27.70   21.8  100.0  100.0        0   64    63   0.9143   11.6
    2017-10-11  21:00:55  27.57   21.3  100.0  100.0        0   68    63   0.9158   11.1
    2017-10-11  21:00:56  27.74   21.7  100.0  100.0        0   68    63   0.9523   11.6
    2017-10-11  21:00:57  27.50   22.0  100.0  100.0        0   67    64   0.9578   11.5
    2017-10-11  21:00:58  28.01   21.8  100.0  100.0        0   65    64   0.8909   11.5
    2017-10-11  21:00:59  27.41   21.7  100.0  100.0        0   67    64   0.9009   11.3
    2017-10-11  21:01:00  27.54   21.6  100.0  100.0        0   67    63   0.8856   11.4
    Any ideas? :)
     
    Vasudev likes this.
  7. Beempje

    Beempje Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    9
    Trophy Points:
    6
    Looking at my own reply I see the CPU cache is still undervolted, even though it says in my settings it isn't.... I'll see if I can reset it and if that changes things.
     
  8. Vasudev

    Vasudev Notebook Virtuoso

    Reputations:
    594
    Messages:
    2,844
    Likes Received:
    1,340
    Trophy Points:
    181
    Never undervolt iGPU. Any monitoring apps like HWINFO or HWMON running in background? Disable any Dell Command Center or similar.
     
  9. Beempje

    Beempje Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    9
    Trophy Points:
    6
    Thank you! Apparently the Dell Performance Optimizer was running in the background. I had no idea it existed, but there you go. The DPO and ThrottleStop were (probably) getting into a fight, resulting in the crashes. You live and learn :)

    Also, the undervolt on the game profile is a no-go apparently. Or at least not as much as I had it on. I tried setting the undervolt back while the game was running and it crashed instantly :p

    Thanks a bunch for the help guys! Sorry for asking newbie questions, it's a complicated piece of software but I'm starting to get the hang of it.

    Btw Vasudev, you said never to undervolt de iGPU. Can I ask why?
     
    Last edited: Oct 11, 2017
  10. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    5,671
    Messages:
    4,841
    Likes Received:
    1,794
    Trophy Points:
    231
    @Beempje - The Turn On - Turn Off button only applies to the Clock Modulation and Set Multiplier features. It dates back to the early days of ThrottleStop when users were too scared to use the program. Some day I plan to move that button and group it with those other settings so it is more logical.

    When using ThrottleStop to undervolt, if you clear the Unlock Adjustable Voltage box, this does not automatically reset the CPU voltage. The CPU will be left in its current state. If you want to reset the voltage offset to 0, It is up to you to do this first, before disabling this feature. That is probably why your cache is still undervolted in the screenshot above. Keep an eye on the monitoring table in the upper right corner of the FIVR screen when making adjustments. It is updated in real time so you will know what voltages the CPU is getting.

    When I see -125 mV for your cache undervolt, that makes me think that you started ThrottleStop, dragged the CPU Core and CPU Cache sliders all the way to the left and away you went. If that is the case, you need to undervolt in smaller steps and you need to do lots of stability testing along the way. Some CPUs can only be reliably undervolted -40 mV or -50 mV. When testing, don't just run a single game. You need to run a wide range of stability tests to make sure the undervolt you have selected is stable.

    A Speed Shift setting on the main screen of 128 is probably going to prevent your CPU from reaching its full potential. It can also lead to instability when you are undervolting. For maximum performance, a Speed Shift - EPP setting of 0 is recommended.

    Your CPU supports overclocking which you can enable in the FIVR window. You bought a high performance CPU, Intel built overclocking into your CPU so you might as well use it. Your temperatures seem OK so far. I would overclock first, adjust the voltage and then do some testing. ThrottleStop shows that you can increase each of your Turbo Ratios by +4. When first starting out, you might want to keep it simple. Check the Overclock box and set the 4 different core ratios equally to 39. You can increase the 1 Core Active multiplier as high as 43 but it will take more playing around with voltages to get this stable.

    @Vasudev probably doesn't recommend under volting the iGPU for stability reasons. When gaming, I assume your laptop has and is using the Nvidia GPU so under volting the Intel iGPU is probably not going to make a significant difference to power consumption or temperatures. Not worth risking stability.
     
    Vasudev, duttyend and Phoenix like this.
Loading...

Share This Page