The ThrottleStop Guide

Discussion in 'Hardware Components and Aftermarket Upgrades' started by unclewebb, Nov 7, 2010.

  1. kakashidinho

    kakashidinho Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    5
    Trophy Points:
    6
    Now the turbo profile is working correctly, seems like only at random waking up from sleep will make 4 cores turbo to be locked at 28
     
    Vasudev likes this.
  2. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    5,649
    Messages:
    4,826
    Likes Received:
    1,754
    Trophy Points:
    231
    @kakashidinho - When you are having problems, it is always a good idea to post a few screenshots. You might not have something set up correctly. The more screenshots the better. So much easier than me having to ask, how is this set, and that and that and that and........
     
    Vasudev likes this.
  3. kakashidinho

    kakashidinho Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    5
    Trophy Points:
    6
    Here are my profile settings:

    profile 1:
    [​IMG][​IMG]

    profile 2:
    [​IMG][​IMG]

    profile 4:
    [​IMG]

    TPL:
    [​IMG]

    Options:
    [​IMG]
     
    Vasudev likes this.
  4. Vasudev

    Vasudev Notebook Virtuoso

    Reputations:
    487
    Messages:
    2,558
    Likes Received:
    1,135
    Trophy Points:
    181
    Change clamp value to 45 and next value to 56 with Turbo time to 16 and uncheck Clamp option. Secondly, increase the primary power plane limit from 0.010 to 28. Enable Intel Power balance set CPU value to 31 and GPU to 9 or 13.
     
  5. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    5,649
    Messages:
    4,826
    Likes Received:
    1,754
    Trophy Points:
    231
    @kakashidinho - The Turbo Ratio Limits for Profile #1 and Profile #2 are both set to the 38 multiplier when 1 core is active and to the 36 multiplier when 2 cores are active. What sort of testing are you doing to show that this is not working correctly? If your turbo profiles are the same then for most loads you might not see any significant difference in the reported multiplier. A lot of tasks only use 1 or 2 cores simultaneously. Your Profile #4 with the very high EPP setting is probably going to interfere with your maximum multiplier. Thanks for your screenshots. I will do some testing but first you need to explain to me and post some pictures of what you are seeing that you think is a problem. It is possible that ThrottleStop is not setting the turbo multipliers correctly after you resume. I mostly use a single profile when using ThrottleStop so I might not have thoroughly tested this possibility. I always like chasing down bugs so a few more details will help me out.
     
  6. kakashidinho

    kakashidinho Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    5
    Trophy Points:
    6
    I used Prime95 to test all 4 cores max speed. Actually my laptop was suffering from overheating when stress testing all 4 cores (rendering is one usecase). that why I need fail safe profile 1 which limits the 4 cores turbo to 28 (base multiplier), also that's why I reduced max Turbo power limit to 40 to reduce heat. For the multiplier after waking up, currently seems like it works correctly so far. I observed that after waking up from sleep, if I immediately run prime95, the multiplier will sometimes initially be 28 for a few minutes, maybe shorter, then revert back to 34 correctly.

    One more question, does PROCHOT97 mean CPU will downclock if temp reaches 97c?
     
    Last edited: Sep 9, 2017
    Vasudev likes this.
  7. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    5,649
    Messages:
    4,826
    Likes Received:
    1,754
    Trophy Points:
    231
    @kakashidinho - PROCHOT stands for processor hot and if your laptop is set to 97°C, it will start slowing down to prevent the CPU from exceeding that temperature. It might go a degree or two beyond 97°C but that is still less than 100°C which Intel says is the maximum safe operating temperature so no worries.

    I did some testing and on my laptop, the turbo multipliers in TS seemed to be working correctly after resuming from sleep or when switching profiles. For your laptop, I would leave the turbo multipliers at their default settings. If the cooling system is not adequate, set the turbo power limit to 40 Watts, enable the Clamp option and let the CPU manage itself. It will automatically reduce the multiplier so power consumption and heat do not become a problem.

    Prime95 is not a great laptop testing tool. It consumes far more power than most laptops are designed for so you usually get immediate power limit (PL2) or (PL1) throttling, or EDP throttling or temperature throttling. I like Prime95 but on a laptop, maybe only run 2 or 4 threads of it and not 8. Watch Limit Reasons when testing to see what is causing any throttling.
     
    kakashidinho and Vasudev like this.
  8. plee82

    plee82 Notebook Evangelist

    Reputations:
    90
    Messages:
    466
    Likes Received:
    311
    Trophy Points:
    76
    Wow I was researching why I had a BD Prochot flag on my MSI GT62VR 6RE and finally figured out. If I unplug/plug charger, the BD Prochot is flagged. Very weird.
     
  9. link626

    link626 Asus GL502VM, Lenovo Y580, Asus K53TA

    Reputations:
    207
    Messages:
    1,667
    Likes Received:
    177
    Trophy Points:
    81
    my PROCHOT is set to 100c. When I am encoding with Adobe Premiere, gpu and cpu work together, and my cpu goes to 100c, even 101c, and Turbo Boost doesn't want to come down.

    6700hq Max turbo is 3.1ghz on 4 cores, and hwinfo64 says there's thermal throttling, but it only drops to 3ghz, and it keeps staying between 99-101c.
    One time, my laptop auto-shutdown while i was encoding, as it didn't throttle enough.

    How do I limit Turbo Boost multiplier? Can throttlestop do that?

    I want to limit to 28x or 29x
     
    Last edited: Sep 10, 2017
    Vasudev likes this.
  10. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    5,649
    Messages:
    4,826
    Likes Received:
    1,754
    Trophy Points:
    231
    @plee82 - Some laptops use BD PROCHOT which forces the CPU to run like an 800 MHz slug when on battery power. I would feel ripped off if my shiny new laptop was slower than a 10 year old laptop that was sitting in the closet collecting dust.

    @link626 - Intel designs their CPUs so they use as much turbo boost as possible, all of the time. I like that feature. Is there anyway you can improve your cooling? That is the real problem. If not then click on the FIVR button and try lowering the Turbo Ratio Limits a few notches. If your turbo power limits are unlocked, reducing the PL1 limit should prevent your CPU from running continuously at its full 100°C rated temperature.
     
    pressing and Vasudev like this.
Loading...

Share This Page