The ThrottleStop Guide

Discussion in 'Hardware Components and Aftermarket Upgrades' started by unclewebb, Nov 7, 2010.

  1. kakashidinho

    kakashidinho Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    5
    Trophy Points:
    6
    Hi, I have some problems with wrong Turbo Ratio Limit settings after waking up from sleep. I have 7700HQ and 2 profiles:
    - profile 1: max 4 cores turbo ratio is 28
    - profile 2: max 4 cores turbo ratio is 34
    After i put my laptop to sleep and then waking up, despite ThrottleStop displaying current profile was 2, it used the turbo ratio settings of 1 (i.e. max 28 ratio for 4 cores). I had to manually switch to profile 1 then back to 2, then the turbo ratio was back to be correct.

    P/S: I already used a script to kill and restart TS after waking up from sleep.
     
    hmscott likes this.
  2. Falkentyne

    Falkentyne Notebook Prophet

    Reputations:
    7,500
    Messages:
    5,572
    Likes Received:
    7,791
    Trophy Points:
    681
    Probably your computer Bios doing that. Throttlestop can't do anything if your Bios changes settings by itself. Sounds like the Bios turns off turbo boost if the computer goes into sleep. Or maybe it refreshes and read its internal settings. Have you tried changing it in the Bios to check that?

    For example if you used XTU and set the max 4 cores to 28, with TS still open, TS won't magically change it back to 34.
     
    hmscott and Vasudev like this.
  3. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    7,546
    Messages:
    10,458
    Likes Received:
    7,742
    Trophy Points:
    931
    Check profile settings on AC and battery in options. You must have set it to 1 for AC and battery which is the default value.
     
  4. kakashidinho

    kakashidinho Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    5
    Trophy Points:
    6
    No profile 2 is set for AC. Profile 1 is my failsafe settings when cpu reaches 90c (automatically switch to profile 1).
     
  5. kakashidinho

    kakashidinho Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    5
    Trophy Points:
    6
    Now the turbo profile is working correctly, seems like only at random waking up from sleep will make 4 cores turbo to be locked at 28
     
    Vasudev likes this.
  6. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,892
    Messages:
    5,692
    Likes Received:
    4,538
    Trophy Points:
    431
    @kakashidinho - When you are having problems, it is always a good idea to post a few screenshots. You might not have something set up correctly. The more screenshots the better. So much easier than me having to ask, how is this set, and that and that and that and........
     
    Vasudev likes this.
  7. kakashidinho

    kakashidinho Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    5
    Trophy Points:
    6
    Here are my profile settings:

    profile 1:
    [​IMG][​IMG]

    profile 2:
    [​IMG][​IMG]

    profile 4:
    [​IMG]

    TPL:
    [​IMG]

    Options:
    [​IMG]
     
    Vasudev likes this.
  8. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    7,546
    Messages:
    10,458
    Likes Received:
    7,742
    Trophy Points:
    931
    Change clamp value to 45 and next value to 56 with Turbo time to 16 and uncheck Clamp option. Secondly, increase the primary power plane limit from 0.010 to 28. Enable Intel Power balance set CPU value to 31 and GPU to 9 or 13.
     
    TheMile likes this.
  9. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,892
    Messages:
    5,692
    Likes Received:
    4,538
    Trophy Points:
    431
    @kakashidinho - The Turbo Ratio Limits for Profile #1 and Profile #2 are both set to the 38 multiplier when 1 core is active and to the 36 multiplier when 2 cores are active. What sort of testing are you doing to show that this is not working correctly? If your turbo profiles are the same then for most loads you might not see any significant difference in the reported multiplier. A lot of tasks only use 1 or 2 cores simultaneously. Your Profile #4 with the very high EPP setting is probably going to interfere with your maximum multiplier. Thanks for your screenshots. I will do some testing but first you need to explain to me and post some pictures of what you are seeing that you think is a problem. It is possible that ThrottleStop is not setting the turbo multipliers correctly after you resume. I mostly use a single profile when using ThrottleStop so I might not have thoroughly tested this possibility. I always like chasing down bugs so a few more details will help me out.
     
  10. kakashidinho

    kakashidinho Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    5
    Trophy Points:
    6
    I used Prime95 to test all 4 cores max speed. Actually my laptop was suffering from overheating when stress testing all 4 cores (rendering is one usecase). that why I need fail safe profile 1 which limits the 4 cores turbo to 28 (base multiplier), also that's why I reduced max Turbo power limit to 40 to reduce heat. For the multiplier after waking up, currently seems like it works correctly so far. I observed that after waking up from sleep, if I immediately run prime95, the multiplier will sometimes initially be 28 for a few minutes, maybe shorter, then revert back to 34 correctly.

    One more question, does PROCHOT97 mean CPU will downclock if temp reaches 97c?
     
    Last edited: Sep 9, 2017
    Vasudev likes this.
Loading...

Share This Page