The ThrottleStop Guide

Discussion in 'Hardware Components and Aftermarket Upgrades' started by unclewebb, Nov 7, 2010.

  1. Dufus

    Dufus .

    Reputations:
    1,194
    Messages:
    1,336
    Likes Received:
    542
    Trophy Points:
    131
    Absolutely, just when you thought you knew every insult in the book someone comes along and teaches you a new one. :D

    @Phoenix you could try maximum performance override MPO using RWEverything to set MCHBAR + 0x5590 (usually memory address 0xFED15990) to 0x14. Don't know if it works on SKL, worked on previous chips.
     
    tilleroftheearth likes this.
  2. Dannemand

    Dannemand Decidedly Moderate Super Moderator

    Reputations:
    5,893
    Messages:
    4,305
    Likes Received:
    852
    Trophy Points:
    181
    @Robbo99999 and @Phoenix: Indeed, a case can be made either way. You worked it out nicely, thank you for that!
     
    Robbo99999 and Ultra Male like this.
  3. illuzn

    illuzn Notebook Consultant

    Reputations:
    40
    Messages:
    126
    Likes Received:
    52
    Trophy Points:
    41
    I'm a noob so forgive me for asking a silly question... will this potentially ruin your computer permanently if you poke at the wrong address?
     
  4. Dufus

    Dufus .

    Reputations:
    1,194
    Messages:
    1,336
    Likes Received:
    542
    Trophy Points:
    131
    Well potentially one could disable over voltage protection and set HSW CPU voltage at 3V which should be more than enough to kill the CPU if poking the wrong places with the wrong data I suppose. Not that I've ever tried applying 3V to Haswell CPU's so only speculation on my part. Usually though it's much more likely to result in nothing or a BSOD.


    EDIT: revise statement for HSW, yes I have run much older Intel CPU's at over 3V, even over 5V. :p
     
    Last edited: Apr 19, 2016
    Papusan, i_pk_pjers_i and TomJGX like this.
  5. D2 Ultima

    D2 Ultima Livestreaming Master

    Reputations:
    4,285
    Messages:
    11,747
    Likes Received:
    9,669
    Trophy Points:
    931
    *eyes suspiciously*
     
    i_pk_pjers_i, TomJGX and Eason like this.
  6. Forssberg

    Forssberg Notebook Enthusiast

    Reputations:
    0
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    5
    The problem was Windows' 10 safety measures. This app requires more privileges than other apps it seems - this is why I had to modify local policies in gpedit.msc to be able to run this app.

    Regarding being stuck at 0.78Ghz, this app rarely works in my case.
    I have i5 2410m CPU. BIOS has almost no options regarding CPU. SpeedStep cannot be turned off there.

    Saying rarely I mean one time it forces CPU to be faster, another time it won't - regarding setting on\off SpeedStep, Clock Modulation or Chipset Clock Modulation.
    Multiplier never changes anything, same as changing button to Turn on from Turn off state.
    There is no way to force this CPU to change its state via this program with 100% accuracy - more time it just does randomly. Stubborn CPU :p
    It is laptop.
     
  7. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,281
    Messages:
    5,240
    Likes Received:
    3,450
    Trophy Points:
    431
    It sounds like you are randomly clicking on things without really understanding the problem or how you should set ThrottleStop up to try and solve it. Show me a screenshot of ThrottleStop while 1 Thread of the TS Bench test is running. I need to see what options you have checked off and I need to see your CPU stuck at 0.78 GHz. Make sure you are using the Windows High Performance profile with the Minimum processor state set to 100%.

    Turning SpeedStep off is the last thing you should be doing. The Set Multiplier feature will not work correctly when SpeedStep is disabled.
     
    duttyend and i_pk_pjers_i like this.
  8. Eason

    Eason Notebook Virtuoso

    Reputations:
    183
    Messages:
    2,161
    Likes Received:
    744
    Trophy Points:
    131
    TS is still being exited every time I unplug AC. If I try to restart it immediately it doesn't open, but a few seconds later it will launch okay. Any way I can track why it's exiting?

    (of course, exit on DC is 0)
     
  9. illuzn

    illuzn Notebook Consultant

    Reputations:
    40
    Messages:
    126
    Likes Received:
    52
    Trophy Points:
    41
    @Eason: I'm glad you asked I was going to post this anyway. I assume that you are using task scheduler to automatically launch Throttlestop. Check out step 8 below.

    Guide to automatically launching Throttlestop in Windows 10

    1. Launch Start, search for "Task Scheduler" and run it.
    [​IMG]

    2. Select your "Task Scheduler Library".
    [​IMG]

    3. Create a Task
    [​IMG]

    4. Name the task whatever you would like. Run it only when a user is logged on and Run it with highest privileges.
    [​IMG]

    5. Create a new trigger.
    [​IMG]

    6. The task should run at logon and the trigger should be enabled. I set it to automatically attempt to re-run every hour in case a crash causes it to exit accidentally (this is optional).
    [​IMG]

    7. Set the task to run Throttlestop. You will need to find this on your computer.
    [​IMG] [​IMG]

    8. Make sure you completely disable "Stop if the computer ceases to be idle" and "Stop if the computer switches to AC power". Even though these options may be greyed out, it appears that they still affect the task.
    [​IMG]
     
    Vasudev, toliyn, FrozenLord and 9 others like this.
  10. Eason

    Eason Notebook Virtuoso

    Reputations:
    183
    Messages:
    2,161
    Likes Received:
    744
    Trophy Points:
    131
    Thanks for the post. That was exactly the problem!
     
    Last edited: Apr 28, 2016
Loading...

Share This Page