The ThrottleStop Guide

Discussion in 'Hardware Components and Aftermarket Upgrades' started by unclewebb, Nov 7, 2010.

  1. Spartan@HIDevolution

    Spartan@HIDevolution Company Representative

    Reputations:
    30,135
    Messages:
    22,807
    Likes Received:
    35,133
    Trophy Points:
    931
    here you go bro, no load, just Chrome running and idle....

    ddd.png
     
  2. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,299
    Messages:
    6,081
    Likes Received:
    5,686
    Trophy Points:
    681
    Sorry, I meant put some load on the CPU and check the multiplier then. When lightly loaded, the CPU will be spending its time bouncing around between various low power C States so the multi can also be bouncing around. Some load on the CPU usually results in a steadier multi reading in ThrottleStop.

    The 100.00 MHz BCLK is looking better.
     
    Last edited: Apr 12, 2016
    Spartan@HIDevolution likes this.
  3. Spartan@HIDevolution

    Spartan@HIDevolution Company Representative

    Reputations:
    30,135
    Messages:
    22,807
    Likes Received:
    35,133
    Trophy Points:
    931
    ok a bit better now, I see core 3/4 dropped to 800 MHz.

    What I'm gonna do next is re-enable C-States in the BIOS since I had them disabled then check

    On a side note, the Cache Ratio is @ 20 / 2.0 GHz so is working right

    aaaa.png
     
  4. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,299
    Messages:
    6,081
    Likes Received:
    5,686
    Trophy Points:
    681
    That's not throttling. Post a screenshot of just ThrottleStop while under load. What HWiNFO reports for MHz can be a little misleading. In a Core i processor, at any instant in time, all active cores are locked to the exact same multiplier and frequency. You can have cores entering various C States but the active cores are always running the same multi. As well, all active cores are always using the exact same voltage.

    [​IMG]

    In this example, all of the C States are disabled so the multi is very steady at 20.00.
     
    Spartan@HIDevolution likes this.
  5. illuzn

    illuzn Notebook Consultant

    Reputations:
    56
    Messages:
    140
    Likes Received:
    71
    Trophy Points:
    41
    I don't think that's throttling... you aren't approaching any sort of conditions where throttling should occur.

    For me set multiplier has never worked on a i7-6500U.
     
    Spartan@HIDevolution likes this.
  6. sluggz

    sluggz Notebook Consultant

    Reputations:
    0
    Messages:
    182
    Likes Received:
    37
    Trophy Points:
    41
    Ok that makes sense. I have the 6820hk
     
  7. Spartan@HIDevolution

    Spartan@HIDevolution Company Representative

    Reputations:
    30,135
    Messages:
    22,807
    Likes Received:
    35,133
    Trophy Points:
    931
    ok here is a screenshot with your above settings, I can see the CPU still @ 4 GHz in task manager

    I know ThrottleStop is for preventing CPU throttling.

    What I am trying to do here is to force it to run @ 2.0 GHz to save power for when I am out in a cafe but maybe that isn't possible with the 6700K as you said.

    1.png
     
  8. illuzn

    illuzn Notebook Consultant

    Reputations:
    56
    Messages:
    140
    Likes Received:
    71
    Trophy Points:
    41
    Off topic: What! i7-6700K on a laptop holy dooly.

    You may find that artificially setting the multiplier to 20 constantly on battery power actually dents your battery life.

    The CPU is meant to throttle down under low loads - you will see that under idle some of your cores are already running at below 20 multiplier.

    What I have found helps is disabling CPU turbo. Running in turbo costs me around 50% more power for a 20% increase in clock speeds. Obviously in the race to sleep stakes this is terrible.

    Most of your power saving will come from c-states and allowing the CPU to throttle down (rather than sticking it at a constant 20x) e.g. I've got 8 apps open with 6 MS Edge tabs (including 1 playing a youtube 1080p video). My CPU is sipping a miserly 1.5-2W. At that burn rate its actually my screen and wifi which are eating up battery (and not CPU).
     
  9. Spartan@HIDevolution

    Spartan@HIDevolution Company Representative

    Reputations:
    30,135
    Messages:
    22,807
    Likes Received:
    35,133
    Trophy Points:
    931
    Not only a regular 6700K, but you can have it delidded for lower temps and can even opt for a binned Silicon Lottery 6700K for guaranteed 4.4 to 4.5 GHz overclocks on a laptop or even higher. In addition, G.Skill RAM of up to 2800 MHz on a laptop :D See:

    EVOC P870DM-G Gaming Laptop

    Secondly, I think I might just forget about forcing the CPU to run @ 2.0 GHz while on the Performance Plan and just use the Power Saving Plan in Windows which puts the CPU @ 800 MHz

    Ill just use Throttle Stop to prevent throttling while the GPU is being used during gaming as that is what is triggering my throttling down from 4.4 GHz to 4.0 GHz when gaming

    I have just increased the Turbo Power Max / Short Turbo Power max from 165W to 225W
     
  10. illuzn

    illuzn Notebook Consultant

    Reputations:
    56
    Messages:
    140
    Likes Received:
    71
    Trophy Points:
    41
    Last off topic post: That's bloody amazing that a desktop CPU can now be squeezed into a form factor resembling a laptop.

    I mean yes 4.8kg is not even approaching ultra book class but that was a fairly normal weight for most normal laptops even 5-6 years ago.

    I'm guessing the compromise is battery life (which is why you are here). That 10W idle power consumption for CPU alone can't be conducive to decent battery life (not that its designed to be used primarily on the road) - especially with a dGPU and huge monitor also chewing up power.

    If you are looking to get a little more portability out of it try these settings:
    - Disable CPU turbo on battery in your power plan (set the maximum processor state to 90-95 percent).
    - Let the CPU throttle itself down by enabling C-states and setting the minimum processor state to 5%.
    - See if you can completely disable the dGPU on battery - dGPUs are not exactly power sippers and my understanding is that, in any event, that the NVidia still sips quite a bit of vampire power even when fully disabled.
    - Undervolt your CPU. Skylake-U is very much undervoltable - not sure if this applies to Skylake-K processors but give it a go (in the FIVR window). Most people seem to have stable undervolts on Skylake-U in the -0.75 to -1.25 mV range. This is around 10% of the power consumption.
     
Loading...

Share This Page