The ThrottleStop Guide

Discussion in 'Hardware Components and Aftermarket Upgrades' started by unclewebb, Nov 7, 2010.

  1. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,805
    Messages:
    6,411
    Likes Received:
    6,700
    Trophy Points:
    681
    When using ThrottleStop, SpeedStep needs to be enabled for the Set Multiplier function to work and you also need to click on the Turn On button in ThrottleStop to take ThrottleStop out of Monitoring mode. This takes care of the basics. If you are still having throttling problems then you can try some more options to see if that makes a difference. Set Multiplier is enough to take care of the throttling in the Lenovo Y510P and Y50 and probably quite a few other Lenovo laptops.

    That is the new type of throttling that I would like to solve.

    My theory is that this type of throttling might be caused by the PP0 Power Limit. Open up the ThrottleStop - Turbo Power Limits (TPL) window to access this. The 4980HQ has a TDP of 47 Watts. After booting up, I would click on TPL, check the PP0 Power Limit box, check the Lock option box and then I would set this to 47 or 58. After that, click on OK. Go use your computer and see if you can get it to lock up at the 28 multiplier.

    The Lock option locks the PP0 register. If this testing does not work out, you will need to either delete the ThrottleStop.INI configuration file or go into that file and delete this line

    PP0POWERLIMITEAX=

    After that, reboot and this will unlock the PP0 register. Using ThrottleStop to Lock this register will prevent other software from using this register to Power throttle your CPU.

    Thanks for all the data that has been posted. When I have more time I will have a better look at the numbers to see what I can figure out.

    @timohour - Did you try checking the Set Multiplier option? That should be set to the same value as the highest turbo multiplier.
     
    Last edited: Aug 18, 2015
  2. suitslft

    suitslft Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Thank you so much for your help!

    Here are my GPU settings from GPU-Z: http://puu.sh/jFSpH/391a81e51f.png
    My GPU runs at 70-80 degrees celsius while playing games.

    I have also adjusted the PCI settings as you suggested. The gpu clock diving still persists in occasional stuttering, but the main problem seems to have been alleviated for the time being.



    During the forementioned stuttering and diving:

    1. The GPU clock dived down from 925/1000 to 400/305.
    2. There was no significant change in GPU temperature or Dedicated & Dynamic Memory.
    3. The GPU load (%) dropped from 96-98 to 64 during the stuttering (3-8 seconds in length), and for an additional 5-7 seconds afterwards (while the clock was back up to 925/1000).

    These were my observations from the log files. Fan Speed was not recorded in any way.


    Once again, thank you for taking the time to read through my stuff and help me with this problem!

    Edit: the GPU diving problem is still persisting. I am going to manually clean my laptop and possibly reapply thermal paste in a few days if a software solution cannot be discovered.
     
    Last edited: Aug 18, 2015
  3. Thurkar

    Thurkar Notebook Guru

    Reputations:
    7
    Messages:
    66
    Likes Received:
    6
    Trophy Points:
    16
    I tried to include as much information as possible, in case I did something wrong along the process, it would be easier to point out.

    First, I restarted my laptop. After boot, I opened ThrottleStop and set the settings like this :

    http://i.imgur.com/G5HDgsD.jpg

    (I just realized I took the screenshot before setting the 47W, but yeah, I didn't forget it ^^)

    The result : http://i.imgur.com/W5sMxv5.jpg

    The ThrottleStop Log : http://pastebin.com/7iUEg4cj

    The Dump : http://pastebin.com/uGfm7764

    Then, I deleted the INI in the ThrottleStop folder, and restarted my computer. Opened up ThrottleStop again and set like this :

    http://i.imgur.com/HWDUlLL.jpg

    The result : http://i.imgur.com/ZMJ7SmL.jpg

    The ThrottleStop Log : http://pastebin.com/vEMWXpxD

    The Dump : http://pastebin.com/QGtwnbVy

    I imagine you didn't have high expectation either ^^ I hope there is some data here that could prove useful to you, if some of it is useless and I shouldn't have bothered with it, please tell me, I really have no idea :D. If I configured TS wrong, I'm ready for more testing.

    Cheers !
     
  4. Eason

    Eason Notebook Virtuoso

    Reputations:
    271
    Messages:
    2,216
    Likes Received:
    892
    Trophy Points:
    131
    You need to go to the "sensors" tab which shows clicks. Play until you get hitching, then switch to the other tab and check the throttling reason in the sensors tab. Mouse over it and it will tell you what the code means, then report back.

    I don't know how ATI drivers work, but if there is an option for "use max clocks" then make sure that's checked.
     
  5. Dufus

    Dufus .

    Reputations:
    1,194
    Messages:
    1,336
    Likes Received:
    548
    Trophy Points:
    131
    Thanks for running the test, but need to see the another dump file.

    Run 60W app then run stress test as in your post 3431, while stress test is running run Dumper, stop stress test, post text file results. I should have been clearer, sorry.
     
  6. Eason

    Eason Notebook Virtuoso

    Reputations:
    271
    Messages:
    2,216
    Likes Received:
    892
    Trophy Points:
    131
    Over the past 2 weeks I've had a couple hard crashes on my blade, both while using youtube in multiple windows at once. It doesn't BSOD, the mouse simply stutters then the screen hangs until I reboot. Does this sound like it could be caused by the intel GPU undervolt?
     
  7. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,805
    Messages:
    6,411
    Likes Received:
    6,700
    Trophy Points:
    681
    @Thurkar - Can you read that informative post from unclewebb. ;)

    From what I see so far, this is not looking good. I will check out your numbers some more tomorrow. Thanks for sharing.

    One last thing to try would be to Lock the PP0 register to zero. Normally a setting of zero tells the CPU to ignore this register. There are registers hiding here, there and everywhere. ThrottleStop might not have access to the register that is holding your CPU to the 28 multiplier. This is not normal but besides returning your laptop, there might not be anything you can do about this.
     
  8. timohour

    timohour Notebook Consultant

    Reputations:
    201
    Messages:
    170
    Likes Received:
    1
    Trophy Points:
    31
    @unclewebb - I have set multiplier to x40 but after a while
    [​IMG]
    you can see the spikes on the XTU graph.

    Without ThrottleStop it would throttle to x26 for longer periods. and then back again to x38.
    [​IMG]

    Since XTU doesn't show any CPU Throttling (I can see it stays @ 0%) I think I can say it is a bios restriction that bypasses the long and short power duration limits set in the NVRAM when using a Dell Power Adapter..

    One solution supplied by Khenglish is use a non Dell power adapter with invalid ID. This way it throttles CPU and GPU. Using Throttlestop I can set my CPU to ran @ 3,8GHz steadily... but there is no way to stop the throttling on the dGPU and with an invalid adapter I can't charge my battery.

    Any ideas?
     
  9. vas

    vas Notebook Consultant

    Reputations:
    34
    Messages:
    207
    Likes Received:
    27
    Trophy Points:
    41
    most probably - yes.

    mine GPU sometime cause "driver restart" when I set it to -90mV, but never do so at -60mV.

    graphics freeze - more hard to recognize source of the problem comparing to graphics driver restart ...

    I would recommend to reduce undervoltage and test again ...
    if problem persists - then there are other problem
     
    Eason likes this.
  10. vas

    vas Notebook Consultant

    Reputations:
    34
    Messages:
    207
    Likes Received:
    27
    Trophy Points:
    41
    Never use XTU and other deep CPU controlling software together ...
    That why you might get unpredictable results
     
Loading...

Share This Page