The ThrottleStop Guide

Discussion in 'Hardware Components and Aftermarket Upgrades' started by unclewebb, Nov 7, 2010.

  1. werdmonkey4321

    werdmonkey4321 Notebook Evangelist

    Reputations:
    95
    Messages:
    349
    Likes Received:
    283
    Trophy Points:
    76
    @unclewebb

    Just thought I would highlight that for Windows 11 you only have to disable "Virtual Machine Platform" in Windows features in order for Throttlestop to access CPU registers again. The thread is quite long so I don't know if anyone highlighted this in a previous page, but users do not have to disable virtualization in the bios or disable Windows Subsystem for Linux. They only have to disable "Virtual Machine Platform" in Windows Features in order for Throttlestop to work again.

    I tested this on an Alienware X17 R1 running Windows 11 build 22000.194

    AWCC OC Controls and Throttlestop work if you disable "Virtual Machine Platform" in Windows Features. Having this feature enabled prevented Windows programs from accessing CPU and GPU registers.
     
    unclewebb, tilleroftheearth and Samot like this.
  2. noric

    noric Notebook Consultant

    Reputations:
    24
    Messages:
    163
    Likes Received:
    5
    Trophy Points:
    31
    I was wondering the same right after I took the screenshot. Then I tried with "High Performance" profile, but it doesn't change anything either.
     
  3. werdmonkey4321

    werdmonkey4321 Notebook Evangelist

    Reputations:
    95
    Messages:
    349
    Likes Received:
    283
    Trophy Points:
    76
    @unclewebb

    Just an fyi I have also started a thread on reddit to keep track of these different issues in Windows 11 and what fixes them. You can use it as a reference if people are having trouble getting Throttlestop to work and method X isn't working. It seems the issues are quite diverse so while my solution is relevant if people are toying around with WSL, it may not be relevant to others who have never touched WSL.

    FYI: (Alienware X17) Windows 11 Disable "Virtual Machine Platform" to get AWCC OC controls and Throttlestop to work again. : Alienware (reddit.com)
     
    unclewebb likes this.
  4. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,735
    Messages:
    6,377
    Likes Received:
    6,613
    Trophy Points:
    681
    Thanks @werdmonkey4321 for keeping up to date on Windows 11 and ThrottleStop compatibility issues.

    I added a link to your post above to the first post in this thread so it will be easy for users to find this important information.
     
  5. berkkocaturk

    berkkocaturk Notebook Consultant

    Reputations:
    6
    Messages:
    110
    Likes Received:
    28
    Trophy Points:
    41
    @Webbmaster

    For stability tests try low loads too cpu dynamicly scales voltage when you set an offset when under load it might work but when you run 2 core 4 core load or power saving load it already lowers the voltage and then you also put an offsett on throttlestop which might make it too low and unstable

    for example
    4.4 Ghz 1.25V Stock
    4.4Ghz 1.2V stable -50mV

    2.5Ghz stock 0.8V
    2.5Ghz undervolt 0.75V might crash

    In fact when i run all core test like cinebench i can set the voltage lower at throttlestop and it doesnt crash when the test is going with all cores but as soon as cores start finishing it crashed

    if the cpu is overheating you can only lower voltage or increase cooling but if the cpu is throttling at 80W that is actually good and if you are not going liquid metal i would not touch it at all...

    I have msi laptop too and set prochot to 98 i have known from experience even if intel doesnt mind it laptop will shut immediatly if it exceeds 100C and when you set it to 99 it can still move over 100C so 98 seems the best
     
    Last edited: Oct 5, 2021
  6. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,735
    Messages:
    6,377
    Likes Received:
    6,613
    Trophy Points:
    681
    The Intel specified thermal throttling temperature is usually 100°C and the thermal shut down temperature is closer to 125°C. This gives the CPU plenty of opportunity to cool down so it does not just randomly shut down. The Intel hardware works fantastic.

    Some laptop manufacturers decided to re-engineer Intel thermal throttling and thermal shut down. They decided to move the shut down temperature down to 100°C. If the thermal throttling temperature is left at the Intel default of 100°C, that creates a problem where the computer will randomly shut down without the CPU having a chance to cool down a little first. Just another bad design idea by laptop manufacturers that do this.

    If the shut down temperature is set to 100°C, now the throttling temperature has to be set lower than that. Usually setting thermal throttling to 95°C to 98°C will allow enough headroom to avoid random shut downs at high temperatures without reducing maximum performance too much.
     
    Gumwars likes this.
  7. noric

    noric Notebook Consultant

    Reputations:
    24
    Messages:
    163
    Likes Received:
    5
    Trophy Points:
    31
    @unclewebb
    Talking about Sandy Bridge, do you know whether the iGPU frquency can be manually adjusted? E.g. to lower the turbo frequency?
    Thanks!
     
  8. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,735
    Messages:
    6,377
    Likes Received:
    6,613
    Trophy Points:
    681
    It should be possible to lower the iGPU MHz but ThrottleStop does not have any ability to do this.
    A future TS feature? Maybe!

    You can use RW Everything to set Memory Mapped location 0xFED15994. This value controls the maximum iGPU MHz. This can be adjusted in steps of 50 MHz. The default for my CPU is 0x18 hex which is 24 decimal.

    24 X 50 MHz = 1200 MHz

    The screenshot shows I have set this to 0x10 hex which is 16 decimal so the iGPU is being limited to,

    16 X 50 MHz = 800 MHz.

    The GPU-Z render test is useful to put a simple load on the GPU so it runs at full speed.

    upload_2021-10-4_9-45-11.png
     
    Last edited: Oct 4, 2021
  9. Flash676

    Flash676 Notebook Enthusiast

    Reputations:
    0
    Messages:
    19
    Likes Received:
    1
    Trophy Points:
    6
    I don't have an AW, but even with "Virtual Machine Platform" off, I can't get Throttlestop to work unless I disable "Memory Integrity" from Windows Security->Device Security->Core Isolation. I'm hoping for a more targeted fix.

    Edit: This lets me adjust CPU Core and Intel GPU, but changes to CPU cache don't seem to cause any change.
     
  10. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,735
    Messages:
    6,377
    Likes Received:
    6,613
    Trophy Points:
    681
    upload_2021-10-5_10-58-32.png

    ThrottleStop runs correctly on my Windows 10 - 20H2 computer with Memory Integrity enabled. Your CPU might have some different security features enabled or perhaps the Windows 10 version you are using is more secure.

    I did find one bug. The 10 core CPUs use Turbo Groups. When Memory Integrity is disabled, I only need to fill in Turbo Group 1 and the CPU understands that I want the 50 multiplier whether 1, 2, 3, ... or all 10 cores are active.

    upload_2021-10-5_11-20-35.png

    When Memory Integrity is enabled, the CPU no longer understands the above setting. ThrottleStop is still setting the turbo ratio registers exactly the same so this has to be a bug at the CPU level. The 10 core CPUs typically use four different Turbo Groups. To trick the CPU, I need Turbo Group 4 to contain the 50 - 10 entry. The Core Count values for the first three turbo groups do not seem to matter so I just set them to zero.

    upload_2021-10-5_11-19-15.png

    Other than that, ThrottleStop seems to work 100% correctly on my computer with Memory Integrity enabled.

    Microsoft wants to improve the security of their operating system. ThrottleStop needs direct access to the CPU's registers. A secure operating system does not allow that. I cannot fix what Microsoft decides to break in the name of security. If you need to run ThrottleStop, you will have to manually disable whatever needs to be disabled. Thanks Microsoft for letting us disable Memory Integrity and the Virtual Machine Platform.

    After you get Memory Integrity and Virtual Machine Platform disabled, delete the ThrottleStop.INI configuration file and reboot. Post some ThrottleStop screenshots so I can see the problem that you are having. I do not know what CPU model you have and I cannot see how you have ThrottleStop setup.
     
    FrozenLord and berkkocaturk like this.
Loading...

Share This Page