The ThrottleStop Guide

Discussion in 'Hardware Components and Aftermarket Upgrades' started by unclewebb, Nov 7, 2010.

  1. noric

    noric Notebook Consultant

    Reputations:
    24
    Messages:
    163
    Likes Received:
    5
    Trophy Points:
    31
    @Rimmsi
    Yes, that button is now checked, because I can't get PL1 and PL2 to work. Anyway, I've now uploaded the correct image of the settings I would like to apply, to avoid confusion.

    Unchecked all "lock" buttons, rebooted and... confirmed, unfortunately they are locked by the BIOS...
    Did someone ever investigate and/or succeeded in unlocking these power limits with a BIOS mod?

    Without "Power Balance" I've found that the iGPU doesn't scale to its turbo frequency while gaming with some emulators, resulting in low fps. That option works really well!
     
  2. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,735
    Messages:
    6,381
    Likes Received:
    6,616
    Trophy Points:
    681
    That is what I thought. I have never heard of any successful BIOS mods for locked 2nd Gen mobile CPUs. Does the default 45W limit cause any significant throttling? You should be able to run most tasks at full speed with 45W. What speed do you get when Cinebench R20 or R23 is running?

    https://www.techpowerup.com/download/maxon-cinebench/

    I have not found many people that have ever found a use for the Power Balance feature. I have thought about removing it for years. Based on your feedback, I will leave it as is. That is less work compared to removing it.

    ThrottleStop has a hidden feature for the Intel GPU. In the ThrottleStop.INI configuration file, try adding this line.

    IGPU=100

    That sets the Intel GPU power limit sky high to 100 Watts which might help eliminate any GPU power limit throttling. If the Intel GPU power limit register is locked, this will not do anything. Not sure if this feature will be of any use to your laptop. It hardly ever hurts to try. :)
     
    tilleroftheearth likes this.
  3. noric

    noric Notebook Consultant

    Reputations:
    24
    Messages:
    163
    Likes Received:
    5
    Trophy Points:
    31
    I have a feeling that the CPU frequency is a bit low while gaming with the iGPU at full speed.

    2.5GHz in Cinebench R20.

    Yes, please! Another example I've found: with PCSX2 (heavily cpu-bound) I set the Power Balance to 31-0, so that the iGPU is throttled and the CPU can turbo-boost a bit higher.

    I'll keep this in mind in case I still see the iGPU throttled at base clock despite "Power Balance". :)
     
  4. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,735
    Messages:
    6,381
    Likes Received:
    6,616
    Trophy Points:
    681
    Can you post a screenshot of ThrottleStop while your computer is running Cinebench and while your CPU is throttling? I would like to see if it is power limit throttling at 45W or if something else is going on. Some people do not know how to set ThrottleStop up on older computers. Not sure if YouTube videos were a thing when the 2nd Gen were released. :)
     
    tilleroftheearth likes this.
  5. Nore12345

    Nore12345 Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    I just set up throttlestop and the temps are great. I'm wondering 2 things though (when using Throttlestop to undervolt m15 r4 laptop - is FID suppose to fluctuate a bit when game is on and do I need to click the "Turn On" option), regarding when I use it to play FFXIV. Also, I'm using an Alienware m15 R4 laptop in case it matters and it has an Intel i7-10870H CPU.

    I undervolted the CPU core and cache by -80.1mV and changed the clock speeds on the bottom left down about 2 each (it went from 50 with 1 core active and 41 with 8 cores active to 48 with 1 core active and 35 with 8 cores active). To clarify this is the section in the FIVR that is labelled "Turbo Ratio Limits" (where it has 8 values, because my CPU has 8 cores, ranging from 1 Core Active to 8 Cores Active). While running tests (TS Bench and Cinebench) I get consistent 34.00 in the FID section on all 8 cores. But when I start FFXIV, I noticed at first the FID was 34.00 for a few minutes but then the FID goes down just a tiny put like 33.5 or 33.7 and fluctuates constantly. Is this normal? I'm new to this so I wasn't sure if it is meant to stay at 34.00 while gaming now. If this is normal, then how do you know exactly if the CPU is thermal throttling? (Just a note, the FPS in the game is good, I have it at 120 limit and it stays at 119-120 outside the major cities and 110-120 in major cities so everything in the game seems fine without any performance loss from lowering CPU voltage).

    Also, since I changed the "Turbo Ratio Limits" section, do I need to select the "Turn On" option in the task bar (right click TS in task bar)? Currently the throttlestop icon is green and the "Turn On" option is unchecked. I know the undervolting is applied whether or not you have this option selected, but I was not sure about if you changed the "Turbo Ratio Limits"? I found this info regarding the Turn On/Off button: "Turn On - Turn Off controls Set Multiplier, Chipset Clock Modulation and Clock Modulation. A lot of 8th Gen CPUs that have Speed Shift enabled do not need to use any of these 3 settings. Clock modulation throttling is rarely used on modern laptops." I was not sure what Clock modulation is though, or if that is what I did?

    Thanks!
     
  6. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,735
    Messages:
    6,381
    Likes Received:
    6,616
    Trophy Points:
    681
    @Nore12345 - I cannot count how many different forums you have asked this same question. I think I answered it on TechPowerUp. I know I answered it somewhere.
     
    tilleroftheearth likes this.
  7. noric

    noric Notebook Consultant

    Reputations:
    24
    Messages:
    163
    Likes Received:
    5
    Trophy Points:
    31
    Here it is:
    cinebenchR20.png


    Actually I don't know why during Cinebench it's throttling at 2,5GHz. During full load it usually throttles at 2,7GHz, for example during a HandBrakeCLI conversion:
    handbrakecli.png

    I have also tried to disable "Power Balance" and it doesn't make any difference.
     
  8. Nore12345

    Nore12345 Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Hi, thanks, yeah I found your responses on techpowerup. I wasn't sure which forum would lead to any response, so I tried them all heh... In any case, I will reply there once I get the logs. Thanks again for your help!
     
  9. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,735
    Messages:
    6,381
    Likes Received:
    6,616
    Trophy Points:
    681
    @noric - Try checking the Set Multiplier box so that information is sent to the CPU. Also clear the Power Saver box when testing. That is more of a feature for the much older Core 2 Duo CPUs.
     
  10. Webbmaster

    Webbmaster Notebook Enthusiast

    Reputations:
    0
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    15
    Looking for a advice for MSI GE76 11UE with i7-11800H - better settings in BIOS and Throttlestop please?
    Bios is the last, stock, overclock switch on there.

    Read recommendation for bios -
    Disable FIVR efficiency.
    Disable FIVR Faults

    is it good and anything else ?
    ps. Intel GPU switch off with MUX switch - so only NVidia discrete only.
    Started from -70, but -60mv found stable (in prime even by default BLEND mode).

    allinone2.png 222222.png
     
Loading...

Share This Page