The ThrottleStop Guide

Discussion in 'Hardware Components and Aftermarket Upgrades' started by unclewebb, Nov 7, 2010.

  1. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,232
    Messages:
    6,024
    Likes Received:
    5,519
    Trophy Points:
    681
    @pombozzera - When you have a problem, post a screenshot or two so I can have a look.

    ThrottleStop uses high performance timers within the CPU for monitoring purposes. Unfortunately, these are shared timers so any other software running on your computer can interfere with these timers. This will prevent ThrottleStop from getting accurate information from them. It does not make any sense why Edge would be doing this but anything is possible. Try exiting any other monitoring software on your computer and kill Edge if it is running in the task manager. Maybe it is Edge causing the problem or maybe it is something else.

    Open up the TS FIVR window and have a look at what Speed Shift EPP value the CPU is using. On some computers, depending on what Windows power plan you are using, Windows will be in control of the EPP value, not ThrottleStop. If ThrottleStop has no control over the EPP value then do not check this option in ThrottleStop. Let Windows control EPP. No point in having two different programs both trying to control the same thing.

    Are you running Windows 10 2004? It might manage the CPU more aggressively.
     
    Last edited: Jun 17, 2020
    tilleroftheearth likes this.
  2. Jdpurvis

    Jdpurvis Notebook Evangelist

    Reputations:
    90
    Messages:
    425
    Likes Received:
    119
    Trophy Points:
    56
    It might be some sort of interaction with your specific hardware and software. I am running the 2004 update with the new Edge browser on both my laptop and desktop (see signature below - Gigabyte laptop with i7-6700HQ), and 8.76 version of TS. All seems to be working normally. TS controls speedshift, and my undervolts remain. My wife's Lenovo has a more advanced i7, and is due for 2004. So far, TS has been working normally, but without either the new Edge or the Win update. Will let you know what happens with the update.
     
  3. pombozzera

    pombozzera Notebook Enthusiast

    Reputations:
    0
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    Sorry for not posting any screenshots; i'm new to the forum and i don't know how i can do it. I'd appreciate some help on that ;)
    anyway, here's an imgur link to it: https://imgur.com/a/30uMGP8

    Edge wasn't running in the background, and also i don't use any other monitoring software. When i'm gaming i use MSI Afterburner but i have been having this issue even when it's closed, so it probably doesn't have anything to do with it. I really have no idea what's causing me this issue, i hope it isn't anything serious. The update can't be uninstalled so right now i'm just crossing my fingers and hoping it don't damage anything. I wonder if keeping my CPU without clock limit and speed shift in value 0 will help at least to minimize the speed problem, but about the C0% i just have no idea whatsoever. Since i have an Tongfang barebone notebook (GK5CP6V) it comes with an gaming center app that does control lots of stuff in the computer, but i don't think that it's associated with the problem as i used it before the update and never had any kind of issues. I'll guess i'll just wait and see what happens. Also, i'm running Windows 10 1909, and throttlestop is in control of the speed shift's value.
     
    Last edited: Jun 17, 2020
  4. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,232
    Messages:
    6,024
    Likes Received:
    5,519
    Trophy Points:
    681
    @pombozzera - I host my screenshots on www.imgur.com

    Do you have the Windows Core Isolation Memory Integrity feature enabled? It might be Windows or your anti-virus software that is blocking ThrottleStop from accessing your system timers within your CPU. Your problem is not yet common but it might become common so hopefully you can figure this out. Check the monitoring table in the top right corner of the FIVR window to see if your voltages are displayed.
     
  5. pombozzera

    pombozzera Notebook Enthusiast

    Reputations:
    0
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    It is disabled and on FIVR my voltages are displayed normally, take a look at this other screenshot: https://imgur.com/a/3hPtq7G
    I have tried disabling my anti-virus as well, but i had no success either, still constant zero C0%
     
  6. djdelarosa25

    djdelarosa25 Notebook Enthusiast

    Reputations:
    5
    Messages:
    37
    Likes Received:
    10
    Trophy Points:
    16
    unclewebb and tilleroftheearth like this.
  7. pombozzera

    pombozzera Notebook Enthusiast

    Reputations:
    0
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    I may have found a sweet spot for the frequency issue. Using speedshift in value 40 makes the processor not get all the way up to full turbo in idle, only when in load. I have a little concern of speedshift in general about the frequencies (and consequently, voltage) jumping all over the place when it's enabled: is there any problem with these voltage/frequency spikes?
     
  8. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,232
    Messages:
    6,024
    Likes Received:
    5,519
    Trophy Points:
    681
    The purpose of Speed Shift Technology is so the CPU can rapidly adjust its speed and voltage to load. This reduces power consumption which is desirable in a laptop. Some users have found that it requires slightly more voltage to be 100% stable when the CPU multiplier is jumping all over the place compared to having the CPU multiplier at a fixed value. If you want to reduce rapid multiplier cycling when lightly loaded, set the Speed Shift EPP variable to 0. Either that or use some monitoring software that completely ignores what your CPU is really doing. :)

    Good news. My magic crystal ball sees a new TS version on the horizon. The WinRing0 and RwDrv.sys drivers have been retired. The new version is up and running, it is under going final testing and it should be available by the weekend. Hopefully it will be able to fly under the radar and keep the anti-cheat programs happy. This will also fix the Windows 10 2004 BSOD issues that are being caused by the RwDrv.sys driver.
     
    relobe, raz8020, cktducky and 6 others like this.
  9. pombozzera

    pombozzera Notebook Enthusiast

    Reputations:
    0
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    This means that with this new TS version, the problem will hopefully be fixed?
     
  10. pombozzera

    pombozzera Notebook Enthusiast

    Reputations:
    0
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    UPDATE: Apparently, everything started working well again. I'm not sure why, the only think i remember doing in TS was trying other speedshift values (from 20~40) and i also lowered the IccMax of the processor. i was just playing forza horizon 4 and i saw that my c0% states were normally reading, as well as my speed shift speeds not max turboing when idle. I'll keep watching and in case anything happens i'll get back here. Thank you nonetheless

    5.JPG
     
Loading...

Share This Page