The ThrottleStop Guide

Discussion in 'Hardware Components and Aftermarket Upgrades' started by unclewebb, Nov 7, 2010.

  1. maffle

    maffle Notebook Evangelist

    Reputations:
    160
    Messages:
    520
    Likes Received:
    472
    Trophy Points:
    76
    @unclewebb could you maybe please implement an execute command line when TS detects entering and leaving standby. also add logging for it too that it shows in log if and when standby was entered and left.
     
  2. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,242
    Messages:
    6,038
    Likes Received:
    5,567
    Trophy Points:
    681
    Good stuff but ThrottleStop is still in suspended development mode. Not sure if or when I will get back to it.
     
    maffle likes this.
  3. simcha binyamin katsof

    simcha binyamin katsof Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    2
    Trophy Points:
    6
    throttlestop screen pic.jpg Hi there.
    Im using a Dell Inspiron 17 5759. i have the "plugged in not charging" error due to using a non original charger
    Can you please help me set the correct settings to throttlestop for my pc?

    Heres a screen pic of throttle stop

    thank you : )
    SB
     
  4. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,242
    Messages:
    6,038
    Likes Received:
    5,567
    Trophy Points:
    681
    The screenshot you posted looks OK. You disabled BD PROCHOT in ThrottleStop and that is allowing your CPU to run at its full rated speed. If your laptop is idle in that screenshot, you probably have too much useless junk running in the background. On a 2 core CPU, you really need to keep a close eye on background tasks. Get rid of stuff that really does not need to be running all of the time.

    Clear the Task Bar check mark if you want ThrottleStop to minimize to the system tray / notification area.
     
    Papusan likes this.
  5. Charles P. Jefferies

    Charles P. Jefferies Lead Moderator Super Moderator

    Reputations:
    22,166
    Messages:
    36,549
    Likes Received:
    4,667
    Trophy Points:
    681
    Do you have a guide or instructions on how to protect that file from being changed? I'm an administrator on my PC but I can't change the permissions on that file for most of the entries under the Security tab.

    Charles
     
  6. Nijimin

    Nijimin Notebook Enthusiast

    Reputations:
    20
    Messages:
    10
    Likes Received:
    13
    Trophy Points:
    6
    you cannot change the permissions because you need to *take ownership* of the files first: right click, properties, security tab, advanced options

    you need to change the ownership of "mcupdate_GenuineIntel.dll" from TrustedInstaller to your own admin account

    my windows is in another language so i unfortunately cannot help with screenshots, sorry
     
  7. Papusan

    Papusan JOKEBOOKs Sucks! Dont waste your $$$ on FILTHY

    Reputations:
    31,787
    Messages:
    26,586
    Likes Received:
    48,991
    Trophy Points:
    931

    To stop Windows from updating the microcode, you'll need to rename or delete one of the following files (after taking ownership):

    C:\Windows\System32\mcupdate_AuthenticAMD.dll -> for AMD CPUs
    C:\Windows\System32\mcupdate_GenuineIntel.dll -> for Intel CPUs

    This needs to be redone after every big update (1809 -> 1903 etc.).

    https://www.win-raid.com/t3355f47-I...code-Repositories-Discussion-18.html#msg86364

    ---------------------------

    https://www.windowscentral.com/how-take-ownership-files-and-folders-windows-10

    Edit. See also... https://www.win-raid.com/t5655f47-downgrade-microcode-i-k-z-extreme.html
    upload_2020-3-4_9-0-14.png
     
    Last edited: Mar 4, 2020
  8. chaugh

    chaugh Notebook Consultant

    Reputations:
    6
    Messages:
    180
    Likes Received:
    3
    Trophy Points:
    31
    I have a Asus gaming laptop (GL504GM) and my issue is the CPU never goes into anything deeper than C3 sleep state. Other than malwarebytes and some notification icons, there is nothing running.

    I'm fairly certain the laptop supports at least C6 and I recall seeing it before.

    Any tips to solve this?
     

    Attached Files:

  9. Jdpurvis

    Jdpurvis Notebook Evangelist

    Reputations:
    98
    Messages:
    431
    Likes Received:
    121
    Trophy Points:
    56
    Your core is in C7, 90%+. Package seems limited to C3. Mine is the same (6700HQ). I think this may be fairly common. Others may have more information on deepest C states for package.
    Best,

    Joe
     
  10. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,242
    Messages:
    6,038
    Likes Received:
    5,567
    Trophy Points:
    681
    @chaugh - If it makes you feel any better, my 4th Gen CPU can use Package C6. After I resume from sleep mode, that all changes. Then my CPU gets stuck and can not go any deeper than Package C2.

    [​IMG]

    I pulled all my hair out trying to find out why but I have never found a solution. I compared all of the Windows power plan settings including the hidden ones and I could not find anything. This did not start happening until after I switched to a newer version of Windows 10. Some poorly written driver is likely responsible for this bug. The documentation about what controls the deepest package C state is one of Intel's many well guarded secrets. It might be SSD related. Turning off some C states has been known to give better benchmark scores. That is the only thing I can think of as to why this became someone's good idea. Now users have a very common problem with no solution.
     
    Falkentyne likes this.
Loading...

Share This Page