The ThrottleStop Guide

Discussion in 'Hardware Components and Aftermarket Upgrades' started by unclewebb, Nov 7, 2010.

  1. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,989
    Messages:
    5,757
    Likes Received:
    4,704
    Trophy Points:
    431
    @rocketvole - I do not believe that the 0.49 GHz that the Task Manager is reporting is accurate. Your ThrottleStop screenshot shows a very dynamic multiplier and it is reporting a CPU speed much higher than what the Task Manager is showing. I have a lot of confidence in the multiplier that ThrottleStop reports. It is one of the few monitoring tools that closely follows the Intel recommended monitoring method. The first thing people tend to think is, Microsoft is a big company, their programmers must know what they are doing. Maybe, maybe not. Let's do some testing to find out what app is properly tracking your CPU speed.

    Enable Speed Shift and set EPP to 255. Is ThrottleStop reporting the minimum CPU speed yet? Did the Task Manager change at all or is it still reporting the same thing? If ThrottleStop is not yet reporting your CPU at its minimum speed, open up the TPL window and set the Speed Shift Min and Max values both to 5. Any changes in reported MHz? After you have finished this test, you can reset the Speed Shift Min and Max values to 1 and 32.

    If the ThrottleStop reported speed changes during the above testing and if the Task Manager just keeps reporting the same thing, I would say that the Task Manager is not accurate on your CPU. Ignore what it is telling you. Nice graph but it is worthless if the data being graphed is not accurate. Speed Shift rapidly changes the CPU multiplier. Any monitoring app that does not use the high performance monitoring timers within the CPU or does not follow the correct monitoring procedure, is not going to be able to accurately report what a CPU is doing.

    As mentioned by @Jdpurvis, any EPP setting greater than 80 can limit the maximum speed of your processor. Start by using an EPP setting of 0 just to try and prove that your CPU and Speed Shift are both working correctly. Does that allow your CPU to run at its full rated speed?

    Your decision to set EPP to 200 is the cause of your problem. You are telling your CPU to run sluggishly so it is. Forcing a CPU to run slow when it has a task to complete is not an efficient way to run a processor. Intel developed Speed Shift to get away from this backward thinking. Intel discovered that the most efficient way to complete a task is to let the CPU do the task as fast as possible. Once done, the CPU core can go back into core C7. This saves power. A fast CPU will have higher peak power consumption but if the cores are allowed to go into C7, the CPU will consume less total power while completing any task.

    Is the C State screenshot you posted when your CPU was idle? I hope not. An efficient 2 core U series CPU should have those cores spending close to 99% of their time in core C7 when idle.

    [​IMG]

    When Windows 10 is setup correctly, it is not that bloated but a lot of apps are. Use the C state data in ThrottleStop to keep an eye on things. Maximizing your C7 residency percentage is an easy way to increase the efficiency of your computer which will save power and improve battery run time.

    When undervolting, set the CPU core and CPU cache offset voltages equally. If you are going to undervolt the Intel GPU, you need to undervolt the Intel GPU and the iGPU Unslice equally.

    While trying to get things sorted out, do not check the BD PROCHOT box. Whether this is checked or not, your CPU will still throttle and slow down if it ever gets too hot. BD PROCHOT and PROCHOT (processor hot) are two different things.

    Thanks for the pics. Hopefully you can do some more testing and post some more pics.
     
  2. Mari1225

    Mari1225 Notebook Consultant

    Reputations:
    78
    Messages:
    113
    Likes Received:
    126
    Trophy Points:
    56
    I am sure that it is somewhere in the back pages but I have a question please, I have been using TS for 2 years now, just recently updated to 8.70, seems fine and works good as far as I can tell, checked it with HWiNFO all matches up.
    My question is the FID is running at 4.5 to 4.6 all the time even with no load and the temps are 35C to 45C, Unless I use Speed Shift, but then the FID only gets to 3.8 even on the 4.6 profile I made, Am I doing something wrong or need to change a setting ?

    Or just leave it running at 4.6 on the FID and move along with my life lol

    Let me know if you need SS:) any help appreciated!
     
    pressing likes this.
  3. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,989
    Messages:
    5,757
    Likes Received:
    4,704
    Trophy Points:
    431
    @Mari1225 - The Speed Shift EPP value on the main screen can be changed. If you have that set to the default 128, it can interfere with your maximum CPU speed. Try setting this to 80. It is my personal fav.

    If you are using the Windows Balanced power profile then it can interfere with the ThrottleStop Speed Shfit EPP value. Use the Windows High Performance power profile if you want ThrottleStop to be in charge of the EPP value. Look in the FIVR window to see if the requested value on the main TS screen is the same as the actual EPP value that is reported in the FIVR monitoring table at the top right.

    Hard to tell if you are doing something wrong if you do not post some pics of your problem.
     
    tilleroftheearth and Mari1225 like this.
  4. Mari1225

    Mari1225 Notebook Consultant

    Reputations:
    78
    Messages:
    113
    Likes Received:
    126
    Trophy Points:
    56
    Win 10 is on High Performance power profile. here are some SS :) Thanks!

    UPDATE: yes changed to 80 for SS EPP, Fixed it now! Now the FID jumps from 9 to 4.6 when needed for heavier loads, like gaming. Now they both say 80 instead of 128 on both tables. Thanks! :)
     

    Attached Files:

    Last edited: Feb 26, 2020
    unclewebb and tilleroftheearth like this.
  5. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,989
    Messages:
    5,757
    Likes Received:
    4,704
    Trophy Points:
    431
    @Mari1225 - No need to check the Set Multiplier option when you are using Speed Shift. The CPU ignores this setting so checking that box just wastes CPU cycles.

    Glad to see that setting EPP to 80 solved your problem.
     
    Mari1225 likes this.
  6. Jdpurvis

    Jdpurvis Notebook Evangelist

    Reputations:
    78
    Messages:
    389
    Likes Received:
    94
    Trophy Points:
    41
    Remember that FID is a momentary value. To see this, set SpeedShift to 0. FID will be quite high, even at idle, when C0% is quite low (and, therefore, processor is mostly in higher C states). :)
     
    Mari1225 likes this.
  7. rocketvole

    rocketvole Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    5
    so I made a separate profile called default with all the same settings as a fresh install (no undervolt, etc). https://imgur.com/a/jgjl99n
    setting the epp to 255 makes the minimum processor state around .5 ghz, which spikes up whenever I do something on the laptop. This sounds pretty expected, but the minimum processor state I assume is .5 ghz. According to the power settings in my laptop, the minimum state should be 5%, which is about 125 mhz. Changing the speed shift min and max values to 5 doesn't change anything- still get .5 ghz.

    I don't think this is an issue with the EPP. On my AC profile, which has an EPP of 128, turning off turboboost within TS results in the same kind of performance- locked to .5 ghz. Setting the Epp to 0 on all my profiles does allow the processor to run at maximum speed all the time.

    Task manager shows the same values as TS. The core multiplier looks dynamic because I didn't enable turboboost when I took the photos, because screenshotting with that setting on was incredibly slow. My bad. The minimum CPU seems to be 5 * 99 mhz, so it seems that disabling turboboost limits the CPU to the minimum state. https://imgur.com/a/XhEqQfC
     
  8. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,989
    Messages:
    5,757
    Likes Received:
    4,704
    Trophy Points:
    431
    That is not how Intel CPUs work. The minimum multiplier for your CPU is 5 so the minimum speed is going to be 498.84 MHz (5.0 x 99.767 MHz) ~0.5 GHz. For your CPU, there are no multipliers less than 5. That is as slow as your CPU can go. The 5% value in the Windows power profile is merely a request. Your CPU cannot run at 125 MHz so it runs at the slowest possible speed.

    An EPP setting of 128 has proven to cause problems. Your EPP setting of 200 is definitely causing problems. Have you tried setting EPP to 80 yet?

    ThrottleStop appears to be working correctly. It is sending the EPP value that you entered to the CPU. It is up to the CPU to decide what speed it is going to run at based on the settings that you have requested. Perhaps disabling turbo boost while using a high EPP value is a bug within the CPU. If you do not want your CPU stuck at 498 MHz, increase the EPP value and do not disable turbo boost.

    Under volting is no longer working on another laptop model. This time it is the Dell G3-3590-A30P with a 9750H that has lost control of its voltage and the turbo ratio limits. Have you ever wondered, "What would modern laptops be like without under volting?" This year, you are about to find out.

    https://www.techpowerup.com/forums/threads/throttlestop-undervolting-isnt-changing-anything.264262/
     
    Last edited: Feb 26, 2020
    Mari1225 and tilleroftheearth like this.
  9. Mari1225

    Mari1225 Notebook Consultant

    Reputations:
    78
    Messages:
    113
    Likes Received:
    126
    Trophy Points:
    56
  10. Mari1225

    Mari1225 Notebook Consultant

    Reputations:
    78
    Messages:
    113
    Likes Received:
    126
    Trophy Points:
    56
    Ok cool thanks! I got it changed as well :)
     
Loading...

Share This Page