The ThrottleStop Guide

Discussion in 'Hardware Components and Aftermarket Upgrades' started by unclewebb, Nov 7, 2010.

  1. pressing

    pressing Notebook Deity

    Reputations:
    273
    Messages:
    1,801
    Likes Received:
    894
    Trophy Points:
    131
    Two guys on the XPS forum at NBR said the latest BIOS update for the XPS 9550 would not block voltage control. @Techland and @_sem_ thanks.

    Today, I updated XPS 9550 6300HQ BIOS to 1.13.1 and indeed voltage control was not blocked in ThrottleStop (e.g. the offset column on the upper right of FIVR screen showed undervolt as I had entered in FIVR control section).

    Details of BIOS from Dell page"
    File Name: XPS_9550_1.13.1.exe (06 jan 2020)
    File size: 9.83 MB

    "This update addresses the Intel Security Advisories INTEL-SA-00241, INTEL-SA-00260, INTEL-SA-00254, INTEL-SA-00219, INTEL-SA-00220, and INTEL-SA-00270. A security advisory is a statement when a product is impacted by a security vulnerability and a remedy is available."
     
    Last edited: Feb 18, 2020
    Papusan and unclewebb like this.
  2. ole!!!

    ole!!! Notebook Prophet

    Reputations:
    2,385
    Messages:
    5,798
    Likes Received:
    3,716
    Trophy Points:
    431

    asdf1.png


    I also tried changing the speed shift to other values such as 0 and highest value in the settings allows no dice. even with cstate off no luck too. it use to work with older versions.
     
    unclewebb likes this.
  3. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,989
    Messages:
    5,756
    Likes Received:
    4,697
    Trophy Points:
    431
    @ole!!! - Your screenshot shows SST in green which means Speed Shift is enabled. The Set Multiplier function has no control of the CPU multiplier when Speed Shift is enabled so do not check that option. All Intel CPUs have always worked like this so perhaps a recent Windows update or BIOS update has enabled Speed Shift for you. Do you remember enabling Speed Shift in ThrottleStop or in the BIOS?

    When Speed Shift is enabled, the only control over the maximum multiplier is going to be through the Speed Shift Max value in the TPL window. This is a global ThrottleStop setting so you will not be able to set different values for different profiles. Maybe someday.

    You have a beautiful 5.0 GHz - 8 core CPU. Why would anyone want to slow something like that down? That is like making your thoroughbred horse pull an apple cart on his days off between races. Not cool. :vbfrown:

    Seriously though, if you want your CPU to run cooler when lightly loaded, enable the core C states in the bios (C3, C6 and C7). Use a Speed Shift EPP value of 0 and let your CPU run at its full rated speed, even when idle. Use the Windows High Performance power profile. The C states will take care of light load and idle power consumption so your CPU will run cool. If you really must slow your CPU down a little when idle, go with an EPP setting of 80. Combine this with the Windows High Performance power profile and ThrottleStop should be able to maintain EPP at 80. Do some temperature testing to confirm that this is a useful thing to do.

    If you are using the Balanced power profile, you likely have ThrottleStop and Windows constantly fighting over the Speed Shift EPP value that the CPU is trying to use. Open up the FIVR window and have a look at the monitoring table to see who is winning the fight. Most of the time, I think Windows will be in control. Only check the Speed Shift EPP option in ThrottleStop when you are using a Windows power profile that does not interfere with the EPP setting that ThrottleStop is trying to use. The FIVR EPP monitoring data will confirm this.

    People get hung up on seeing low MHz or a low VID value when idle but when the C states are enabled, this is pointless. When a core enters C7, it is basically in a dormant state. It is disconnected from the internal clock so it is sitting there at 0 MHz and it is disconnected from the voltage rail so it is getting 0 volts. Whatever monitoring software is reporting for MHz and volts does not apply to the cores sitting in C7. As long as your system does not have a lot of background junk running on it, you can have individual cores spending as much as 99% of their idle time in C7. Fiddling around with idle MHz and idle VID voltage is not going to improve upon this in any meaningful way.

    I am assuming that you disabled hyper threading in the BIOS on purpose. Make sure CPU-Z reports 8 Cores - 8 Threads.

    Thanks for the screenshot. I always like seeing TS report a perfect 100.000 MHz BCLK value, especially on a CPU that I have never had my hands on. The TS BCLK algorithm reports the measured BCLK without any cheating or rounding of data. That beats the hell out of all those monitoring programs where the supposedly measured BCLK wanders around aimlessly.

    @pressing - Looks like the update you installed does not contain a fix for SA-00289. That is the bad one to watch out for that disables under volting.
     
    Last edited: Feb 16, 2020
  4. ole!!!

    ole!!! Notebook Prophet

    Reputations:
    2,385
    Messages:
    5,798
    Likes Received:
    3,716
    Trophy Points:
    431
    its a bit more complicated on my set up but I tried a bunch of combination including the ones you mentioned such as max turbo at 0, speedstep disabled etc no dice.

    heres a new screenshot with me deleting .ini file and doing a cold shutdown/ startup.


    08.png


    I have window cstate completely disabled and coreparking all turned off. last thing I want is have window control my system. best is to leave everything at max performance in bios + window power profile, then let TS a single software control it so when problem arise it is simple troubleshoot, as well as strike balance for max performance, or max power saving and ease of use, which imo should be the target of every user if they have an unlocked bios.

    as for why I wish to downclock, there are things i wish to do such as test fan cable, laser thermometer the cpu heatsink see the temperature without a fan ruining my measurement. keeping the clocks at say 20x will allow passive cooling. where as 50x will trigger thermal shutdown on a laptop heatsink trying to passive cool it.

    edit: HT disabled through bios.
     
    Last edited: Feb 16, 2020
  5. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,989
    Messages:
    5,756
    Likes Received:
    4,697
    Trophy Points:
    431
    In that screenshot, Speed Shift is disabled. That's good. For Set Multiplier to work, you need to enable SpeedStep. In theory, that should give you control of your multi. Make sure the Non Turbo Ratio is set to 0.

    I like enabling the core C states in the bios. They can reduce temps significantly when lightly loaded and will not hurt performance as long as you set your CPU up so it is running at full speed. With 8 cores, there are probably going to be a lot of time when you are not using all 8 of them. To me it makes sense to have unused cores truly sitting in an idle state.

    Many desktop users hate the C states because they combine them with the Windows Balanced profile. Try enabling the C states in the bios and use them with your CPU set to run at full speed. Compare idle temps and fan noise, etc.
     
    Last edited: Feb 16, 2020
    ole!!! likes this.
  6. ole!!!

    ole!!! Notebook Prophet

    Reputations:
    2,385
    Messages:
    5,798
    Likes Received:
    3,716
    Trophy Points:
    431
    yea in that screen shot it shows running at 48x, but multiplier portion is 44x and even with a brand new .ini file with cold startup, its not working with non max turbo at 0 and speedstep disabled. do you know anything else might be causing this? if i set to 44x, it use to go just 44x.
     
  7. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,989
    Messages:
    5,756
    Likes Received:
    4,697
    Trophy Points:
    431
    That is what is causing this. SpeedStep has to be enabled. Try enabling SpeedStep in ThrottleStop and if that does not work, you will need to enable SpeedStep in the BIOS.

    @pressing - Forgot to ask you. After you updated the BIOS, what microcode version does ThrottleStop report in the FIVR window?
     
    Last edited: Feb 16, 2020
  8. ole!!!

    ole!!! Notebook Prophet

    Reputations:
    2,385
    Messages:
    5,798
    Likes Received:
    3,716
    Trophy Points:
    431
    my original settings is with speedstep enabled lol i think bios is enabled as well let me check again then.

    @unclewebb

    alright man this is messed up, my findings are opposite lol. my bios has speedshift enabled by default and if i leave speedshift off in TS "enable speed shift" box unchecked, I can control multiplier just fine. soon as i check that box and turn on speed shift I can no longer control the multiplier, it just stuck at the cap set in that profile...

    pls help me with your wisdom lol.

    09.png

    10.png

    so first one has speed shift enabled and once box is clicked, it grays out and I cannot uncheck it.. if i do that I can no longer control multiplier until delete .ini and cold shutdown + restart.

    2nd screenshot, I leave that box unchecked in TPL window but I MUST checked those two boxes in red, otherwise multiplier control will not work.
     
    Last edited by a moderator: Feb 17, 2020
    unclewebb likes this.
  9. pressing

    pressing Notebook Deity

    Reputations:
    273
    Messages:
    1,801
    Likes Received:
    894
    Trophy Points:
    131
    Once you enable speedshift you need to turn off the computer to disable it.
     
  10. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,989
    Messages:
    5,756
    Likes Received:
    4,697
    Trophy Points:
    431
    Speed Shift and SpeedStep are two completely different ways to control the CPU speed. For the Set Multiplier function to work, Speed Shift has to remain disabled and SpeedStep has to remain enabled.

    If you use ThrottleStop to enable Speed Shift, the moment you do that, your Set Multiplier setting and the SpeedStep setting are ignored. The only way to disable Speed Shift is you must reboot and make sure Speed Shift is disabled in the BIOS. That is why ThrottleStop shows this setting as grayed out. As soon as you enable Speed Shift, there is no simple way to disable it. Only a reboot will disable it. This is how Intel designed this CPU feature. It is not TS being dumb.

    In your screenshot above, you have checked the Speed Shift EPP box but this is not going to do anything because Speed Shift is disabled.

    You have to use one or the other, not both. You cannot use a combination of the old school SpeedStep and the new and improved Speed Shift. The newer Speed Shift supersedes anything SpeedStep related.

    When ThrottleStop shows SST lighting up in green, Speed Shift is enabled.
     
    Last edited: Feb 16, 2020
    ole!!! likes this.
Loading...

Share This Page