The ThrottleStop Guide

Discussion in 'Hardware Components and Aftermarket Upgrades' started by unclewebb, Nov 7, 2010.

  1. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,815
    Messages:
    6,414
    Likes Received:
    6,729
    Trophy Points:
    681
    Your screenshot shows that you have the Turbo Boost Long Power Max set to 45 Watts and you also have the Clamp option enabled which will force the CPU to throttle below its default speed. Did you do any testing with the Long and Short power limits set higher in ThrottleStop and without the Clamp option being checked?

    I would reboot, don't run XTU or HWiNFO and then fix ThrottleStop. Do some hands on testing with Limit Reasons open to see when throttling kicks in. The TS Bench is probably good enough for this purpose. PL2 should go red first and then PL1 will go red if these power limits are holding your CPU back. I am trying to see if there is a throttling problem or if the problem is because of how you have ThrottleStop setup.
     
    Maleko48 likes this.
  2. yahyoh

    yahyoh Notebook Enthusiast

    Reputations:
    0
    Messages:
    49
    Likes Received:
    6
    Trophy Points:
    16
    i tried to change the PLs under TPL manually, it kinda worked but now cant use the normal power limits 45w PL1 and 56w PL2 as non turbo so its always running at 80w PL2 and 56W PL1 which not ideal. in intel XTU there was no issue.
    the attached files shows when PL1 and PL2 kicks in since the start.
     

    Attached Files:

  3. Rahego

    Rahego Notebook Consultant

    Reputations:
    77
    Messages:
    267
    Likes Received:
    136
    Trophy Points:
    56
    @unclewebb I was posting in other thread but i might try to ask here. Since you're expert - do you have any idea how i can demand static voltage on this one?

    I was trying to reach steady 5ghz with my i7 7700k. But unfortunately no luck so far. So i decided to try something with static voltage. Apparently it is only reason why it keeps crashing. I cant measure exact VID for this clocks with adaptive setting.
    BUT - somehow when im setting it up in throttlestop - it doesn't affect VID at all. It's still same and keeps changing as if it was adaptive.

    Any idea what could be a problem in this case? I heard that MSI somehow could screw us up on this. Other possibility is that im doing something wrong/missing some setup to make it work.

    [​IMG]
     
  4. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,815
    Messages:
    6,414
    Likes Received:
    6,729
    Trophy Points:
    681
    The screenshot you posted is not showing that. It shows PL1 is the reason for throttling and your CPU is running at 44.9 Watts so power limit throttling is keeping the CPU a hair under the 45 Watt limit.

    [​IMG]

    The other screenshot you posted shows that none of the boxes are red in Limit Reasons. This means at that moment, the CPU is not throttling due to power consumption. Your CPU is running slightly slower than its maximum speed but I think this is because of your Speed Shift setting. You can open up the FIVR window at any time and in the monitoring table at the top right, it will show you what EPP value your CPU is using in real time. If Speed Shift EPP is set to 128, some CPUs will not be able to reach their rated maximum speed when bench testing. If you are using the Windows Balanced power profile, this can reduce your Speed Shift EPP setting to a less than optimum value.

    Windows 10 has a bad habit of hiding some of the power profiles. You can still access the Windows High Performance power plan by opening up a command window and using this command.

    powercfg /s SCHEME_MIN

    To go back to the Balanced power profile you can enter this command:

    powercfg /s SCHEME_BALANCED

    When testing, go by what ThrottleStop is showing you. Ignore HwINFO and Intel XTU. After you make a change with ThrottleStop, XTU will not show you the change. You might also need to restart HWiNFO after making some changes with ThrottleStop.
     
  5. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,815
    Messages:
    6,414
    Likes Received:
    6,729
    Trophy Points:
    681
    @Rahego - Some desktop boards feed voltage directly to the CPU so the VID signal is ignored. That means the CPU will get its voltage based on what you have set in the bios and anything voltage related you try to set in ThrottleStop will not do anything.

    Some Asus boards have a bios option that lets you determine if the VID signal should be used or not. I cannot think of their name for this at the moment. MSI might have a similar bios option. For a fixed or static voltage, I would just enter this info into the bios.

    If you want a steady multiplier when idle, you will probably need to disable your C states (C3, C6, C7). That might be holding you back from getting the 50 multiplier.
     
    Last edited: Jul 25, 2019
    pressing, joluke and Rahego like this.
  6. yahyoh

    yahyoh Notebook Enthusiast

    Reputations:
    0
    Messages:
    49
    Likes Received:
    6
    Trophy Points:
    16

    I dont think you understand what i meant, these screen shoots in turbo mode and throttlestop is holding back the PL1 to 45 watt as if the turbo mode is not working, in 1st screen shoot its limiting the power to just 56 watt as non turbo PL2 instead of 80watt and 2nd screenshots shows how its limiting the PL2 to 45watt after the 28sec window

    the helios 300 2019 has 2 power limits modes

    1- normal PL1 45 watt and 56 watt PL2
    2- turbo PL1 56 watt and 80 PL2

    but the issue when running throttlestop the system wont able to change the power limits it will be always stuck at 45,56watt limits till i restart the machine and not use throttlestop, on the other hand XTU doesnt cause such issue
     
  7. 4W4K3

    4W4K3 Notebook Evangelist

    Reputations:
    73
    Messages:
    452
    Likes Received:
    208
    Trophy Points:
    56
    Trying to find out why I've lost all C-States? I'v changed my Windows power plan to all defaults, it's just sitting in C1? Scratching my head...

    I noticed because it's idling around 50C where it used to idle 38C. It would also enable C3, C6, and C7 on idle. But now it's not?

    noC.png

    One of the only changes I can think I'v made is updating my nVidia graphics a few days ago. And I can't be sure eactly when this happened. I literally just noticed today. Ugh...could it be that? I guess I could try to rollback.

    Ugh I am averaging 8W draw on idle??? WTF is going on? It used to be near 0.8W

    I rolled back nVidia driver with no luck. Very perplexed, and would appreciate any input. Had perfectly accessible C3, C6, C7 states days ago and now they are all gone. Would re-installing ThrottleStop possibly change this? Grasping at straws here...

    This is probably asking a lot but if anyone knows any specific registry attributes that control enabling and disabling c-states? Perhaps I have unknowingly changed one of these while working with ParkControl?

    I suppose my last resort will be to fully Reset Windows and hope the registry values all go back to default. Unfortunately, I'm pretty sure I never made a backup.
     
  8. Er0ck

    Er0ck Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    6
    Was wondering if someone could provide a little help with a project I am working on. I have a system with a Gemini Lake N4100 in it that I have done a fan mod to it that keeps it very cool. I already removed the TDP time limits and increased the Watts and now both the GPU and CPU are running at 700 mhz and 2400 mhz respectively with no throttling. Had to find an extra place outside of the MSR where it also had a throttle set but got that removed finally. After going through the Intel papers and doing some research, it appears that the GPU speeds are writable and can be increased. With what I am using it for this would be a big boost as I have a decent amount of CPU headroom but would love to see if I could get the GPU speed increased a bit. I am not sure if it could be accessed via a memory dump in RW or in MMIO, and have no idea how to enter the correct address or offsets in the Intel papers in RW. Here is a quote from a forum where a guy basically was trying to do the same thing with the Apollo Lake SOC which is basically the same silicon as mine.

    https://www.overclockers.com/forums...ange-ratio-on-Apollo-lake-soc-and-intel-HD500

    Not sure if this is the exact place that I would need to change it, I guess there would be maybe a few different ways to do it. But to me removing the maximum MHZ limit and increasing the multiplier might be the way to do it, or simply increasing the multiplier on its on so it could go over the 700 mhz limit. Already seen huge improvements in performance in the programs I am running, but as they tax the gpu to 100% it would be nice if I could use some of the headroom to bump up the mhz a bit more on that. Not sure if it's possible or not, but any help would be greatly appreciated.
     
  9. Er0ck

    Er0ck Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    6
    You didn't somehow disable C states in the bios by chance did you?
     
  10. Er0ck

    Er0ck Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    6
    Does anyone have any idea why I have getting all 0s in RW for memory addresses FED10000 and FED15900? Again I am on a Intel Gemini Lake N4100 cpu with 8 gigs of ram, can't understand why they are not showing up! *EDIT* I am guessing the memory is mapped completely differently here than the rest of the Intel family, anyone got any clue where these might be?

    [​IMG]
    [​IMG]
    [​IMG]
     
    Last edited: Jul 27, 2019
Loading...

Share This Page