The ThrottleStop Guide

Discussion in 'Hardware Components and Aftermarket Upgrades' started by unclewebb, Nov 7, 2010.

  1. pressing

    pressing Notebook Deity

    Reputations:
    252
    Messages:
    1,729
    Likes Received:
    828
    Trophy Points:
    131
    I don't think you warped the heatsink. However, Dell has sold a lot of warped heatsinks. It seems Dell stepped up their game with some of the more recent 9570s. Getting individual CPU core temperatures close during stress testing is a good clue that your heatsink is flat and thermal paste application is thin, even, and with complete coverage.

    Once you remove the heatsink, you need to clean the thermal paste and reapply. This is the best way to assure your repaste is spreading thin, evenly and completely. This is a popular method.

    Trust no one. Test for yourself and verify. Part of the problem is wide factory variance in CPUs, heatsinks, and thermal paste application. Part of the problem is that some owners are more careful about thermal mods.
     
    Papusan likes this.
  2. TSE

    TSE Notebook Deity

    Reputations:
    233
    Messages:
    884
    Likes Received:
    14
    Trophy Points:
    31
    Oh, I see what you mean now - the individual CPU core temperatures vary a lot. This for sure isn't normal? Should I maybe just try to remove my thermal paste job and redo it and see where it goes?

    I'll have some time tomorrow to work on this- both the thermal paste and thermal pad work.

    On a semi-related note, my battery life has gone to hell and my fans keep spinning up and down no matter what since yesterday - I suspect when I installed Dell Power Management tool. I think I need to do a fresh install as well, because even when I uninstalled it I am having the same issues. Ugh.

    Thanks for the help.
     
  3. pressing

    pressing Notebook Deity

    Reputations:
    252
    Messages:
    1,729
    Likes Received:
    828
    Trophy Points:
    131
    No. Run a CPU benchmark for a while, like Prime95. Look at real-time core temps on the main window of ThrottleStop. If all cores have similar temps when running all cores of the CPU hard for a few minutes, then your thermal paste distribution is probably even and your heatsink is probably flat.

    If you see real-time core variances that are large during benchmarking, consider additional steps, like inspecting your paste job, cleaning and repasting.

    Dell Command I Power Manager allows you to change fan scheme. Go to "thermal management" tab and select "optimized" or "quiet". When you uninstall, I think the settings stick but can't remember to be frank.

    Also you can boost battery life with SST (ThrottleStop main window) higher. I run around 80 for everyday use but 255 might give you even better battery life.

    You can bring these XPS thermal questions to the Dell forums as they are not so ThrottleStop related. http://forum.notebookreview.com/forums/dell-xps-and-studio-xps.1049/
     
  4. illuzn

    illuzn Notebook Consultant

    Reputations:
    56
    Messages:
    140
    Likes Received:
    71
    Trophy Points:
    41
    May I just say @unclewebb how much I miss and appreciate Throttlestop now its gone.

    I've upgraded to Windows 1903 and winring0.dll no longer works as previously mentioned. Laptop runs hotter than ever with fans on for a significantly longer time and I've lost around an hour of battery life.

    Thank you for all of your hardwork over the years - I know this is all of your control but I just wanted to wish you all the best and thank you for my past few years as a satisfied "customer" :)
     
  5. TSE

    TSE Notebook Deity

    Reputations:
    233
    Messages:
    884
    Likes Received:
    14
    Trophy Points:
    31
    That's a damn shame if true! Is there going to be a work around? Intel XTU has nothing on Throttlestop. :)
     
  6. illuzn

    illuzn Notebook Consultant

    Reputations:
    56
    Messages:
    140
    Likes Received:
    71
    Trophy Points:
    41
    It's reported further up in this thread but this is the exact error I receive:

    2019-04-15.png

    I have tried everything including a clean install and completely disabling UAC but it doesn't help as far as I'm aware.

    Agreed - XTU is so bloaty compared to the lightweight, fast and effecient TC.
     
  7. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    7,290
    Messages:
    10,365
    Likes Received:
    7,631
    Trophy Points:
    931
    I'm using TS on 19H1.30 build w/o any issues. Do one thing; Copy TS's ini file somewhere and delete the folder and re-create the folder on another drive. I think Win 10 wrecked the permissions. They do it from time-time.
     
    joluke and c69k like this.
  8. illuzn

    illuzn Notebook Consultant

    Reputations:
    56
    Messages:
    140
    Likes Received:
    71
    Trophy Points:
    41
    Edit: Ignore this post - my last point triggered a few cogs in my memory and I figured it out. I'm leaving this here in case some of the diagnostic information is helpful to somebody.

    This is not working on Windows 10 Pro Build 18362.53 (x64).

    Exact instructions I'm using:
    1. Download fresh copy.
    2. Using windows explorer/ 7-zip extract to a new folder on a secondary drive (the drive is not formatted with NTFS like my boot drive).
    3. If using windows explorer, manually go to folder and unblock downloaded files (right-click properties, uncheck the block).
    4. Run TS 8.70.6

    I am not trying to restore my existing settings at this stage in order to isolate the problem.

    Are you perhaps running a different flavour of Windows 10 (enterprise/ home)? Have you changed any of the windows security settings?
     
    Last edited: Apr 15, 2019
  9. illuzn

    illuzn Notebook Consultant

    Reputations:
    56
    Messages:
    140
    Likes Received:
    71
    Trophy Points:
    41
    I'm replying in a new post for visibility. @unclewebb would you please sticky this to the first post for visibility.

    This applies to people who are receiving this error on trying to start TS 8.70.6 on Windows 10 Pro 19H1 Builds (as of writing Building 18362.53):
    2019-04-15.png

    I've cracked the problem. Users who who purchased their computer after the Fall Creators Update have Windows 10's Memory Integrity Enabled by default. Throttlestop obviously changes system memory registers and Memory Integrity likely blocks this function. Read more about memory integrity.

    NOTE: Turning of Memory Integrity is a serious matter. Do not turn it off if you do not understand what you are doing. You may not be able to turn off Memory Integrity if your computer is joined to a corporate domain. Turning off memory integrity may violate your workplace's IT security policies.

    The easiest way to disable memory integrity is via Windows Security as follows:
    1. Double click windows security in the tray or run it by searching for it by name.
    2. Select the Device Security Tab.
    3. Select "Core Isolation Details"
    4. Toggle off "Memory Integrity"
    5. Follow the prompts to restart your computer.
    6. Throttlestop should now run as intended - if not try the usual recovery steps: (1) move the throttlestop.ini folder somewhere else to reset settings and (2) try a fresh install.
     
    4W4K3, magnetoeric, joluke and 7 others like this.
  10. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,673
    Messages:
    5,598
    Likes Received:
    4,283
    Trophy Points:
    431
    @illuzn - Thanks for your detective work. I included a link to your post above in the first post in this thread. It is near the top so it will be easy to find.

    Update 2:

    I toggled Memory integrity on, rebooted and ThrottleStop started OK. I do not have any problems with the WinRing0 driver whether Memory integrity is on or off. This is while using Windows 10 - 1809.

    Starting with Windows 10 - 19H1, it looks like the Memory integrity setting can completely block the WinRing0 driver which will prevent ThrottleStop from starting.

    If Memory integrity is enabled, I do see a bug where ThrottleStop reports 0.00 MHz. I assume that TS cannot calculate this correctly without having memory access.

    I also discovered that having the Memory integrity setting set to On, prevents the ThrottleStop FIVR - Disable and Lock Turbo Power Limits feature from working correctly in Windows 10 - 1809 and likely any newer Windows versions.

    I get this error.

    Error starting service: A certificate was explicitly revoked by its issuer.

    [​IMG]
     
    Last edited: Apr 16, 2019
    4W4K3, Papusan, Vasudev and 1 other person like this.
Loading...

Share This Page