The Official MSI GT73VR Owners and Discussions Lounge

Discussion in 'MSI Reviews & Owners' Lounges' started by -=$tR|k3r=-, Aug 16, 2016.

  1. hmscott

    hmscott Notebook Nobel Laureate

    Reputations:
    5,074
    Messages:
    17,793
    Likes Received:
    21,820
    Trophy Points:
    931
    Oh, oh... maybe MSI is defaulting the X Boost enabled again? This was enabled by default the first time it was shipped (2016), but MSI changed that in the next release to default to disabled. Keep it off.

    From closed thread:
    http://forum.notebookreview.com/threads/what-is-msi-xboost.800919/#post-10448313

    It's explained in this video (starting at 3:50):

    Long story short: you should probably disable both X-Boost options if you care about keeping CPU usage down.
    disable XBoost - both.JPG
     
    Last edited: Mar 7, 2018
    Djadit likes this.
  2. Shehary

    Shehary Notebook Deity

    Reputations:
    292
    Messages:
    876
    Likes Received:
    1,247
    Trophy Points:
    156
    Or you should install the latest Dragon Center 1.2.1802.0501 with following note
    1. Update the APP download QR code for Dragon Dashboard.
    2. Update Help Desk version to 1.2.1802.0501.
    3. Remove X Boost to improve the system stability.
    Due to the changing software specification, the latest Dragon Center will remove and stop maintaining the X Boost feature; if you’d like to have the X Boost feature, please download and install the Dragon Center version1.2.1801.2401.
     
    Last edited: Mar 7, 2018
    Ultra Male and hmscott like this.
  3. Djadit

    Djadit Notebook Evangelist

    Reputations:
    93
    Messages:
    416
    Likes Received:
    152
    Trophy Points:
    56
    Thanky you
    I have installed it
    whether the xboost feature still appears in your dragon center?
    I still see xboost feature on the latest dragon center

    Sent from my CPH1723 using Tapatalk
     
  4. Shehary

    Shehary Notebook Deity

    Reputations:
    292
    Messages:
    876
    Likes Received:
    1,247
    Trophy Points:
    156
    No, in latest Dragon Center, No more x-boost option.

    Uninstall DGC and delete the left over files manually and Install the latest version.

    How to update DGC

    Read Manual Update & Installation section, Refer to Point 3
     
    Djadit likes this.
  5. Patrick Star

    Patrick Star Notebook Enthusiast

    Reputations:
    6
    Messages:
    11
    Likes Received:
    4
    Trophy Points:
    6
    Hi everyone, my laptop has come (GT73VR TITAN PRO 4K 479)
    So far so good, no defect at all
    OC'ed the CPU 4GHz on stock thermal paste no problem, thermal is good, but sometimes the GPU fan is quite loud
    Games run GREAT (my previous laptop use GT745M so.... this is,,, so... EXCITING XD)

    Here is some problem tho:
    1. The laptop keep telling me to activate windows, and says the key is wrong, how to fix this? some clue: the box says it come with win 10 pro but the one installed is win 10 home, will clean install fix this
    2. The color of the screen is too warm/yellowish for my taste, anyone know how to adjust this? because the other color setting on dragon center are also yellowish
    3. sometimes when bootup, the lighting on the keyboard back to the brightest light level, instead of the previous one I set, any idea to fix this?

    The last but not least, I wanna ask for suggestion. My model come with 256GB SSD, I will probably format it 200GB for Windows (and games), 40GB for linux(adn work).
    Should I put games on SSD or HDD with that capacity?


    Thanks in advace everyone :D
     
    hmscott likes this.
  6. Ultra Male

    Ultra Male Super Tweaker

    Reputations:
    16,614
    Messages:
    18,500
    Likes Received:
    26,052
    Trophy Points:
    931
    Go to PC Settings > Update & Security > Activation > then click on Change Product Key and enter your Windows 10 Pro key to upgrade from Home to Pro

    for the color, right click on the desktop, choose MSI True Color, then try a different color profile.

    I like designer at night as it's easier on the eyes but sRGB is good for every day use.

    I don't know about the keyboard because I always have it on the brightest level [​IMG]

    With that kind of capacity, put the games on the HDD. You have no space dude. put a game or two and your SSD is full so rather than having them all unorganized and install some games on C: and others on D:, just install them all on D:. Also, when you are installing Steam or Origin, make sure you select D:\Program Files (x86) as the destination rather than C: that way, the games will install on D: by default

    [​IMG]
     
  7. Shehary

    Shehary Notebook Deity

    Reputations:
    292
    Messages:
    876
    Likes Received:
    1,247
    Trophy Points:
    156
    Caused by Dragon Center (DGC)

    in DGC, go to Led Wizard, disable Led Wizard (remove check)

    Run SteelSeries Engine 3 and Click on MSI GT73 , manage keyboard color and brightness. Keep Led Wizard disable in DGC
     
    Ultra Male likes this.
  8. Ivan994

    Ivan994 Notebook Consultant

    Reputations:
    95
    Messages:
    214
    Likes Received:
    189
    Trophy Points:
    56
    Hello guys,

    I have problem with my GPU USAGE. I think when I had Dragon Centar I did not have this problem. In for example Witcher 3 my GPU usage is from 75 to 99 % but in new NFS it is around 65 to 85 %. How could I make it to be all the time 99 %? Maybe is 1080 p bottle neck for GTX 1080? But, how I remamber I have not had this problem in the past. I put in Nvidia control panel high performance and nothing changed.
     
  9. Shehary

    Shehary Notebook Deity

    Reputations:
    292
    Messages:
    876
    Likes Received:
    1,247
    Trophy Points:
    156
    cannot compare GPU usage of 2 different games

    Witcher 3 is very GPU demanding game where as new NFS is not and if you wana push the GPU to 99% you have to make changes in game setting and push them to Max...if your game setting already Maxed out and still GPU usage is 65 to 85% than that's the usage is required by the game and no matter what you do you cannot push it 99% because game doesn't need it.
     
    Pedro69 and Ivan994 like this.
  10. Ivan994

    Ivan994 Notebook Consultant

    Reputations:
    95
    Messages:
    214
    Likes Received:
    189
    Trophy Points:
    56
    I thought that if your GPU is not on 99 % all the time something is bottleneck. All my games are on max settings. I tried 3-4 games and only on shadow of mordor I have my GPU running at 99 % all the time. Could you please test for me 3-4 games and tell me your GPU usage is 99% all the time or is always changing from 60% to 99%.

    thanks mate :D
     
Loading...

Share This Page