The Official MSI GS73VR Owners' Lounge

Discussion in 'MSI Reviews & Owners' Lounges' started by NHF, Aug 23, 2016.

  1. Derek712

    Derek712 Notebook Virtuoso

    Reputations:
    460
    Messages:
    2,558
    Likes Received:
    990
    Trophy Points:
    131
    It'll easily have your needs
     
    Ultra Male likes this.
  2. CaptCurt

    CaptCurt Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Is there a good Mouse you can recommend? I Don't game, just edit photos & videos.
     
  3. Derek712

    Derek712 Notebook Virtuoso

    Reputations:
    460
    Messages:
    2,558
    Likes Received:
    990
    Trophy Points:
    131
    I personally use the Logitech g700 for both work and games.
     
  4. rfdub

    rfdub Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    I recently purchased a refurbed GS73, which came with the 60hz 1080p IPS panel, which I immediately swapped out for what seemed like a legit AUO 4K panel I purchased from Newegg, but now I've got this really weird and annoying issue where any dark areas in any videos look blocky / artifacty and show really bad color banding. It basically makes watching video on this thing impossible. Another user mentioned a similar problem way back on page 36 and then again on page 39 where he said a service centre "flashed an eeprom" as the motherboard thought the laptop had the wrong panel, so I tried updating the bios with the bios from the 4K version off the MSI site, which did make the logo at boot nice and crisp, but unfortunately hasn't fixed my issue. So, any ideas on what I could try next? I really wanted the 4K panel for graphics work, and couldn't afford the 4K version, so please don't suggest I just buy the 4K version. Any advice would be greatly appreciated!
     
  5. rfdub

    rfdub Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    I was able to fix it myself in an incredibly dumb way. Even through I'd removed and reinstalled both the GTX 1060 and HD 630 drivers twice already, I used Display Driver Uninstaller to remove and reinstall both drivers again and the issue is completely fixed. To be honest this is my first Windows machine after almost a decade of being a Mac user, and while I did used to build my own PCs back in the day, this was such a classic reintroduction to the wonderful world of Windows. Buy a refurbished machine, DIY replace the panel, get weird drivers issues, reinstall a bunch of times, then *really* reinstall and it finally, gloriously works.
     
  6. unpilot

    unpilot Notebook Consultant

    Reputations:
    65
    Messages:
    275
    Likes Received:
    125
    Trophy Points:
    56
    For some reason my SD card reader will not ...well read. I put in a sd card and nothing.
    The weird thing is it also does not work in my other MSI laptop.
     
  7. Ultra Male

    Ultra Male Super Tweaker

    Reputations:
    16,773
    Messages:
    18,554
    Likes Received:
    26,148
    Trophy Points:
    931
    Maybe the SD card itself is corrupted? Try another SD card
     
  8. Ultra Male

    Ultra Male Super Tweaker

    Reputations:
    16,773
    Messages:
    18,554
    Likes Received:
    26,148
    Trophy Points:
    931
    SteelSeries Rival 310 or Rival 600

    You don't even need to install a driver for them since they share the same SteelSeries Engine that is used by your laptop's SteelSeries Keyboard [​IMG]

    See if Donald can source them for you to include it in the box
     
  9. votehart

    votehart Notebook Enthusiast

    Reputations:
    20
    Messages:
    41
    Likes Received:
    25
    Trophy Points:
    26

    Any chance can provide a link to Newegg to the panel you purchased? Has it held up ok and how difficult was the installation?
     
  10. Saldeban

    Saldeban Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Hi,

    I recently purchased a GS73VR 7RF. I have updated all the drivers that were not up to date in the device list.
    I want to get the machine running well from the start so that I don't encounter problems straight away.

    I am hoping some experienced owners can share their tips. Any help would be greatly appreciated and I will try to share any issues/fixes in the future.

    Does anyone have any advice on the below:
    • What bloatware to remove
    • What anti-malware/spyware software to install/buy
    • How to get the best performance on the 256GB SSD drive and the 2TB HDD drive
    • How to read from SD cards and USB sticks faster (Would a fast card reader attached to the USB3.1 or thunderbolt port increase transfer speeds?).
    • Any other tips to optimise performance, display, battery calibration for example

    Thanks
     
Loading...

Share This Page