*** The Official 2019 MSI GS65 Stealth with RTX GPUs Owners and Discussions Lounge ***

Discussion in 'MSI Reviews & Owners' Lounges' started by JRey, Jan 25, 2019.

  1. Thysanoptera

    Thysanoptera Notebook Consultant

    Reputations:
    26
    Messages:
    164
    Likes Received:
    46
    Trophy Points:
    41
    Optimus set to iGPU by default, I tried all power settings. That is happening even without eGPU connected - I’m traveling this week.

    I just loaded the drivers from MSI again and sure enough everything is back to normal, idle in the 30’s with GPU fan off as opposed to 50’s with fan @3k rpm.
     
  2. Mikhailovich Liovsky

    Mikhailovich Liovsky Notebook Enthusiast

    Reputations:
    12
    Messages:
    44
    Likes Received:
    30
    Trophy Points:
    26
  3. atxtonyc

    atxtonyc Notebook Enthusiast

    Reputations:
    0
    Messages:
    22
    Likes Received:
    6
    Trophy Points:
    6
    I have been and am noticing the same thing. For me, the dGPU never goes off (orange light is always on) and temps are settle around 50 even when CPU is at 0%. I haven't had the time to work through what's going on.
     
    Michael A. Saldana likes this.
  4. atxtonyc

    atxtonyc Notebook Enthusiast

    Reputations:
    0
    Messages:
    22
    Likes Received:
    6
    Trophy Points:
    6
    Good to know, I'll give this a try.
     
  5. ctlaltdefeat

    ctlaltdefeat Notebook Enthusiast

    Reputations:
    0
    Messages:
    18
    Likes Received:
    4
    Trophy Points:
    6
    Regarding the dGPU not powering off when it's not in use, I suspect it may be because something used its RAM and didn't properly clear it, and so Optimus can't power off the GPU for fear of losing the memory. Try disabling and re-enabling the dGPU with the device manager, waiting for a few secs, and seeing if the light turns white.
    That's what happens in my case, anyway, so I bound powershell commands to a hotkey that disables and re-enables the dGPU. It has to run with Admin privileges:

    Code:
    Get-PnpDevice | where {$_.friendlyname -like "*nvidia geforce rtx*"} | disable-pnpdevice -confirm:$false
    Get-PnpDevice | where {$_.friendlyname -like "*nvidia geforce rtx*"} | enable-pnpdevice -confirm:$false
    
     
  6. atxtonyc

    atxtonyc Notebook Enthusiast

    Reputations:
    0
    Messages:
    22
    Likes Received:
    6
    Trophy Points:
    6
    Yeah, I did notice in Process Explorer that some apps were holding onto dGPU memory. I'll give this a try, and thanks for the Powershell script.
     
  7. Thysanoptera

    Thysanoptera Notebook Consultant

    Reputations:
    26
    Messages:
    164
    Likes Received:
    46
    Trophy Points:
    41
    Now I have messed up something, the orange light goes on as soon as laptop starts (white is on for maybe half a second right after pressing power button on cold boot), doesn't go off at all, whether the dGPU is disabled in device manager or not. GPU-z doesn't report dGPU sensors (temp 0C, dashes for clocks) but I can feel the bloody thing warm plus it heats up the CPU. It looks like when dGPU is disabled the Silent Option shows iGPU temp.
     
  8. jelenn

    jelenn Notebook Enthusiast

    Reputations:
    2
    Messages:
    37
    Likes Received:
    13
    Trophy Points:
    16
    I'm using them - no problems. White led when dGPU isn't active and temperature about 33*C right now.
     
    Thysanoptera likes this.
  9. Thysanoptera

    Thysanoptera Notebook Consultant

    Reputations:
    26
    Messages:
    164
    Likes Received:
    46
    Trophy Points:
    41
    Thanks, I'll keep messing around then. What version of drivers do you use, number and gamers/creators?
     
  10. jelenn

    jelenn Notebook Enthusiast

    Reputations:
    2
    Messages:
    37
    Likes Received:
    13
    Trophy Points:
    16
    419.67 DHC
    Without nvidia experience.
     
Loading...

Share This Page