The offical micro-stuttering casualties threat (gs40,43 and 63 vr)

Discussion in 'MSI' started by Mixsez, Oct 7, 2016.

  1. Mixsez

    Mixsez Newbie

    Likes Received:
    Trophy Points:
    Hello and Welcome!
    I just got my MSI gs63vr, it is a great machine, although I find one major flaw in it, which is the micro stutters.
    After a Google search that included every keyword possible, I was not able to find a solution, but I found out that gs43vr and gs40 users also experience it.

    The issue
    It mostly appears after a reboot, it comes in a form of a 1-second freeze and audio lag if you play any music or watch YouTube. The lags are random, but I think that I found a way to force it by going to Desktop > Right click > Display settings. If you had a little lag, you're welcome.
    I'm sure that it is related to Nvidia Optimus or it's components (iGPU \ dGPU \ Software), here's why:
    GS63VR's (don't know about the 43's) have that power indicator above the keyboard, which ,if you watch carefully change it's color to orange while the nGPU kicks in. By that, every time that I the led tinted orange, there isn't any stutter at all.
    "falconwolf703" from Reddit made a video demonstrating

    The kinda fix - inspired by "hmscott"
    Basically, force the 1060 to work full time, you can do it by using Inspector. (Another temporary solution is to right click on any program and press start and use the dGPU or uninstall Nvidia Drivers altogether, it will remove Optimus, the GPU will work, which will make to problem disappear, but it just for testing purpose).
    I wrote "kinda fix" since it isn't what we should get by paying this high amount of money over a laptop. We don't have G-sync because of Optimus and the laptop will run a bit hotter and louder with the GPU, because of that, since it's already there, the feature should work flawlessly.
    Nahamic and ELAN are both mentioned in hmscott's comment, I haven't tried to uninstall them, I don't think they collide with Optimus.

    The real solution

    I posted this that in case that somebody will know how to fix it or MSI \ Nvidia see how many people have this issue and they would release a fix. MSI's tech support guy wasn't aware of this problem.

    Thank you

    Update #1
    I just noticed that on the second the I press Display settings the led turns orange for a second, which suggest that the stutter caused by Optimus, which activate the GPU for a second for the operation, I guess that it is related to the sensibility of the feature, I also guess the only Nvidia are able to tweak that.

    Update #2
    BIOS and Firmware update didn't help
    And, as seen on this old video by Nvidia, the dGPU SHOULD kick in while games are not being played, so it's not Optimus's sensitivity
    Last edited: Oct 7, 2016
    Vasudev, hmscott and MiSJAH like this.
  2. stekorghif

    stekorghif Notebook Enthusiast

    Likes Received:
    Trophy Points:
    On my GS43VR (which I returned because it had other issues), setting the preferred graphics processor in Nvidia Control Panel to the Nvidia card solved the microstutters. More information here
    hmscott likes this.
  3. hmscott

    hmscott Notebook Nobel Laureate

    Likes Received:
    Trophy Points:
    I thought the whole text would be good to have here to comment on, as the question was asked here for a wide range of models.

    Maybe when you get a final fix well worded and put together in final form, someone can post that fix to all the related Owners Lounges? :)
  4. jrgn

    jrgn Newbie

    Likes Received:
    Trophy Points:
    Hi all,

    I had/have micro stutter on a brand new GE62 7RE(gtx1050 ti / intel 630).

    I spend days & nights looking for a conclusion/solution.

    What I managed to learn so far:

    This so-called micro stutter is caused by frame corruption while streaming the frames from the GPU to the IGP(integrated). In older technologies the GPU would stream directly to output, and this did not happen. But wehn switching back and forth between IGP & GPU the screenn would go black for a blip when switching. Optimus introdiced the so-called frame buffer that streams the video toward the IGP, which in turn sends it to output.

    For a refernce look for micro stutter wiki.

    Another interesting thing is that this mostly happens when you have parallax motion(different distances) of objects. When you are in the middle of a room with no pillars, it doesn't stutter. No idea why.

    Anyway... After trying a zillion of workarounds and tweaks, I finally solved it by this:

    - Fresh installation of Windows 10
    - I installed only official drivers by Intel & Nvidia, none of the MSI QA'd stuff(chipset, wlan, bluetooth, video, MEI-driver only, and geforce driver + physics).
    - I ran windows update to get drivers for everyting else, and then clicked 'update driver' for all devices in device manager.

    Since then I am micro stutter free.

    Hope this can help a few casualties :)

    Last edited: Feb 23, 2017
    hmscott likes this.
  5. stealthpro4ko

    stealthpro4ko Notebook Enthusiast

    Likes Received:
    Trophy Points:
    The issue as described in the original post (1-second freeze when going to Desktop > Right click > Display settings) is a well known problem now. See the following links:

    The stutter or brief freeze is still an issue with Windows 10 Fall Creators Update. So far the only thing that worked for me is to keep the dGPU running in the background. This tool does exactly that but with minimal resource consumption. Please let me know if it helps you as well. More details at https://github.com/jobeid/TrayPwrD3.
    alaskajoel likes this.

Share This Page