***The MSI GS60 Ghost Pro 970M Owner's Lounge***

Discussion in 'MSI Reviews & Owners' Lounges' started by charliex3, Oct 7, 2014.

Thread Status:
Not open for further replies.
  1. Derek712

    Derek712 Notebook Virtuoso

    Reputations:
    462
    Messages:
    2,574
    Likes Received:
    998
    Trophy Points:
    131
    I think it's safe to assume it'll work with most MSI laptops with thunderbolt 3. I was able to get it to work with both the GS63vr and gs73vr as well.
     
  2. Spunky90

    Spunky90 Notebook Enthusiast

    Reputations:
    20
    Messages:
    42
    Likes Received:
    6
    Trophy Points:
    16
    I heard that is a common issue with the keyboard but I have one squawking key. Is there a how to fix guide? I have disassembled the key however I could not find anything wrong with it :(. It definitely makes different sound when pressed then the rest of the keys.
     
  3. Derek712

    Derek712 Notebook Virtuoso

    Reputations:
    462
    Messages:
    2,574
    Likes Received:
    998
    Trophy Points:
    131
    How did you disassemble the key?
     
  4. wolfstone

    wolfstone Notebook Enthusiast

    Reputations:
    1
    Messages:
    35
    Likes Received:
    2
    Trophy Points:
    16
    Hi just got a GS60 QD. ghost yesterday ,
    Skylake I7 8 gb ddr4 (2133)
    256 m2 and a gtx 965? I thought they had 970 in?
     
  5. Kyrne

    Kyrne Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    I believe it depends what retailer you bought it from.

    When i was buying mine I had the choice of 2 different version of the 970m (3gb / 6gb)
     
  6. mystycs

    mystycs Notebook Evangelist

    Reputations:
    0
    Messages:
    334
    Likes Received:
    0
    Trophy Points:
    30
    Anyone know about, or know of a solution to fix the black horizontal line flickering on the MSI GS60?

    An example vid below:

     
  7. carmamir

    carmamir Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    5
    Any one knows anything about screen flickering in GS60 2QE (GTX970M) ??

    I have noticed that just Today, updated BIOS but didn't helped (while at first I have noticed it on dark background website, after BIOS update I am not able to replicate this issue on a website, I was able to replicate flickering screen on Dirt Rally (after 3-4 minutes of playing on ultra).

    Is it the issue with a cable ? (secondary screen was free from any flickering)

    I just wondering if that is simply a case of ordering a new cable and fitting it or maybe the issue is with motherboard ???


    Is there any consensus to the reasons of this issue ???
     
  8. Yippee38

    Yippee38 Notebook Enthusiast

    Reputations:
    0
    Messages:
    30
    Likes Received:
    2
    Trophy Points:
    16

    I appreciate the write up. I was all ready to heap praise upon you for finally helping me to get Win7 installed on my Ghost Pro. However, it just gives me a BSoD with the "stornvme.sys" error message before it even starts installing. <sigh> I'm at the point where I'd pay to have this done for me.
     
  9. Aryemis

    Aryemis Notebook Enthusiast

    Reputations:
    0
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    5
    The cable may simply not be well seated.
    If you are familiar with taking apart laptops, you could open it up to check for that, it's not that hard if you've done it before.

    I recently opened mine up completely to clean the fans and repaste the CPU (ended up repasting the GPU as well because the heatsinks are connected).
    Mine is a year and a half old and had never been cleaned before that, it was hitting 95°+ in Overwatch and thermal throttling pretty hard (even when limited to 3Ghz, and CPU fan at full blast).
    Now after an hour of prime95 the CPU is at 80°C (with less fan speed), at 3.2Ghz (power limited).
     
  10. moussa247

    moussa247 Newbie

    Reputations:
    2
    Messages:
    8
    Likes Received:
    1
    Trophy Points:
    6
    Hey, proud new owner of a GS60 6QE here, would appreciate any help. Sometimes my laptop just doesn't boot when its been off for a while and I have to wait, I seem to be having the same issue as this person http://www.tomsguide.com/answers/id-2942400/msi-gs60-6qe-wont-boot.html
    Would love to hear any advice, for now I have disabled fast boot and I'm gonna see if the problem reoccurs. Thank you!
     
Thread Status:
Not open for further replies.

Share This Page